Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex6500 default audio

Mark_WS7M
Mark_WS7M Member ✭✭✭
edited February 2019 in FLEX-6000 Signature Series
Hi All!

I received my upgrade flex6500 LATE friday night.  I figure I must have been the very last UPS delivery of the day...

Anyway I was using a flex6300.  Because the radios are so similar I decided to leave SSDR installed and just setup the new radio.  I didn't change anything.

Typically, when at my desk (where the radio is) I use the headphone port on the radio.  This is because I don't have to mess with the audio input/output devices and can also hear CW sidetone directly from my keyer.  I'm working **** CW mostly these days to get back to speed.  I do a little digital for fun here and there.

I also have a Mac Laptop and for that I purchased DogPark SDR which is very good.  I don't really operate yet from this but sometimes I will sit and just monitor some CW while I am watching a football game or something.  I have done a few CW qsos that way and it works nicely.

So last night was the first night I tried to use dogpark on the 6500.  It found it, connected and started to show signals on 40m but I couldn't hear anything.  I double checked all the audio and even restarted the mac.   Still wouldn't work.  It was 11pm and so I just shutdown for the night and figured I'd look at it in the morning.

So this am I come down, run SSDR on my desk (win10) computer and I decide to try the remote option.  Well I was surprised to get no audio either.  I could see audio going into Dax slice A but nothing coming over my default audio device.  

I verified it was the device by playing a windows sound or two.  So I began to look at various setup options in SSDR.  I could not really find anything that seems to enable/disable audio other than the remote button.

Then I noticed I didn't have a profile selected.  Currently the only profile in my list for some reason is the dogparksdr default profile.  So I selected and all of a sudden audio!

So here is my question:  Clearly selecting the profile enabled the audio.  But shouldn't I be able to manually go to some place in the software, set things the way I want to achieve the same thing?  IE is there a checkbox, audio driver selector or something that I could not find?

I does concern me that in my looking I could find nothing obvious to get the audio working over remote but suddenly when selecting a profile that I really don't know much about (dog park created it) I can get the audio to work.

Am I just missing a setting somewhere doing this manually?

Answers

  • Don Agro
    Don Agro Member
    edited March 2017
    When you say "Dog Park Created it" (the profile) that is only partially true. We name the profile, we save it and we load it - but we have nothing to do with it's contents. The profile contains settings choices that you have made, we only tell the radio to save it or load it. When you loaded the dog park default profile you returned the radio to a state that you had previously set.
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited November 2015
    Hi Don, Ok my apologies...  I understand you rename and save.   No intention in this post to target dogpark as the problem.  In fact it seems to be the thing that illuminates the issue.

    Clearly there is some setting I cannot find that loading the "renamed and saved" dogpark profile fixes.

    So to be clear, I do not blame or think dogpark SDR had anything to do with the cause of this problem.  It seems somehow to be related to changing from the 6300 I had to the 6500 without a reinstall of SSDR from scratch.

    So I am looking find that setting or checkbox that enables audio (like loading the dogpark SDR default profile does).
  • Don Agro
    Don Agro Member
    edited March 2017
    No problem Mark, I think you may be right about the radio change. 
  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    Also, the profiles live in the radio, not in the client. There are still some settings that need attention in SSDR until Don can completely migrate the whole package.
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited November 2015
    Ya this is still an issue.  I can't get audio out of dogpark SDR.  It seems I was able to get audio in my Win10 box next to the radio but quitting SSDR then running dogpark on the mac laptop results in a radio connection but no audio even though the dogparkSDR default profile seems to be selected.

    I should also mention that I tried SSDR remote on a windows laptop and had the same issue.  I can't get audio to that either.
  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    Mark, try resetting the radio, starting SSDR first and checking all your settings (including DAX - which must not be set as a default audio device). Once you have it square under Windows, save the profile and launch DPSDR. Load your new profile and see what happens. You may need to re-select Mac Audio and the Input/Output devices in Preferences.

  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited November 2015
    Ok with quite a bit of fiddling I was able to get this to work.  

    I went to SSDR on Win10 and saved a known working profile that allowed remote audio.  I quit SSDR, ran dogpark - No audio.

    I went to my mac sound control panel, made sure speakers were selected, tested them, still no audio.

    Went to dogpark settings and reselected the "built in output" for audio.  Also checked "mac audio".  Still nothing.

    Went back to the sound control panel and for some reason output which had been set before to internal speakers was no on a soundflower output.  I changed it back to internal speakers and it started to work.

    No idea why it changed but it does seem to work now.  I'll keep an eye on it and see if I run across more strangeness.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.