Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can't get Fldigi to connect to Flex-6500 since I allowed Windows 10 to do an upgrade 28Aug15.

Have been running Fldigi 3.21.78 successfully under Windows 10 with SmartSDR version 1.4.16 using RigCAT and SmartSDR.xml.  I allowed Windows 10 to do an upgrade and cannot get RigCAT to initialize.  SmartSDR CAT is working fine - it shows the correct frequency for example when using the test feature.  I checked on the two Microsoft updates that comprised the update and per the KB they don't seem to relate to networking. Only one was available to uninstall, so I tried that. I also tried turning off Windows Defender and the firewall, and still no luck.  I also downloaded and intstalled Fldigi 3.22.13 (latest version) with an updated xml rig definition file.  Still no success.  Also tried reinstalling SmartSDR to reinstall SmartCAT but still no success.  Likely something simple I am missing.  Any ideas?


  • W7NGA
    W7NGA Member ✭✭✭
    edited January 2018
    Keith, I just installed Windows 10 and it is working with SSDR like a dream with no issues. Fldigi would not initialize as the .xml definition file had disappeared. I downloaded it once again, pointed to (opened) the new file in the RigCat section, initialized, and everything works. You have to be very specific as to where the file resides. Perhaps this is not your issue, but others might find it of value.

    W7NGA - dan
    San Juan Island, Wa.
  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited November 2017
      I would got through and redo all of the CAT & audio setting in FLdigi and SSDRCAT/DAX as if you where setting it up for the first time.. WIndows sometimes scrambles CAT and audio ports on reboot and upgrades..

    AL, K0VM
  • John n0snx
    John n0snx Member
    edited August 2015
    I had the same issue until I manually deleted all the com port related to Flex in the device manager.... Then reload SSDR and let it rebuild the Flex ports and all was fine after that... good luck...
  • Rob G6EIH
    Rob G6EIH Member
    edited January 2019
    If your runing antivirus software this can disable com's on many ports, uninstall your antivirus and see if it works, you can always install antivirus again and it won't compromise other settings or software.
  • Keith - KE4TH
    Keith - KE4TH Member
    edited August 2015
    Rob - I tried turning off Windows Defender, the antivirus software native to Windows 10.  The SmartSDR CAT is not showing any Available Flex Virtual Ports and I think somehow this is part of the issue. The Main tab still shows COM4 for 3rd party software.
    John - I could not find any com ports in device manager related to Flex software.  I tried showing hidden devices and still no luck finding any ports.  Maybe lack of ports is the issue.
    I appreciate everyone's comments!
  • Keith - KE4TH
    Keith - KE4TH Member
    edited May 2020
    I removed SmartSDR and deleted visible and hidden ports in device manager. Interesting that the ports only showed up after I deleted SmartSDR.  After reinstall, the new virtual ports created, COM4 (for Fldigi) and COM14 (for radio), show with yellow caution triangles in device manager.  The error message is "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)".  Apparently this is the issue, even with a clean install, the virtual com ports are not working properly.  Any ideas how to get a cleaner install?
  • John n0snx
    John n0snx Member
    edited August 2015
    Keith now that they showed up delete them again reboot computer and reload ssdr again... that's what worked for me....
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Keith - this is the pitfall of not completely removing the entire SmartSDR "ecosystem" before allowing Windows to upgrade an operating systems; drivers get hosed in the upgrade process.  

    My recommendation is to revert back to your previous OS version, uninstall entire SmartSDR "ecosystem" (https://helpdesk.flexradio.com/hc/en-us/articles/204975589), upgrade to Win10 and then re-install SmartSDR.
  • k3Tim
    k3Tim Member ✭✭✭
    edited December 2016
    Had same exact message when I upgraded from win7 to win10. Removing the devices as already mentioned and installing SDR-CAT manually using Admin-priv fixed it. Sa!e was required for SDR-DaX. After this everything has worked under Windows 10 and I am glad to be over this hurdles. Good luck...

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.