Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Cat stopped working

W4WHL Member ✭✭
edited December 2018 in SmartSDR CAT
I just received my 6300, but smartsdr cat will not load.  I get a error stating "Cat stopped working"  Here is the error from the event log.  I checked and the virtual serial port service is running.  Not sure what to check.  I tried on another computer and it worked fine.  Not sure what could be causing this on this computer.  Any ideas?

Application: Cat.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Net.Sockets.SocketException
   at System.Net.Sockets.Socket.DoBind(System.Net.EndPoint, System.Net.SocketAddress)
   at System.Net.Sockets.Socket.Bind(System.Net.EndPoint)
   at AsyncSocketsV2.server..ctor(Int32)
   at Cat.Main..ctor()
   at Cat.Program.Main()


  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited September 2018
    Perhaps something corrupted in your computer for some unexplained reason. Have you tried restoring your computer to an earlier date? Sometimes the restore function corrects the computer to its former state when it was working.
  • Bill
    Bill Member
    edited February 2015
    You are right on but I would add that the radio and the computer are partners in the station. Many people neglect the care and feeding of the computer and it can have all kinds of issues, especially stuff running in the background upon startup. Getting rid of the junk weekly with a pcclean type program makes the computer twice as accessable. The same people who would never miss brushing their teeth regularly, run a collectively cruder up machine and have these type problems! Bill, KI4B
  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited December 2018

    I have preached over and over and over again on this net to make a hard drive image and it always falls on deaf ears with an ensuing argument. Even the restore is better than nothing but you are correct.

    Jim, K6QE

  • DrTeeth
    DrTeeth Member ✭✭
    edited August 2016
    I image daily and religiously.

    Lets not talk about the (windows, natch)  PCs with broken prefetch or corrupt icon caches. See a lot of this when I service PCs. Big performance hits.

    My PCs are like greyhounds - lean and fast.
  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited December 2016
    Guy tell me, would this be happening if the computer is only a Flex box?. I mean some use the computer for everything then run SSDR as well.
  • W4WHL
    W4WHL Member ✭✭
    edited July 2016
    Back to the original topic.  I fixed my issue,  And here is what it was if anybody runs into this;

    My PC had another virtual com port driver I used with power SDR.  I removed this driver and reinstalled everything.  Now I have my log program work fine with the 6300.

    So my advice is as said above, look for drivers and services that might be conflicting and remove them.  A clean slate is always best for sure.

  • DrTeeth
    DrTeeth Member ✭✭
    edited August 2016
    I doubt it. I do not use any computer as exclusively for Flex. All sorts of other stuff is going on at the same time - only stuff that is needed.

    I have never come across a situation where heavy multitasking itself makes a program crash.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.