Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Update "Not Responding"

Joe Veras
Joe Veras Member ✭✭
edited December 2019 in SmartSDR for Windows
Following the Quick Start Guide, I installed my new 6300 and software. My first-time start produced an Update Required on the Radio Setup screen. I clicked on the update button and the screen soon changed to "Not Responding," with the little circle icon going round and round. After a few more minutes the screen grayed out. It's been sitting here doing nothing for an additional 30 minutes. 

Help! Brand new radio and it won't work. Bummer.

Vital Stats: Flex 6300, 64 bit Windows 7 on an AMD processor PC with 16 GB RAM. The radio is hooked to the computer through my Netgear router. SmartSDR is the 1.3 version that arrived with the radio from Austin yesterday. PSDR worked well with this setup (minus the ethernet connection) for several years.


  • Steve W6SDM
    Steve W6SDM Member ✭✭
    edited December 2014
    I have a very similar setup.  I installed mine a couple of weeks ago and it went flawlessly.  Are you sure the network is seeing your radio?  In my Netgear software, there is a tab that maps the network and shows me all of the devices connected to it.  I would start over and also power cycle your router.

  • NX6D Dave
    NX6D Dave Member ✭✭
    edited December 2019

    I think the radio can be seen from SmartSDR.  SmartSDR saw the radio and listed it, then recognized that the radio needed a firmware update.

    I agree that rebooting everything should be the first thing to try.  This includes completely de-powering the radio and bringing it back up from cold.  Keep an eye on the Ethernet activity light on the radio's RJ45 connector.  That may give you an idea of what is happening.

  • Ken N9VV
    Ken N9VV Member ✭✭
    edited December 2016
    Joe, David, Steve, 
    would it do any good to try running SmartSDR "as administrator" just to see if this could possibly be a permission problem?   Sometimes when I get a "not responding" I can change the priority of the process to "higher than normal" or "run as administrator" and that clears the problem. Just a thought.
    GL de Ken N9VV
  • Bob
    Bob Member
    edited December 2016
    Similar problem. My Internet connection to shack is wireless. Plugging radio to computer Ethernet port on computer not working. My solution: Ran a long (150 foot) Ethernet cable from router in the house to the shack. Installed Ethernet gigabit switch($20 or so) on that cable at the shack. Short Ethernet cable #1 from gigabit switch to radio. Short Ethernet cable #2 from gigabit switch to computer. Booted computer. Turned off wireless NIC on computer (in the task bar). Now connected by cable to Internet. Tested Internet by viewing some sites on the Internet. That established that my Internet connection was working. Turned on radio and did factory default. Invoked SmartSDR on the computer. Selected my radio in the SmartSDR GUI and it said update. Rather than "not responding" I got to updating. Radio did update. In fact it turned off and then on a few times during the update. Took about ten minutes. Then spectrum graph popped up on computer! Played with radio a bit. Disconnected Ethernet cable from house to shack. Turned on computer wireless NIC. Got Internet back via WiFi. Radio and SmartSDR still working. Left gigabit switch on between radio and computer. So far all working. I may need to run Ethernet cable to shack as permanently in the future especially for updates. Great radio! Hope this helps.  73 Bob AD7WU
  • Joe Veras
    Joe Veras Member ✭✭
    edited October 2019
    Thanks to everyone, I am making progress without final success. Ken, one of early attempts at solving the problem was to "run as administrator." That often helps some programs launch; no luck in this case. 

    As suggested by Steve and David, I powered everything off and did a complete cold start. The update finally ran, filling in the yellow progress bar completely, although the radio setup screen never changed to "connect" from "update. The green power light changed to violet while it was updating, so that was a change from what happened before when it was in the "not responding" mode. 

    At present, an hour-and-a-half after the update progress bar filled in, it the radio setup screen is just sitting there. The network activity LEDS on the radio's RJ45 socket are 1) steady yellow and 2) flickering orange. 

    The Netgear "Net Genie" software shows 8 devices including the PC, wireless router, and the internet. Nothing is identified as the Flex 6300.

    The 6300 has the external amp connection keyed up (although no amp is connected to be keyed, it just lights up the LED on the buffer).

    So . . . it's doing more stuff, but I'm not on the air yet.    73- Joe, K9OCO
  • Joe Veras
    Joe Veras Member ✭✭
    edited April 2016
    OK! Another complete power cycle on everything and I have Panadapter screen.  Will get a chance to try that out tomorrow. Is this device designed to teach me persistence? Thanks again. K9OCO

  • Steve W6SDM
    Steve W6SDM Member ✭✭
    edited December 2014
    It sounds as if your problem is with your network/internet connection, not the computer.  The firmware update should not have taken that much time to update.

    Now that you have the update, you don't need the Internet.  Run the Ethernet cable directly from the rig to the computer.  See how that works.  If there are problems, change cables.  If it's okay, then you have a problem with your WiFi network.

    Although it may work on a robust WiFi network, I would not depend on wireless to connect my Flex.  I am using a Gigabit router and I am still plugged directly into the router.

    In Netgear Genie, it won't identify as Flex right off.  It will most likely come up as a "network device".  Look for something new that wasn't on your network before, or unplug the Flex and see what drops off.  One you have identified which network device it is, assuming there is more than one, you can label your radio as Flex so that it is easier to find next time you have a network issue.  You will also see the radio's network IP.

    If you are already plugged into your router, you may want to reset your router - there should be a button somewhere to restore factory defaults.  You also may have to look at your firewall and anything else that could be keeping the Flex from having full access.

    Good Luck!

  • safetyproumb
    safetyproumb Member
    edited November 2016

    I had a very similar experience when I received my 6300 last week. Although I eventually was able to upgrade the radio firmware to v1.3.0.41, it took 30 to 40 minutes for SmartSDR to connect with the radio and begin the update process.

    I'm operational with my 6300 running SmartSDR v1.3.0.116 and I am having a great deal of fun. However, I'm continuing to experience the following connection behavior. I boot the PC and wait for SmartSDR CAT to run. I then power-up the radio, wait for the blinking green to go steady, and then start SmartDDR. The radio is discovered. When I hit Connect, one of two things happen; the connection is made immediately and I'm operational, OR SmartSDR, SmartSDR CAT, and SmartSDR Alert Helper all become unresponsive. SmartSDR Cat always fails first. Oddly, if I have the patience to wait 30 to 40 minutes, the connection is made and I'm operational. Sometimes the connection is not made and after an hour or longer I give up. This can't be right.

    I tried running both SmartSDR CAT and SmartSDR as Adfministrator with no resoltution of the problem.

    If a connection with the radio is made immediately, I can shut down the radio and exit SmartSDR and as long as I do not turn off the PC or switch to another profile, I can start SmartSDR and the radio and get an immeditae connection. 

    I'm running Windows 7 Home Premium, SP1; Intel Core [email protected] GHz, 64 bit; 6 GB Ram. I'm running out of an Administrator profile and when the software and radio are operational, system resources are not stressed. I am not running any third party firewall or antivirus software. The radio is connected directly to the PC.

    I can usually count on getting opeational if I delete and re-install the software and do a hard reset on the radio. I guess its time for a support ticket submission. However, any support from this community would be appreciated.

    Jim, N3JWE


  • KY6LA_Howard
    KY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Direct connections have been reported as being "flaky" Suggest you use a router to generate the IP That always fixes the problem.
  • Stan VA7NF
    Stan VA7NF President Surrey Amateur Radio Communications Member ✭✭✭
    edited February 2017

    The hang of SmartSDR is "normal" when SmartSDR and the Flex are on different subnets; and this is often because your local router is not fully powered up when the Flex becomes ready (No network = internal IP = Different than the computer = SmartSDR hang.

    Perhaps this condition can be corrected in 1.3.1 with a message that the selected Flex is on the wrong subnet; and no hang

  • safetyproumb
    safetyproumb Member
    edited November 2016
    I submitted a support ticket and after a couple of quick email exchanges, I'm thinking the problem was identified and a solution developed.

    I'm now disabling my wireless adapter before powering up the radio and establishing the direct link-local connection with the PC. Connection with the radio is immediate under all start-up and shutdown sequences I have tested so far. I then enable the wireless connection and proceed with normal radio operation and an internet connection. Flex support did also suggest adding a 1Gb switch to the set-up, but I have not done that yet.

    Jim, N3JWE
  • N7BCP
    N7BCP Member ✭✭
    edited July 2017
    For a 6500 or 6700 it would be nice is the front display could show the radios network configuration.
  • Joe Veras
    Joe Veras Member ✭✭
    edited April 2016
    I'm ready to close this issue out; Used the 6300 all day yesterday and it is working well on every mode and band. Many thanks for the help from the Community. The new radio is as much fun as I had anticipated!  73- Joe, K9OCO

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.