Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

DAX and VARA Issue

Options
lvplummer
lvplummer Member ✭✭
edited May 12 in DAX
I have been away from ham radio for about a year. Back a year ago, I used VarAC with the VARA modem connected to my Flex 6300 running an earlier version of SmartSDR and everthing worked beatutifully.

As part of recently restarting my digital ham activities, I have upgraded SmartSDR to 3.7.4, VARA to 4.8.7, and VarAC to 9.1.0 all of which are the lastest versions. OS is Windows 11 with lastest updates.

I am running CAT via TCP with no problem selecting frequency or triggering PTT. I am using DAX for both receive and transmit audio and the receive path works perfectly. However, there is a glitch in the DAX audio transmit path.

Transmit audio level is set for proper ALC. In fact, transmit sort of works. However, there are sometimes dropouts during transmission which can be seen on the SmartSDR RF waterfall and on received VARA waterfall from a separate Icom IC-7300 based setup. Transmitted data is received correctly about half of the time. When I send a VarAC CQ (2 messages), sometimes one is transmitted and sometimes none.

With so many moving parts, I wanted to isolate the issue. I connected the digital audio output stream from VARA to a hardware sound card and then phyically connected the analog output of the soundcard to the 6300 MIC input. That works perfectly. However, this physical solution can't be operated remotely which is one of my objectives.

One other piece of information. When I do a "VARA Tune" which sends a single 1500 Hz tone instead of multiple tones, I don't see the dropout.

I have reinstalled SmartSDR 3.7.4. I have reinstalled VARA. I have tried this setup on two desktops and one laptop computer with consisted results. All computers are running Windows 11.

Any help or insight would be appreicated.

Larry
W6LVP

Answers

  • KD0RC
    KD0RC Member, Super Elmer Moderator
    Options

    Hi Larry, I am using the same setup except for Win 10 instead of 11. Here is how I have the RIG tab in VARAc Settings:

    I am guessing that you already have this the same at your station.

    Here is how I have the SoundCard option in VARA HF:

    Note that the example screen shot that they give is not for a Flex radio. Rather that setting the DAX audio for 1/3 ALC, I set the audio level to be just under 0 dB by adjusting my DAX TX Gain slider to 48 per the Dave, WO2X recommendation (exactly right for my station).

    If all of that is OK, post back here. Dropouts are often a function of the network. Things like RFI in the router/cabling, poor WiFi connection if you are using WiFi, etc.

  • lvplummer
    lvplummer Member ✭✭
    Options
    Thanks very much for your response.

    Some comments:

    My general setup is the same as yours. I have tried both TCP and Serial CAT with the same result - CAT works fine for both but I prefer TCP for its simplicity. However, I just noticed that your radio is "SmartSDR" and mine is "FlexRadio." Something I will check tomorrow. IO just downloaded the newest CAT file and "FlexRadio" is not there. Maybe this is the problem and will be resolved if I replace the file with new one and use "SmartSDR>"

    I agree that 1/3 ALC is too low. I adjust the transmit audio whether DAX or analog to same point as yours. I actually increase the audio level until the RF output peaks on my LP-100A wattmeter.

    Since writing the orginal post, I tried the setup on a Windows 10 desktop computer. SmartSDR (with DAX and CAT), VARA, and VarAC were all installed from scratch.

    The three desktop computers are plugged into the same Gigabit Switch as the 6300. My Windows 11 Laptop was connected via WiFi. All with the same result.

    If the new CAT rig control file doesn't solve the problem, I plan to connect a desktop directly to the 6300 with no ethernet swtich, no extraneous internet network traffic, and no collisions. Since the desktops and even the WiFi laptop all have their traffic flow through my Gigabit switch, I wonder if that might be the source of the problem.
  • Gary NC3Z
    Gary NC3Z Member ✭✭✭
    Options

    I run VarAC daily (and have been for a long time) with my 6500 on Win 11 and have not seen what you have described. I actually run 4 instanced simultaneously with my 6500.

    As for the Rig ini file saying SmartSDR or Flex, that was just a simple naming in the file and has no bearing on an update. When we were developing the CAT IP I may have called it Flex originally but switched it to a more proper SmartSDR so as not to confuse with 5000 series radios. So do not worry about that.

    I did not upgrade the latest SSDR since it said it was on for the Maestro so I am using V3.6.8

    For VarAC I am using alpha v9.2 as we are testing some GPS integration but 9.1 and before all acted the same with SSDR.

    For VARA drive level I have found that setting it so that the SSDR Level is at -5dB peak works the best.

  • lvplummer
    lvplummer Member ✭✭
    Options
    This arrangement also worked well for me for quite a while albeit with earlier versions of all software. I can assure that I am not imagining the problem.
  • Gary NC3Z
    Gary NC3Z Member ✭✭✭
    Options

    My big difference is running SSDR V3.6.8

  • lvplummer
    lvplummer Member ✭✭
    Options
    After learning from Gary that the issue is not an incorrect CAT configuration, I suspected the problem to be network related.

    Next step was to create the ultimate simple network - just a Cat 7 cable directly from my PC to the Flex. That simple setup worked perfectly.

    I then reconnected the Flex and PC back to the Gigabit ethernet swtich where they were originally connected and everything still works.

    I have tried multiple long file transfers and all is good.

    My guess is that the ethernet switch had a glitch in its switching table which was cleared when I disconnected and reconnected the two cables.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.