Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Suddenly SmartSDR doesn't see my Flex6400!

N7DK Dave
N7DK Dave Member ✭✭
edited August 23 in Networking
After working for years, suddenly my SmartSDR app says "There are currently no radios available". My LAN/Internet ethernet connection to my Flex6400 looks good. I can "ping" successfully to the radio from any computer.

I've tried upgrading to v3.5.8 to see if that might cure the problem, but I get the same result. Frustrating!

Can you suggest some other things I might try?

Thank you.
Dave N7DK
Scottsdale, AZ
[email protected]

Best Answer

  • fpmacko
    fpmacko Member ✭✭
    Answer ✓

    $20 says that you're using ESET security software. I had the same problem last week. Ken in tech support pointed me to ESET as the likely problem. I checked the logs and found that they pushed out an update to a scanner module the same day my problem started. Apparently, even though it was a file scanning module it hosed something in the firewall. I had to set rules in the firewall to allow my PC to talk to my 6500 and PGXL.

    If indeed you have ESET I'll be happy to point you toward the specifics of how to set the firewall rules.

    73.....Frank / WA3NHK


  • N7DK Dave
    N7DK Dave Member ✭✭
    Wow, thanks, Frank! In fact I AM using ESET -- I have been for years, but all of a sudden this problem cropped up -- Please do point me to the specifics on firewall settings -- I might be able to stumble my
    way through it, but you'll save me a lot of aggravation trying to figure out ESET's settings!
    73 & thanks again! Dave / N7DK
  • N7DK Dave
    N7DK Dave Member ✭✭

    Follow-up: I paused the ESET firewall, and sure enough, SmartSDR came right up ...

    I'd still like that help on firewall settings, Frank !

    73, Dave, N7DK

  • fpmacko
    fpmacko Member ✭✭

    Will do, Dave. I’m not in the shack at the moment so standby til tmw and I’ll post the procedure.


  • N7DK Dave
    N7DK Dave Member ✭✭

    Hi, Frank - Duh!

    I decided to try clearing the ESET problem myself, and to my chagrin, it was pretty easy. ESET instructions were at the site below and I've cured my problem. My Flex6400 and SmartSDR system is again working smoothly.

    Thanks for seeing my original note and nailing the problem for me with one shot!

    73, Dave, N7DK


  • fpmacko
    fpmacko Member ✭✭

    Sounds good, Dave. I’m still on my iPhone so I won’t bother trying to read that until I get home. One thing to note… be sure to open all protocols just in case. I think it defaults to TCP/UDP only.


  • N7DK Dave
    N7DK Dave Member ✭✭

    Thanks, Frank -- as I recall, my initial attempt to "unblock" on ESET didn't completely do the job -- my 6400 was communicating, but with an odd display. ESET offered some sort of wider path to the radio, and when I said yeah, yeah, give it to me, full operation was restored.

    I might never have tumbled to ESET as the problem except for your note on this forum. You made an old ham happy!

    73, Dave, N7DK

  • fpmacko
    fpmacko Member ✭✭

    Glad to have helped, Dave. Lemme know if you run into anymore roadblocks.

    73.....Frank / WA3NHK


    I just took a look at the rules I setup and noticed that I unblocked DAX and CAT as well as SSDR and PGXLdesktop, but forgot to tell you....

    That's probably why you got the odd display. The route to get to the rules page is from the ESET main dialog is...

    1. Click Setup
    2. Click Advances Setup at the lower right corner.
    3. Under Firewall/Rules click Edit.
    4. Add a rule for each flexradio app just like I did. You'll have to give the full path to each app's EXE file.
    5. Be sure to say "any" IP protocol.

    The dialog box that lets you build the rule manually looks like this....

  • Mr Radio
    Mr Radio Member ✭✭

    I have follow up this matter with ESET.

    THey suggested to try this:

    It seems like the issue is with the firewall module. To resolve this issue please enable pre-release updates from your ESET settings and reboot the computer. 

    1. Open your ESET program.  

    2. Go to Setup > 'Advanced setup or (Press F5)

    3. Click 'Update' -> Profile -> Updates -> Select 'Pre-released' update.

    4. Click 'OK' and restart your computer. 

    5. Click update > Check for updates.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.