Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Interlock Message with PGXL

This morning when trying to transmit I got the following message which would not allow transmission, "interlock is preventing transmission AMP:PG-XL".

Did not matter what band, restarted SmartSDR, same thing. Did not matter if PGXL was in standby or not. Did not reboot 6700 for fear of the current issue regarding slices may come up, though a fix is eminent.

I shutdown FRstack, same thing. I turned off the TGXL, same thing, shutdown the PGXL utility, same thing, then turned off the PGXL and the message stopped. Powered TGXL back up and all flags were OK on PGXL but the message came back. Even after repeated attempts the message would appear with the PGXL on and go away when it was off, so started scratching my head.

Before I started panicking about a possible PGXL problem I thought I would check out the device settings in the utility and for the heck of it I would try to let the firmware rediscover the 6700. So under the FlexRadio tab I disabled both Port A and B configurations, saved and restarted the utility. Then went back to the FlexRadio tab and enabled both Port A and B configurations, saved and restarted the utility. BINGO, the interlock message stopped and the radio could transmit again with PGXL in either standby or operate.

Has anyone experienced this? Is this something known or something new? After operation phone, FT8 and a little AM test yesterday had no issues but did have a few FT8 transmissions on 60m so had to play with output bandwidth to stay within allotted frequency, (awaiting new Canadian TURF file). The only thing I can think of what might have caused or contributed to this is when going on FT8 on 60m, the PGXL was in operate mode before I quickly shutdown and put PGXL in standby. After that I went on operating on other bands with no issues. Then when going QRT I shut down SmartSDR leaving the radio on as normal and put PGXL in standby before shutting it off. Perhaps the persistence got messed up?

Before I hit the button to post this, I searched the community again and did find this response from Dave w2ox:

3.3.29 6400/PGXL now interlocked!

where Dave says "So if you run into interlocking try going into the amp utility and then click save to reboot the amp."

Guess next time I'll do more research but I hope this helps anyone who comes across a similar interlock issue or maybe help developers as to the cause of the interlock flag red herring in the first place.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.