Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR Will Not Install

Neither of the last two levels of SmartSDR will install on my (Windows 10 now 11) computer. The install progresses until I hit Install. The bar appears and about 1 second later it all disappears, leaving nothing installed. It is leaving a file, AppCrash_SmartSDR_V3.3.39... in Windows\WER\ReportArchive which I cannot interpret.

Everything else on that Dell computer works OK but I did have one problem booting: Apparently PortCLS.sys violated the address space. That did not occur on Windows 10, but has happened once on Windows 11.

I have removed all SmartSDR versions and rebooted but the problem persists.

V3.3.29 and V3.3.39 installs and works OK on my Surface laptop.

Why did I upgrade to Windows 11? Because I was ready to do the upgrade and was having problems with SmartSDR. It took many minutes to start, would not connect with WSJT-X and did not bring up CAT. Would not all the drivers be changed when upgrading to Windows 11? Would that affect the install of SmartSDR? I ran SFC /scannow and it found nothing wrong.

John, K2CIB



  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Hi John, I would submit a help desk ticket. Flex support will know how to use the AppCrash file.

  • VE7ATJ_Don
    VE7ATJ_Don Member ✭✭✭

    John... what Len said.

    Just so you know, I (and many others) are running the latest versions of SSDR on Win11 with no difficulties installing.

    Something to take a look at may be some of the 'bloatware' that Dell routinely includes in their OS packages. Or, you may have corrupt Win11 files, which can be solved by getting Windows to install a clean copy of itself. (It's a selection from the settings, no extra charge as they just use your existing licence and download clean OS files from the interwebs...)

  • Rich M5RIC
    Rich M5RIC Member ✭✭✭
    edited August 2022

    Try this, worked for me as the installer was failing.

    1. Right click on the .exe file for the new version where you downloaded it
    2. Select Troubleshoot compatibility
    3. Choose 'Try recommended settings'
    4. Click 'Test the program

    Worls 9/10 for people.



  • JohnK2CIB
    JohnK2CIB Member ✭✭

    I finally traced the problem down to a corrupted registry. There was an error file in Windows. Updating from Windows 10 to 11 apparently carries the registry errors over. So, I bit the bullet and did a clean install of Windows 11. Then SmartSDR installed just fine.

    However, I have not been able to get any sound out of SmartSDR although the sound card works fine with system sounds. DAX shows a good audio stream.

  • VE7ATJ_Don
    VE7ATJ_Don Member ✭✭✭

    So, when you say you can't get any sound out, can you give us more details of your setup (remote, Maestro or not, sound from laptop speakers, from the headphone jack on the Flex?)? Are you meaning no sound in an FT8 stream?

    That will help us help you.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.