Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

DAX Driver Error on NEW Windows 10 (or 11) installation

PA2TA Member ✭✭
edited June 2022 in DAX

This is about a first installation of SmartSDR on a NEW Windows 10 machine, so it is not about changed names of the DAX Audio devices after an update or upgrade of Windows.

A lot has been said and written about DAX Errors, but I couldn't find anything related to this problem.


If you get the "DAX Driver Error" message after installing SmartSDR on a CLEAN Windows 10 (or later) installation, first check the "Memory Integrity" setting under "Core Isolation". If it is enabled, disable it. The DAX drivers do not need to be reinstalled, a reboot of the machine is sufficient.

The long story:

My brand new HP Elitebook laptop is equipped with Windows 10 Pro, but this may also apply to new installations of the Home version or Windows 11 (Pro or Home).

After uninstalling the inevitable bloatware, the next task was to install SmartSDR. Everything went fine, but after starting SmartSDR the message "DAX Driver Error" appeared on the screen.

This was certainly not the first time I installed SmartSDR, it has been running flawlessly for years on multiple laptops and PCs running Windows 7, 10 and 11, both the Home and Pro versions. But it was the first time I encountered this problem. Strange, why does it run without problems on all those other machines and not on this new laptop?

In device manager the DAX drivers showed the error message:

Unable to load the device driver for this device into memory. The driver may be corrupted or missing. (Code 39)

{Invalid Image}

%hs is not suitable for Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or software vendor for assistance. Error status 0x

Even after uninstalling and reinstalling the drivers several times, following the procedure described by Tim - https://helpdesk.flexradio.com/hc/en-us/articles/204017069-How-to-Manually-Re-Install-DAX Drivers - the problem persisted.

I spent two days and one night trying to solve the problem by removing more software from HP and searching the Flexradio forum and the rest of the internet, all to no avail.

Until I ran into the "Core Isolation" - "Memory Integrity" settings. After disabling "Memory Integrity", followed by a machine reboot, miraculously the DAX devices appeared under "Audio Input and Output " in "Device Manager" , and under "Sound, video and game controllers" the DAX drivers no longer showed errors.

Conclusion: after disabling "Memory Integrity" the DAX Drivers are correctly loaded into memory. The disadvantage is that "Memory Integrity" cannot be re-enabled afterwards because incompatible drivers are now present.

Learn more about Device Security and Core Isolation here: https://support.microsoft.com/en-us/windows/device-protection-in-windows-security-afa11526-de57-b1c5-599f-3a4c6a61c5e2

The reason it worked fine on all other machines is probably because the other machines are all a bit older and the "Core Isolation" and "Memory Integrity" settings only appear in later versions/updates of Windows.

On one of the laptops, recently migrated from Windows 10 to Windows 11, the "Core Isolation" function is not present, on another it is present but disabled. It turns out that "Memory Integrity" is turned off by default for migrations from Windows 10 to 11.

Maybe not a top priority, but it seems to me that Flexradio has a job to do here to eventually make the DAX drivers compatible (but I also realize that the drivers are probably deeply embedded in Windows and that this is not just a piece of cake ).


  • Larry Benoit
    Larry Benoit Member ✭✭

    Been there, done that with three different Microsoft Surface Laptop 4 computers running Windows 10 or 11. As you note, this is happening with newer Windows PCs that have the necessary hardware to support the latest Windows 10/11Device Security features.

    Flex support advised that another re-write of the DAX drivers is forthcoming to address this security defect and other longstanding bugs. As is customary, no target date was given.


    Larry KB1VFU

  • johnn1jm
    johnn1jm Member ✭✭

    I'm wondering if I should turn memory integrity off or wait for Flex. Everything is okay on my Dell tower(older).

    John N1JM

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Hi John

    If everything, including DAX, is working on your Dell tower then I would not change the current setting. The old adage, “Why fix it if it isn’t broke?”

    Since your computer is older hardware may be why you are not experiencing the problem.

    Have fun with your Flex!

    Dave wo2x

  • johnn1jm
    johnn1jm Member ✭✭
    edited August 2022

    Yes, I installed SSDR on a new Lenovo laptop with Windows 11 Pro and everything worked except DAX. I think I will hold off.

    73, John N1JM

  • Manfred
    Manfred Member
    edited September 2022
    same trouble: Where is the solution for it? I don't like to work with a unsafe PC only to play a radio! Where are updates and features? Hey Flex are you still there? I'm going to lose my confidence
    in these radios. No more progression and this security error is a lot to handle for me.

    73, Manfred HB9FLU
  • Thanks for posting it! We run exactly into this problem with one of the remote access users and your hint solved it here as well. Brand new PC with Win10.

    73 Holger

  • kn6leh
    kn6leh Member
    I just got a 6400 (non-M) and was excited to get things set up, only to discover that I have to disable effective security on my PC to make it work? Incredibly disappointing. This issue seems that it's been open for a while. Any news from FlexRadio on modernizing the driver?

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.