Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

KPA500 doesn't always unkey

Hi guys! I've found my 6400M doesn't always unkey my KPA500 after a transmission. Or at least not switch the antenna back to receive. The asterisk on the KPA500 stays on when it is acting up and I have to rapidly key the PTT to get it to release.

If it sticks in the amp keyed mode, I can unplug the RCA plug from the back of the Flex and it unkeys. Plugging it back in keys it again. So, it is certainly the Flex. I hear the relays doing their thing each time and they sound the same if it locks up or not.

This is pretty much every other transmission or so, so not a rare happening. I've tried enabling TX2 and the same problem there. Same on 20 and 40 so it's not band dependent. Tried with power set to zero, same problem.

Ideas? Newbie here.

Dave, AI7R


  • Dave AI7R
    Dave AI7R Member
    Well, I continued to troubleshoot and should have done that before posting here. And heck, I don't see a way to delete a question.

    So, since it's here, I seem to have fixed it with an installation of an older version and found no problem. Then re-installed the newest version and, of course, no problem. So far.

    I'm finding a new appreciation for my Drake gear. Takes as long to 'boot up' but if there is a problem at least you can smell it. ;)
  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Hi Dave, I think that a factory reset would fix it. I don't think that the reinstall did anything except to force a factory reset.

    If it happens again, I would submit a help desk ticket.

  • Dave AI7R
    Dave AI7R Member
    After a LOT of troubleshooting, it turned out to be the Heil mic adapter cord I'd just gotten from Flex. The 4 pin XLR version. When I went back to just using the supplied hand mic the problem stopped.

    I tried ferrite chokes on the lines and no help. I'm going to build my own cable and see how that works. I'll update it here.
  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Hi Dave, try unplugging the PTT just enough to not have it grounded (i.e. use the ground from the mic) and see if that makes a difference.

    My Heil HM-12 has a huge ground loop unless I do that. Might be related to your issue.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.