Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FYI -- Macssdr and ssdr v3.3.39 issues

K3SF
K3SF Member ✭✭✭

Hi all


i have attempted twice to get v 3.3.39 on my 6600m to work with macssdr and also xdax/xcat

i run m1 macbook mini and various mac minis in the shack and have no problem with v3.2.39 interfacing with any of the mac programs.

When i installed v3.3.39 it appears to be good install on the 6600m..

yes i followed all the proper proceduresand have submitted trouble ticket...

trouble ticket closed telling me to contact the mac developer

which i have done

but

based on macssdr NOT connecting to the 6600m and xdax not seeing a stream ID and showing noisy data stream...this leads me to not recommend update to v3.3.39 for any mac users...

I have reverted back to v3.2.39 and everything mac works again

if other mac users have had better experience please let me know.

THanks

Paul K3SF

Comments

  • K3SF
    K3SF Member ✭✭✭

    i have received the following response from Marcus

    Paul K3SF



    Marcus / DL8MRE (Marcus Roskosch)

    Apr 30, 2022, 0:34 GMT+2

    Hi Paul,


    thanks for writing but ideally you would have used the contact developer feature of my App which will also generate a ticket.


    Yes, during my tests I found the 3.3.39 update quite buggy. I bricked one of my own 6600 even by using the Windows version to update this Radio whereas I was successfully able to upgrade a second Radio by upgrading it by my macOS App. However, the firmware seems to be very unstable and that's why I have removed it from the available firmware options for upgrading in my App.


    I would suggest to do the same what I am doing, to stick with the older 3.2.39 firmware, until Flex has fixed their problems. I have also informed flex about the issues. 


    You can revert back to 3.2.39 using my App.


    During the times when I was able to connect to the upgraded Radio I couldn't even see any advantage of the new firmware so I can't see any reason to upgrade. 


    Best 73s,


    Marcus, DL8MRE

  • Alan
    Alan Member ✭✭✭

    With no issues, I am running Flex firmware 3.3.29, Mac SDR, xCAT, and xDAX.

    The radio is a Flex 6600.

    I have not tested SmartLink.

    I do not use the Flex ATU.

    One difference, I updated the Flex firmware from Windows Smart SDR.

    Alan. WA9WUD

  • K3SF
    K3SF Member ✭✭✭

    MIKE VA3MW

    WILL you Please delete this post.....

    I have made some errors with the post


    Paul K3SF

  • K3SF
    K3SF Member ✭✭✭

    Hi All

    The error i made was NOT asking Marcus to include his email response to my trouble ticket.

    I assumed since it was a response to a trouble ticket it would be appropriate to share. i found it was easier to copy/paste the full response rather than just extracting the salient portions.

    So I owe an apology to Marcus for sharing too much.

    When i did the update to my 6600m, it went well. the radio had not obvious issues on its own.

    Since the M model have their own PC with the screen tablet, the update was under complete flex control.

    BUT

    when i went to use all the Mac s/w like SSDR for Mac ( Marcus) it never connected properly.

    also when using xcat/xdax by Mario the xdax could not retrieve a valid stream ID and hence a corrupt dax data stream. xcat seems to work but i did not do any extension testing. The invalid stream id hinted to me that an API changed.

    The response i got from flex was the trouble ticket was closed cause it was a third party s/w issue and to contact these third parties.

    So with all this information in hand i reverted back to the previous version and the station is fully operational again.


    Paul K3SF

  • Alan
    Alan Member ✭✭✭

    Paul

    As I posted earlier, I have the same Mac configuration as you, and I am using Flex Firmware 3.3.39, without any observable issues.

    Also, I have never had the xDAX and XCAT issues you describe, again with firmware 3.3.39.

    Perhaps there are other factors at play. Perhaps a Local Area Network issue?

    Alan. WA9WUD

  • K3SF
    K3SF Member ✭✭✭

    Hi Alan

    i appreciate your post. i run a 6600M and you say you use 6600 (non-M I assume)

    The M model handles all the updating itself...no pc required...

    The OS on the tablet in the Model is under flex configuration control.

    If i had network issues it would show up even with the previous version 3.2.29.

    Network include 6 port gigbit switch that connect the mac minis (two) to the 6600m

    and

    to a local airport router which is then connected to FIOS router



    so i feel confident not network issue...

    The macs that connect to 6600m run Monterey (12.13.1)

    i am a bit confused too as to why it seems to break the interface to these key mac s/w here.

    i have gone thru the process three times so far trying to makle it all work with 3.3.29. with no success and have had to revert back to 3.2.29...always doing factory reset when reverting back.

    so i would be interested in experience of others who run 6600M and this mac s/w.

    Paul K3SF

  • K3SF
    K3SF Member ✭✭✭

    Hi alan

    I have found out my 6600M has the 256Mb SD and i was wondering what size SD card your 6600 has.

    This maybe why i am having issues with mac s/w and your data point would help a lot to help pin point possible cause for me.

    TIA

    Paul K3SF

  • K3SF
    K3SF Member ✭✭✭

    hi ya'll


    F Y I ...

    After physically checking the size of my SD in my 6600m ..

    Yep..i opened it up and removed and re-seated the 256Mb SD card

    and

    reseated the internal ethernet cable of he 6600m when i clean off the fan

    then i did the update to 3.3.29...following the procedure.. i got it to all work..

    now have xdax and xcat and macsdr all happy with new 3.3.29

    All attempts before that seemed not to provide consistent results.

    I am now seeing proper stream id in xdax when running the just the main panel of 660m

    and

    macssdr connect and disconnect properly.


    This fixed my situation and provided here as F Y I only...



    Paul K3SF

  • K3SF
    K3SF Member ✭✭✭

    UPDATE 12 May2022


    I had ordered the 4GB SD as my 256Mb SD didnt fail just needed to be reseated

    but i wanted my 6600m to be totally up to date.

    the 4Gb SD arrived today from Flex

    took about 2 minutes to install as i had already the case top off when i reseated the 256Mb SD

    the 4Gb SD came with 3.3.29 on it...

    The 6600m came right up and all my mac s/w working fine ( mldx, mac ssdr, xdax, xcat, wsjtx, fldigi)

    OH...did have to rebuild my profiles but i am getting good at that...


    Paul K3SF