Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

How to disable (mute) the audio of smarSDR on Mac?

pc3t
pc3t Member ✭✭
I've been trying to mute just the radio when doing something else in my Mac but I just can't! Even connecting a headphone still receiving the sound on computer speakers. I could't redirect it also to my headphones. I clicked on speaker icon in the software and nothing happens, I did the same in the vfo window and still, I have to mute the enitre sound on my Mac, windows version works better and flawlessly.
Tagged:

Best Answer

  • rsobol
    rsobol Member ✭✭
    Answer ✓

    I had a similar issue and found that by closing the slice once for each of the bands and then re-opening it, the problem was resolved. This had to be done only a single time for each band. I could not turn off the volume no matter what I tried, until I did this. The icons all indicated the volume was muted but it was not. Hope this helps.

Answers

  • W7NGA
    W7NGA Member ✭✭✭

    These problems are fun to solve and generally, with enough information, the solution rises to the surface.

    If you could, perhaps describe the type of Mac, which operating system, and version of SmartSDR for Mac.

    Check and see if the 'settings' menu at the top of the window looks similar to my setup.

    We can proceed from there ...


  • pc3t
    pc3t Member ✭✭
    Hi Dan,
    Macbook pro 16", Monterey 12.1. SSDR 2.015.
    No idea where did you get this window above. I can't mute when DAX channel is not activated. You can see in the image, all speakers should be on mute but I'm still receiving audio. Again, only when DAX channel is active.
  • pc3t
    pc3t Member ✭✭
    Never mind, I know which window it is. The gear on top. It is like yours but same behavior as I mentioned before.
    73
    Alex
  • rsobol
    rsobol Member ✭✭

    Meant to say "buttons", not icon. Why it worked for me, I really don't know!

    73

    Randy

  • W7NGA
    W7NGA Member ✭✭✭

    Sometimes, it is simply best to delete the App and load it again via the App Store. Rebooting your Mac would also be a good idea. Any odd behavior that I have experienced has been squelched after those two operations.

    I also rub my QSL card three times ...

  • pc3t
    pc3t Member ✭✭
    I just did what Randy said and it worked, but as soon as I closed the app and open it again, I had to close the vfo and open a new rx windows to be able to mute. It is a workaround, something that I was not expecting for such expensive app. :/
  • rsobol
    rsobol Member ✭✭

    Yes, that is good news. In my instance, I found I could mute the audio only on certain bands which was very odd. It muted on some but not on others. Even though the buttons indicated mute, I still had speaker audio. I have already mentioned this to Marcus. It seems like some type of initialization is done the first time the band/slice is selected and closed. I thought it was just me having this issue. Glad you got it going.

  • W7NGA
    W7NGA Member ✭✭✭

    I am wondering if this all goes away if you select the 'Use Radio Output' option where the audio comes directly from the speaker and headphone jacks on the radio. Does SmartSDR for Mac behave correctly when muting the audio in that configuration? And, have you rebooted both MacBook and SmartSDR for Mac? Looked at the Sound configuration in System Preferences? Try selecting Bluetooth AirPods or other output device to see if the issue remains.

  • pc3t
    pc3t Member ✭✭

    No changes! I've rebooted, I have connected another headphones or bluetooth headset and the the audio keep flowing on macbook speaker. I changed preferences to use other audio output but the radio audio keeps there. I have to mute the macbook every time. This is really annoying. I'm regretting to have bought this app since on windows everything works as it should. That is one of the reason I didnt' buy the iOS version yet. Very frustrated. :/

  • W7NGA
    W7NGA Member ✭✭✭

    Please let us all know when/if you find the solution to your problem.

    73

  • pc3t
    pc3t Member ✭✭

    What I noticed after DAX enabled, I can't mute it at all. Even if I turn off the macbook speaker, I still keep listening. I will try to open a ticket to Marcus.

  • pc3t
    pc3t Member ✭✭

    Problem solved, so simple... :/

    on Radio -> DAX Streaming.

    Both "Enable DAX..." checkboxes should be off.

    All good for now on..

    73