Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Transmit Recordings smart sdr for Mac

Apologies if this has been covered, I did look. Running the latest version of SSDR on Mac book, while I can record audio, and play it back using the transmit tab, and the radio keys (goes red etc), and I can hear the recording, there appears to be no RF. I tried engaging the Dax as was suggested on a thread and only crashed the 6400. This a great feature to help stations hear how they sound at my station…if I could get it to work…thanks

Comments

  • W7NGA
    W7NGA Member ✭✭✭

    Good morning from soggy and snowy Oregon. I am running SmartSDR for Mac on a mini M1 Mac that does not have an input device. I can record a track, and when transmitting the input switches to Mac but there is no output as you have experienced. If I change my setting in the Radio Controls to Mac (from BAL or MIC) it will then transmit the recorded audio. You must also go into the settings menu on the 'Recordings' tool and set TX gain to an appropriate (non-zero) setting. I would think that the app switching to Mac as the input device should work the same as manually setting it to Mac but in my initial investigations it isn't working as expected.

    73

    W7NGA, Daniel, Seaside Oregon

  • KP4IP
    KP4IP Member ✭✭

    Which version of SmartSDR for mac are you running? I'm running 2.0.15 and I can record and TX the recording without issues using the recordings tool. DAX does not needs to be enabled to TX recordings.

  • rbrossetto
    rbrossetto Member ✭✭

    I too running 2.0.15. I can record fine, and playback, but the playback is not going out no RF. Thanks to Daniel W7NGA, I engaged the mac in the MIC settings...well, it worked, but it came along with a strong hum going out in the RF...so Im back to the drawing board on this one. I must have an errant setting somewhere but I have no idea.

  • W7NGA
    W7NGA Member ✭✭✭
    edited January 4

    In the 'Recordings' mode audio comes from your laptop and can cause problems if RF finds its way into the computer. I would insure that the recordings are coming thru correctly and then gradually increase power until the hum (possible RF ingress) occurs. If it doesn't occur at low power settings you are probably on the right track and will have to play with physical separation, ferrites, and other mitigation measures.

    I will write to Marcus, the SmartSDR for Mac developer, and let him know that we are seeing the problem with audio routing in the recordings mode. I'm also curious how you have determined your signal includes hum (separate receiver, FDX).

    W7NGA

  • rbrossetto
    rbrossetto Member ✭✭

    Thanks for the reply. The report of a background hum is coming from station listening to my TX recordings. B

  • W7NGA
    W7NGA Member ✭✭✭
    edited January 5

    I have shared the audio routing issue with Marcus, DL8MRE and will report back. I am able to run full legal limit on AM with the Recordings tool playing a recorded audio track via MAC M1 mini. No issues.

    W7NGA

  • W7NGA
    W7NGA Member ✭✭✭

    Marcus DL8MRE says the Mac audio routing issue with the Recordings tool is a bug and will be fixed in the next update.

    W7NGA

  • rbrossetto
    rbrossetto Member ✭✭

    Ah, a bug, well at least for once its not operator error (me). I will await the next update from Marcus. Thanks and 73, Brad

  • FotisGR
    FotisGR Member ✭✭
    edited January 11

    Same problem here, i contacted before a week with Marcus but he told me that there is not a problem from others users.... now i see that there are other users with the same problem

    sv3eao