Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR on MAC keeps freezing

When I go into transmit mainly tune at 10watts my software freezes up sometimes just for a second and sometimes it crashes but leaves the radio in transmit. I then have to go and physically turn the radio off to get out of transmit. FT8 is almost useless because it throws the timing off I assume. It is the worst on 20m which is the band it usually crashes on, but 40m is usable but freezes constantly and 15m, 10m, 6m are just fine with no freeze or crash ever. Now the strange thing is my shack is in the pole barn and when I am out there connected to that wifi on the same LAN it works perfect on all bands I have. If I come into the house and connect to that WiFi again the same LAN is where the issue happens.

My shack internet is through a Netgear BPL to get the signal from the house to the pole barn. The main internet comes into the house and the BPL sends the internet through my power lines to get to a WiFi router out in the barn. Again it works perfect out in the barn, but in the house a totally different experience. The Flex 6400 is connected to the router via an ethernet cable that is 75ft long. I could not get the router closer because the BPL signal would be lost or to weak to work effectively.

It acts like there is RF getting into the ethernet cable, but if that was the case it should do it when out in the barn as well. If not even worse than when sitting in the house. The antenna is a butternut vertical about 95ft from the barn and use DX engineering 400max 100ft coax for the feedline. The barn is insulated but with metal roof and walls, so it almost acts as a faraday cage. I do have the excess coax coiled up under the bench where the radio sits, and am going to try running the excess outside to see if that helps. I have also tried coiling the ethernet cable and putting a ferrite snap-on to keep any RF out but that didn't work. I also tried putting 4 of the same ferrite's on the coax with no change. Everything is grounded separately to a ground buss that is connected to a ground rod just outside the barn.

I hope I covered everything and look forward to any ideas.

Thanks Curt AC9HO 73

Comments

  • John KB4DU
    John KB4DU Member ✭✭✭

    If I follow your description, there are two computers running SmartSDR, 1 in the barn and one in the house? The one in the house locks up on transmit? Is there a WiFi access point in the house as well as one in the barn?

  • Curt_AC9HO
    Curt_AC9HO Member
    No sir, I should have been more clear. I have only one computer a MacBook Air M1 that I use in the house and take with me out to the barn. I use it via WiFi in both the house and the barn. In the barn the router is a Netgear BPL WiFi router and in the house is an Apple Airport both on the same network. The Apple Airport feed the internet through the power lines to the barn where it is then WiFi again, but the radio is hardwired from the single ethernet port on the Netgear router. Does that help? Thanks for reading and replying.
  • John KB4DU
    John KB4DU Member ✭✭✭

    Ok, I understand better. I use tplink over the house wiring to get internet to the shack on the opposite end of the house rather than run cat5 all the way.

    sounds like rf being picked up somewhere. I would suspect the power lines first since it is part of the link from the house to the barn. Perhaps some ferrite beads or toroids between the router and power would help.

  • Curt_AC9HO
    Curt_AC9HO Member
    I never thought about that. I put ferrite beads on the CAT6 cable but never thought about the actual romex going right behind the radio. Thanks for the tip I will try that tomorrow with what I have and see if that makes a difference.
  • Curt_AC9HO
    Curt_AC9HO Member
    Well with the ferrite beads I have it did not make any difference. I went to the Palomar website and they have a kit to choke everything coming into the radio, like the power, ethernet, coax, key, literally everything as far as I can tell, so I purchased that. I also ordered more ferrite beads as well as a **** of five ferrite beads specially made for vertical antennas. So when all this comes in I will find time to install and update if that fixed the issue.
  • K6TTD
    K6TTD Member
    I have been having similar issues with SSDR for OS X. I'm using a friends Flex 6500, located on a hilltop about 20 miles from my home. Both are connected via ethernet broadband. Netgear routers on each end.

    I'm running on a late 2014 Mac Mini (8GB). I am running with SSDR operating via an external solid state drive.

    I am able to log in and operate it in receive, and work the VFO & other controls. However, after about 3 minutes of run time, the software freezes completely. Not attempting to transmit so far. Just receive.

    Have been able to run using Maestro and Windoze version of SSDR without issues - though those are currently down due to Flex Server issues. Not sure if this "freeze" is related to what is going on with the Flex Server - or issues with my Mac.

    Should I attempt to re-install my SSDR for OS X?

    Any thoughts would be greatly appreciated.

    Thanks

    Peter Gambee
    KT6TT
Sign In or Register to comment.