Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Installation of v3.2.31 failing with ntdll error - anyone else?

A previous version was running fine. But when I try to install 3.1.12 the installation barely begins and the the window closes with no error message. The application log produces event below each time. I have tried all the usual things such as rebooting, uninstalling the older version of SmartSDR, updating Windows, etc. Please advise

Faulting application name: SmartSDR_v3.2.31_Installer.tmp, version: 51.1052.0.0, time stamp: 0x5ec61809
Faulting module name: ntdll.dll, version: 10.0.17763.1852, time stamp: 0x5d8b408f
Exception code: 0xc0000374
Fault offset: 0x000e05e3
Faulting process id: 0x3bb8
Faulting application start time: 0x01d72e2f83fcce76
Faulting application path: C:\Users\rsmith\AppData\Local\Temp\is-SF9B7.tmp\SmartSDR_v3.2.31_Installer.tmp
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 836d65c5-5603-462c-b46b-f86428d43583
Faulting package full name:
Faulting package-relative application ID:

Best Answer

  • Rich M5RIC
    Rich M5RIC Member ✭✭✭
    Answer ✓

    Try this, worked for me as the installer was failing.

    1. Right click on the .exe file for the new version where you downloaded it
    2. Select Troubleshoot compatibility
    3. Choose 'Try recommended settings'
    4. Click 'Test the program


  • John K3MA
    John K3MA Member ✭✭

    I do not remember the exact error but ever since V3 came out on several Windows 10 computers I will get the same issue. I have found that if I let the error occur with computer restarts 3 or as much as 4 times the error finally stops and from that point on SmartSDR starts correctly. Like I said in another post it has been simpler just to let the error run its course of restarts then to document it and try to trouble shoot it.

    In summary. Do the install and then try to start SmartSDR. Let it fail and restart the computer and try again. Do it up to 5 times before changing anything else. It works for me so maybe it will work for you.

    John K3MA

  • unit9419
    unit9419 Member
    [{"insert":"Thank you. However it is the install itself that is failing\n"}]
  • unit9419
    unit9419 Member
    Oh my goodness! it worked!!!! Thanks Rich!
  • Aaron Weed
    Aaron Weed Member
    [{"insert":"Rich has the right idea but it didn't work for me. I right clicked on the executable, clicked on \"Compatibility\" tab, clicked on \"Compatibility mode\" check box and chose \"Windows 7\", click on \"Run this program as an administrator\". Then it ran through the installer...\n"}]
  • Stu M0MMZ
    Stu M0MMZ Member
    Over 2 years later, having installed this on a number of PCs, I ran into a problem with 3.5.9 having the same issue.
    Followed the instructions as above and it decided that it wanted to installed in Compatibility mode for Windows 8.

    System is an old i5 running Windows 11 which was forced as it doesn't have the correct hardware.

    Thank you Rich for your insight.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.