Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SO2R with 6600 and N1MM+ for RTTY Contests

Lawrence Libsch
Lawrence Libsch Member ✭✭
edited February 25 in Third-Party Software

My SO2R setup for RTTY contesting mutes receive on the other radio whenever I change the TX radio in N1MM+. That is : I am TX on radio one and see a mult on radio 2. If I invoke a TX macro on radio 2, Tx begins immediately on radio 2, BUT radio one is muted. This also happens if I use the "Break" key to switch TX radio. I have been told this was because my antennas were both using the same SCU. However, after rearranging antenna cables for radio one on Ant 1 jack and radio 2 on Ant 2 jack and setting 6600 so radio one RX and TX on Ant 1 and radio 2 RX and TX on Ant 2, in fact muting continues as before.

Related observations: If I change TX on Flex, TX does not change in the DI. If I add preamp on radio one, it does not turn on preamp on radio two, confirming the two radios are on different SCUs.

Ideas please.

K4KGG, Larry

Best Answer

Answers

  • Tim K9WX
    Tim K9WX Member ✭✭

    Do you have the full duplex switch turned on? It's at the bottom left part of the SSDR window and clicking toggles between off and on. I am not at home right now so I grabbed this off of a YT video. In this image, the FDX function is turned ON.


  • Hi Tim,

    Yes, I have FDX on. Thanks for the suggestion. If you have any other thoughts, I'm listening.

    K4KGG, Larry

  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator

    Hi Larry, I have to believe that this is happening in N1MM. Is there an option somewhere that drives the behavior of the mute function based on TX slice?

  • Hi Len,

    I can't tell if it's the 6600 or N1MM+. If I change TX in the 6600, it does not turn on the mute in the non-TX slice (radio). But it also does not change the TX slice in N1MM+. It's when I change TX in N1MM+ that I get the muting of the non-TX radio. I don't know what controls the mute function in N1MM+. In configuring my SO2R setup, I used the Flex document "Setup for SO2R Mode with a Flex-6700 and N1MM+" by KE5DTO and K9CT.

    I asked this question in the Flex Community because I judge there are more Flexers who also use N1MM+ than there are N1MM+ users also using Flex radios. But so far no other responses than yours.

    K4KGG, Larry

  • Tim K9WX
    Tim K9WX Member ✭✭

    Is it just the receive audio for the second slice that is muted (what you hear in headphones) but you continue to get decoding in the second slice via MMTTY or whatever decoder you are using? Or, is the muting that takes place actually muting of the RF, so that decoding stops for the second slice?

  • Hi Tim,

    I can't find any RTTY signals to attempt to decode at the moment. (CW Contest) I use MMTTY and notice that the graphics in the RTTY Engine display do show signal reception when receive shows as muted and there is no audio from that slice/radio in my headset. So it appears that muting is only in the headset.

    K4KGG, Larry

  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator

    Hi Larry, well that sounds like it is N1MM doing the muting. My guess is that it was intentionally written that way. I don't know if there is an option to change that, so you might want to ask on an N1MM forum if no one with the info chimes in here.

  • Hi Len,

    Please explain why you think N1MM+ is causing the problem. Thanks.

    K4KGG, Larry

  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator

    Hi Larry, Changing the TX control in SmartSDR has no effect on muting, so that leaves a third party app as the culprit. Try shutting down all third party apps, then add them in one by one until you get the bad behavior. That should point you to the guilty party.

  • Hi Len,

    Yes, loading my SO2R RTTY profile in SSDR without invoking N1MM+ does allow me to change TX without any RX muting. Rx muting is turned on when N1MM+ is started. It does appear to be N1MM+ that's causing the problem.

    Thanks for your help.


    K4KGG, Larry

  • Hi Boyan,

    Yes, the tilde fixed it. I can now listen on radio one while I TX on radio 2. True SO2R.

    I have saved the the Flex settings to a new global profile and look forward to the next RTTY contest.

    A very large thank you.

    Also again thanks to Tim and Len.

    K4KGG, Larry

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.