Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Panadapter and waterfall frozen on new windows 10 laptop.

I would like to share a few pictures of smartsdr, windows 10 details to help solve my problem which I think is a driver problem.

I have searched and not found a how to post pictures to this forum. Following tims article on a picture is worth a thousands words, But does not describe the process. Since I do not see an attachment tab anywhere..... I assume I upload my picture to online hosting site and paste the link here.

Please share the post that I could not find, so I get onto solve the windows 10 issue.

Thanks in advance



  • k3Tim
    k3Tim Member ✭✭✭

    There is a paper clip at the bottom of the bounding box where one types in the comments.

    One can attach a JPG / PNG image file to post.

  • ShawnQuinn
    ShawnQuinn Member ✭✭
    Thanks for the answer Tim. Inside the bottom left of the bound box I do not have an option to post images thru a url when I am logged into the flex community, however if I log out and revisit this post there is a option then to up load images thru a insert media "url" . I'm wondering if I don't have privileges yet, to post images yet. Can someone confirm or deny this is the case. Im using chrome as the browser.

    Copy and paste this link and you will see I have no options to include attachments.


    It seems silly I would have to put a ticket in to request something that can be solved by the good users of the FLEX COMMUNITY.


  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin

    @ShawnQuinn Correct. You need more Community points before you can post images (this is a mechanism to prevent spamming).

  • ShawnQuinn
    ShawnQuinn Member ✭✭
    I have a 6400m running 3.1.12. On my windows 7 PC everything works as it should. Just received new windows 10 Laptop, this is when the problems started.

    Problem is the panadapter and waterfall do nothing. They display what ever is going on when first launched, then freeze. The slice A window cuts off most of the frequency display. I can transmit, tune, move slice around everything else appears to work.

    Since I can not post pics to this forum yet. Please copy and paste the link below to see image of above.


    Here is the display windows settings. Please copy and paste the link below to see image.


    Here is a close up of slice A window. Please copy and paste the link below to see image.


    Here is a copy of Network Diagnostics. Please copy and paste the link below to see image.


    The new windows 10 laptop is connected directed to 6400m by cat 6 (non-shielded). Cable is GOOD.

    Here are the window10 and Laptop stats. Windows 10 is up to date. Please copy and paste the link below to see image.




    I can show a list of drivers from the cmd window, however the list is very long, would be a lot of screen shots. If there is any particular driver that needs to be shown let me know and I will capture and post links to them.

    I apologize for the long post with all the copy and paste links, however I don't a see I way to provide the information required.

    Thanks in advance

  • ShawnQuinn
    ShawnQuinn Member ✭✭
    Here is my Cat connections currently. Please copy and paste the link below to see image.



  • ShawnQuinn
    ShawnQuinn Member ✭✭
    All fixed, turns out the PC graphics adapter/driver combo has a defect. For a temporary workaround solution, the Hardware acceleration has been disabled. Tim Ellison provided me with a line of text to add to the Registry.

    SmartSDR 3.1.12, Works as it should now. FlexRadio customer service is awesome!

    Special thanks to Tim Ellison for his quick attention to this matter.

    Merry Christmas all.

  • I am having the same problem after installing on a new WIN10home computer. What was the solution??
  • ShawnQuinn
    ShawnQuinn Member ✭✭

    Hi Roger

    I submitted a Ticket, the reply Tim provided, is a work around till intel can provide a fix. My Smartsdr 3.1.12 waterfall and panadapter work as they should now.

    "If so that graphics adapter/driver combo has a defect for the GPU implementation and a temporary workaround solution The bug is in the Intel Iris Xe hardware acceleration implementation. Hardware acceleration has to be disabled. 

    Below are the registry commands for disabling hardware acceleration and re-enabling when a fix is available.

    Copy and paste the following into the Command Prompt with administrator rights and press the Enter/Return key.

    reg add HKCU\SOFTWARE\Microsoft\Avalon.Graphics /v DisableHWAcceleration /t REG_DWORD /d 1

    To re-enable:

    Copy and paste the following into the Command Prompt with administrator rights and press the Enter/Return key.

    reg delete HKCU\SOFTWARE\Microsoft\Avalon.Graphics /v DisableHWAcceleration

    I did try the lasted drivers but only worked for a short time, so went back to the registry change above. Works again as it should.




  • Ted S
    Ted S Member ✭✭

    If the new drivers worked only temporarily, you may find that that an OEM maintenance utility rolled back the driver to an older version. I had to disable HPs driver update utility auto update feature, as it kept rolling back the new Intel driver. This was because the Intel Driver was newer than the one available on HPs website.

    After disabling the HP driver update utility and reinstalling the latest Intel Driver the fix became permanent.

    Ted WR4T

  • The registry command fix the issue on my ACER Swift I7 with Intel Xe graphics. :-)


    Alessandro i2sva

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.