Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can't Connect to DLI Web Power Switch over the Internet

Reggie
Reggie Member ✭✭

Hi,

I am trying to connect remotely to a DLI Web Pro Switch Pro to turn/off my Flex 6600 through the internet. I configured port forwarding to Port 80 on a ASUS RT-AC88U router, and I set a static IP address on a Web Power Switch. I also set up DDNS using myname.asuscomm.com.

When I use a computer on the same LAN as the Web Power Switch, I can ping and connect to the switch using the local IP address of the switch and the WAN (public IP) address assigned by my internet company. When I tried to connect to the switch via my smartphone 4g, the connection times out.

When I try a to connect to the switch using a computer on a different network, I am unable to ping or connect to the switch using the myname.asuscomm.com or WAN IP address of the router.

I notice when I go to the Network Map in the router, sometimes the Web Power Switch IP address and Mac Address is displayed in the Clients List, and it indicates that the Client IP address is static; other times, the switch is not listed in the Client’s List. When it not displayed in the Client’s List, I can still ping it and connect to it using a computer on the same LAN.

I have tried to use ports 8080 and 8443; however, the connection times out when I try to connect using myname.asuscomm.com or the Wan IP address.

When I checked ports 80, 8080, and 8443 using the Port Forwarding Tester website, the tests show these ports are closed on my Public IP (WAN) address.

I manually assigned the Web Power Switch IP address in the router under LAN – DHCP Server, but I get the same results. I can connect and ping the switch using a computer on the same LAN using the Wan (public IP) address, myname.asuscomm.com, or the Wan IP address, however, I can’t ping or connect to it using my smartphone or from a computer on a different network.

Is there some configuration that I missed that is blocking my ability to connect to the Web Power Switch via the internet using my smartphone on 4g or using a computer on a different network?

Thanks,

Reggie

Comments

  • Is your Internet provider blocking ports? Try using a non-standard port such as 1955.

    From a computer on your LAN go to myip.com to determine your public IP. From outside your network try connecting to your Web Switch Pro by using the IP address followed by :1955 (or whatever port you assign. That is a colon between the IP address and port number, no spaces). In the router port forwarding don't forget to port forward the new port to the IP of the Web Switch. If that works then there is an issue with your dynamic DNS service.

    If that does not work then possibly your ISP is using double NATting, meaning they have one public IP address which they use to serve several different customers. Smaller co-op ISPs sometimes do this. In that case the ISP would also need to set up specific port forwarding in their routers.

    As far as the Web Switch intermittently not showing up in the device list on the router - you should set up DHCP reservations in the router for the MAC address of the Web Switch Pro and your radio so they always get assigned the same IP. It is not recommended to use static IP address in case you ever move the equipment to a different network with different subnet scheme.

    Once you get it working you might want to check out Node Red. I wrote a flow for Node Red to control the Web Switch Pro (and other equipment including the Flex) from a browser on any device, including Smartphones. Node Red server can run on several different platforms including a Raspberry Pi, Windows, and MAC OS.

    73

    Dave wo2x

  • Reggie
    Reggie Member ✭✭

    Dave,

    I resolved the issue. I had a typo in the gateway IP address on the Web Switch Pro configuration.

    Thanks for all the help.

    Reggie

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.