Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

amplifier is not outputting full power

i'm on a 220v dedicated line. the amp and radio is less than a month old. it was working fine last time I used it. Just started up the 6700 after being off for two weeks. using 100 percent drive from the radio i'm averaging 600 or so watts from the power genius. my swr is also not an issue. i'm new to flex and there could be a setting i'm missing. Does anybody have any suggestions? thanx

Answers

  • KD0RCKD0RC Broomfield, COMember ✭✭✭

    Have you checked your mic gain setting?

    73,

    Len, KD0RC

  • PatrickPatrick WH6HI KauaiMember ✭✭✭

    100 percent drive could be driving amp into fold back? Maybe.....

  • k3qhk3qh Member
    thank you for the quick response, not sure what the problem was but I fiddled with the mic gain and a few other buttons and things seems to be working OK. This is an awesome piece of equipment!
  • KD0RCKD0RC Broomfield, COMember ✭✭✭

    Glad you got it working!

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.