Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Your session has expired. Please log in....

KC9FFV Member
Hello everyone,

I'm having an issue with my Maestro.

When I try to connect to my local radio over the LAN it works fine, as soon as I try to connect to a remote radio over the internet it does the login, shows me the remote radio in the list of available radios but when I try to connect I get a grey window pop up that says:" Your session has expired. Please log in..."

I tried with other friend's radios/accounts and it always does the same thing.

I searched all over the community but I didn't find any postings about it.....

What am I doing wrong?
Anyone has any idea?
Thanks in advance!


  • BY5EA
    BY5EA Member
    I have the same problem
  • Toffy
    Toffy Member ✭✭

    Me too

    Tof dj6zm

  • Marc
    Marc Member ✭✭
    same problem here. Your session has expired. Please log in...
  • DM2DZM
    DM2DZM Member
    :D Here sri also
  • M0UNN
    M0UNN Member
    Same problem here since last night. Was operating in Ukranian Contest, went for a glass of wine and came back to be greated by a message to sign back in to Maestro. I can sign in into SmartLink account, can see 2 of our radios there, but as soon as I connect to any I get
    'Your session has expired.Please log in...'
    Is there a problem at my end or is there a problem with SmartLink or something else?
    Your suggestions much appreciated...
  • ka9ees
    ka9ees Member ✭✭✭

    I don’t have this problem. I’m sure you all have tried this. Do you need to re-register SmartLink?


    Ed KA9EES

  • Marc
    Marc Member ✭✭

    now I know two more guys, with the same problem.

    Maestro and SmartLink doesnt work. ,

    Flex please fix it!

  • Ken Hansen
    Ken Hansen Member ✭✭

    Having same issue.

    I registered my new-to-me 6400 to my smartlink account, thought I contacted it over smart link before I left the remote radio, now it (maestro) accepts my credentials, I select the SmartSDR version to run (3.1.12), it shows my remote radio, but upon selecting it, I get 'session expired' message. Frustrating, as I thought I tested this before I left remote location.

    If I need to register the Maestro on the same local network as the radio, I can do it, but that's 90 minutes out of my life each way...

    Has anyone experiencing this issue found a solution?

    selecting Smart Control Mode

  • SM0OEK
    SM0OEK Member
    Same here. A friend of mine could use his Maestro on my Radio w/o any problems, but I can't use my Maestro.
  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin

    This issue appears on some Maestros using SmartLink accounts, we're investigating. We'll update folks when we find the root cause and have a plan to fix.


    Dan, N7HQ

  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin

    As of 4PM CST today (2020-11-10), this issue is resolved and SmartLink should now be functional for all accounts and platforms including Maestro.

This discussion has been closed.