Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

High keyboard latency - low CPU usage- when running multiple instances of JTAlert

Hi Folks,

As a Flexradio user and I typically operate WSJT-X with at least 4 bands running simultaneously via my 6700. I will feed each slice of the Flex to a different WSJT-X process, and then I will run an equal number of JTAlert instances, each capturing the UDP stream of the individual WSJT-X process. Being able to monitor every band I'm interested in simultaneously is the primary reason why I chose to buy a Flex radio.

I have noticed that as I add more JTAlert instances, my Keyboard latency will decrease linearly. By the time I have reached 4 processes, the latency is to the point where typing is very difficult. It feels like 500ms or even higher.

My system is not taxed at all with all these programs running, I have a 12-core 4.0Ghz processor, and 32GB ram with a very fast GPU, and NVME storage. CPU usage while decoding 4 bands is 10- 20% & memory consumption is about 50%.

I have tried debugging for most of the day, and can confirm that the latency only happens with multiple JTalert instances running. I do not feel any keyboard sluggishness when I add more WSJT-x or Flexradio slices.


I have opened a discussion on the JTalert support site & at least one other user confirmed the same thing. If you have experienced this problem, please chime in on this thread at hamapps support.

Thanks in advance!

W9PDS

https://hamapps.groups.io/g/Support/topic/77022792?p=Created,,,20,1,0,0::recentpostdate/sticky,,,20,2,0,77022792

Comments

  • Patrick W9PDSPatrick W9PDS Member ✭✭
    [{"insert":"Thanks to the community for helping to troubleshoot. We can confirm this is a real issue, (specifically with Flexradio users since we run multiple instances) and we did find a work-around. I posted the details in the thread above but you need to go into JTAlert settings, Miscellaneous, Hot Keys, and disable all Hotkeys. \n\nI am currently running 5 instances & am able to type this message at the same time.. It was impossible to do this prior. \n\n73,\nW9PDS\n"}]
  • Patrick W9PDSPatrick W9PDS Member ✭✭
    edited October 2020


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.