Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

cant connect via smartlink or through home network

KI4P Member ✭✭

Hello all!

i have read the post on networking issues, my 6400 has been working on my network and via smartlink, tried to connect the other day using my IOS app and didnt show the radio via smartlink but did on network, but when i click on network it comes right back to the connect page, so I redone the port forwarding and still no luck, double checked the ports according to the smartlink setup and they are same. something has went crazy in the last week or so, only thing i have done to PC was add webroot and malwarebytes, have disabled webroots and still no luck, cant turn malwarebytes off that i can see, may have to delete it and try that. ill include a snipit of the router port forwarding. so any help appreciated

Thanks Richard - KI4P


  • Ted  VE3TRQ
    Ted VE3TRQ Member ✭✭✭

    When you hover over the radio in the SSDR radio chooser, it will show what the configuration of the radio is. Does it still have the IP address you expect? i.e. did anything strange happen to the radio address assignment?

  • KI4P
    KI4P Member ✭✭

    all info shown when you hover and in setup shows same as in the attached pic. IP address same, port numbers match as above. disabled virus and malware on computer just in case restarted modem/router, switch, radio, computer and all. at work now but just thought of something is too check if its using ipv4 or ipv6, dont know how that would change but who knows, but desktop connects fine.


  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited September 2020

    For SmartLink:

    Use different port numbers. If you have UPnP enabled, then you probably have conflicting ports.

    Also, make sure you are not double NATing too: How to Determine if your Network is configured for Multiple NATing

    For the Local LAN:

    Virus scanners and Internet security suites can block the radio from communicating with the PC that is running SmartSDR. You have to figure out which one is causing the problem and figure out how to "whitelist" the broadcast based network discovery protocol the radio uses. Or remove the offending program.

    In general, Windows Defender that comes with Windows does a very adequate job of virus protection as long as you adhere to safe browsing practices as nothing will protect against zero day threats. I find that the third-party addon software causes more trouble than any value from added protection.

  • KI4P
    KI4P Member ✭✭

    as stated above! still no luck in connecting. connects fine via my WIFI, but smartlink will not connect, can not get it to go green, tried deleting port forwarding and redoing them multiple times. reset radio from static IP to DHCP and no luck, hasn't been a real issue but now its getting very frustrating! it has worked in the past but quit and will not connect! I'm no it guy but I don't see any way to check and see if my router has UPNP enabled, only see port forwarding! By way I am using the IOS app to try and connect, IOS Ver 14.0.1, even changed the IP on the app to same as my radio as Michael suggested earlier.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.