Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Ios 14 update issue

After updating my iPad to iPadOS 14 I can no longer see my radio on the local network. I can still see the radio on SmartLink.

I believe the issue is that the app does not “ask for permission” to use the local network. If you look at the settings app at Settings-> Privacy -> Local Network you will see a list of apps that have requested access to the local network. Unfortunately, SmartSDR for iOS isn’t in that list.


  • Bob K8RC
    Bob K8RC Member ✭✭✭
    • Start the app
    • Go to Settings-Show Extended Settings and change LAN mode from 'Discover' to 'Scan'
    • Go to Panadapter and tap the screen to connect
    • Allow it to use the LAN when it asks for permission. If it doesn't find anything that's OK.
    • When the scan completes return to Settings
    • Change 'Scan' back to 'Discover'

    Just conjecture on my part, but I believe this works because, as you have found, after the update, the app doesn't have LAN privileges established and "Discover" is a "passive access" mode. (Just listening).

    "Scan" is an active mode and requires LAN access which is requested then established. Once those privileges are established, the passive approach works.



  • Thanks Bob,

    I tried your suggestion and at first it didn’t work. I got the message “nothing found”. So I went back to extended settings and looked around some more. It was then that I noticed that the “Network” setting said “”. At one time that was a correct value (I’ve moved and changed from an Apple router to a Fios router). I changed the network setting to and retried, now it works.

    What’s puzzling is that prior to the upgrade to iPadOS 14, this was working. I’m unsure what the network setting was, Things were working so I didn’t look at settings.

    73’s Doug

  • BTW, SmartSDR for iOS now shows up in Settings->Privacy->Local Network and therefore the permission to use the local network can be disabled if you so desire.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.