Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

CWX Bug? No audio or sig after macro abort

Pat_W5WTH
Pat_W5WTH Keep Radio Fun!!!Member ✭✭

FR6400 with v3.1.12

When I fire off a CWX macro via a Function Key the macro always sends as expected, BUT if I abort the macro by pressing the straight key or paddle dah/dit key the audio seems to turn off and I stop receiving sigs. The bandscope shows 'flat noise' and the pan adapter does not update. The only way to restore normal operation is a quick restart of SmartSDR.

It doesn't happen every time, but it only takes 2 or 3 attempts to duplicate the issue.

SmartSDR or User problem?

Thanks,

Pat / W5WTH

Comments

  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator

    Hi Pat, I have been trying to recreate your issue, and can't seem to. I did it on a dead band with the power turned down to 1 watt which got me thinking... Can you reproduce the issue at extremely low power? If it only happens at higher power, then there is a possibility that RF is getting in somewhere causing your issue. If it happens at 1 watt, then it is likely something else altogether.

    Another thing to look at - are the CW paddles plugged fully into the socket on the back of the rig? I don't know if this could cause the issue, but it is an easy thing to check to be sure.

    73,

    Len, KD0RC

  • Pat_W5WTH
    Pat_W5WTH Keep Radio Fun!!! Member ✭✭

    Len:

    Thanks for helping me sort this.

    I was pretty certain I did the tests on low power so I wouldn't be sending test garbage into the airwaves. I did double check that this morning and used 1W. I decided to do a (****) video of the result and happen to reproduce the issue on the 1st macro abort. In the vid the macro abort was done by pressing a straight key connected directly to the rig. I did do unplug/replug the CW key before the test.

    Pat / W5WTH

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin

    @W5WTH do you have Break In enabled?

  • Pat_W5WTH
    Pat_W5WTH Keep Radio Fun!!! Member ✭✭

    @Tim - W4TME , Yes. Screen cap is from the vid.

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin

    @W5WTH it is a little hard to tell, but do you have Iambic off? If so, can you enable Iambic and see if the behavior you reported persists?

  • Pat_W5WTH
    Pat_W5WTH Keep Radio Fun!!! Member ✭✭

    @Tim - W4TME .

    Thx. The 6400 was not iambic enabled in the vid. I made the change and enabled iambic as suggested. I left the power at 1W.

    No change. The result is still the same when I interrupt the CWX macro. Also, it doesn't matter if I hit the 'dit' or 'dah' paddle to interrupt the macro.

    One more data point..... to rule out the PC running SmartSDR as the issue I decided to completely turn off the PC and tried to duplicate the problem with the Maestro (2nd Gen). Same result with the Maestro and with the PC.

    Thanks again for the help.

    Pat / W5WTH

  • Pat_W5WTH
    Pat_W5WTH Keep Radio Fun!!! Member ✭✭

    @Tim - W4TME One additional test I was able to run thanks to the YL running the vacuum cleaner right now.......

    If I disconnect my ant with the 6400 functioning normally the noise level drops to about -120, but I could still see some interference spikes due to the vacuum cleaner. When I forced the issue to occur by aborting a macro the noise was still at around -120 (pic above) but flat all the way across with no vacuum induced interference spikes.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.