Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Spurious TX harmonics at FT8 on JTDX...

Gerry
Gerry Member ✭✭
What cause these spurious TX harmonics on FT8 and its possible solutions?

I monitor FT8 frequently on 20m and the Flex looks great with spots overlayed on the pan adapter... I installed SliceMaster to handle all the settings for JTDX to function. Works very well!

image

The problem arises when I try to reply to a CQ... The Flex panadapter now looks like this and WHOA!

image

Where are these harmonics coming from?

I manage to complete the QSO, though. But TX with these birdies, I felt, was not good. How to eliminate these? It happens each time I TX, when I reply to a CQ or when I CQ myself.

It may be interesting to note that, when I TUNE using the Flex TX radio controls, I get this beautiful, crisp signal (we kinda expect this)... centered on the FT8 20m frequency.

image

BUT when I TUNE from the JTDX program (right-hand side of program screen with other Tabs - Monitor, Bypass, etc) I get this -

image

All the harmonics appear! JTDX must be the culprit...

I have not found any JTDX setting to fix. I have made sure the Working Frequencies enumerated in the Files >> Settings>>Frequencies contain ONLY the FT8 frequency (deleting/taking away other frequencies added for F/H mode in the band). At TX the harmonics appear.

I suppose this is the same for the other FT8 bands on JTDX...

Any suggestions?

73s
Gerry
DU7EYG 


Answers

  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator
    edited April 2020
    Hi Gerry, I don't think those harmonics are actually being transmitted unless you are overdriving.  To be sure, put your radio into Full Duplex (FDX button, lower left) and open a second panadapter. Select the RX A receiver (no antenna connected). Transmit the FT8 sig into a dummy load. The second panadapter can be zoomed in or out to give you a good look at the signal. This will be a much better representation of what you are actually transmitting. If you still see crazy harmonics, try reducing the drive until it clears up.

    73,
    Len, KD0RC
  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator
    edited June 2020
    You are severely overdriving the audio level.

    open DAX control panel and adjust DAX TX lower. If you watch the level meter on right side of main gui screen there is a bar graph that starts from the left and a single “box” tothe right of it. You want to adjust DAX TX so that the single box is just to left of zero (right side). The far right should remain yellow, not red. 
    Right now your level is so high the single box of the level meter is buried to the right.

    Here is how it should look.



    73
    Dave wo2x
  • Gerry
    Gerry Member ✭✭
    edited April 2020
    Thanks, Len (KD0RC) and Dave (WO2X)! ISSUE IS SOLVED!

    Both of you mention the matter of overdriving the audio level... perhaps JTDX is causing it.

    At JTDX, I moved down the Power level a tad bit and the "spurious harmonics disappeared."

    Using what Len suggested about seeing what actually is transmitted, the birdies do not seem to be  transmitted.
    Using what Dave suggested about DAX control, the DAX TX level now does not overshoot the bar graph.

    These two suggestions have confirmed independently what adjusting the Power level at JTDX does.

    At TX, the panadapter now looks right -




    Again, my heartfelt thanks to the Community. This "virus vacation" is now put to good use. BTW, my Flex 6400 is about a month old! 

    73s
    Gerry
    DU7EYG


  • Andy M5ZAP
    Andy M5ZAP Member
    edited April 2020
    Hi Gerry,

    I noticed from your screen shots that even though you are overdriving you are only indicating 40w transmit power.

    If you check that you transmit audio filter is wide enough for the the audio frequency range you are trying to transmit.

    If you are receiving with a 3k filter and want to transmit anywhere within that region you will need to set your transmit filter to be 0 to 3000 plus a bit depending how steep the filter edges are.

    If you are using WSJT-X software then you can within the software settings in the "Radio" tab set the split operation to "Fake it" and then when the software produces a tone it will shift the  transmit freq of the radio and keep the tone within a tighter mid range so a wider TX filter is not required. To use this you will need to have the WSJT-X software CAT communication setup with the flex to allow the software to set the revised transmit freq.

    Andy M5ZAP
  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator
    edited April 2020
    YES!  I love it when a plan comes together!  My Flex is about as old as yours.  I don't know how I lived all these years without a panadpter...
    Len
  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited April 2020
    To prevent the generation of audio transmit harmonics in DIGU/DIGL, the level peak indicator must not be above 0 ( red ).  Going above 0 will not generate more useful RF output.  Staying below 0 should insure a clean signal.   You can control the level either with the output control in WSJT-X/JTDX and/or the 'TX gain' slider in the DAX GUI.

    AL, K0VM
  • MENARD PHILIPPE
    MENARD PHILIPPE Member
    J'ai mon DAX a -10 db et pourtant j'ai des harmoniques à l'émission .
    Test fait en mode FDX sur deuxième VFO
  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    I find with WSJT-X I leave the power slider in WSJT-X up all the way and set DAX TX to 48. This keeps the peak indicator just below zero (yellow).


    Dave wo2x

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    @MENARD PHILIPPE

    Désolé je ne parle pas français. J'utilise Google Traduction.
    J'ai mon DAX TX réglé au niveau 48. Puissance WSJT-X au maximum.
    
    Quelle est la hauteur des éperons par rapport au signal de transmission réel ?
    


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.