Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can't set DAX TX as default output device

w5ap
w5ap Member ✭✭
edited February 2020 in DAX
Under latest Win10, I can't set the default sound device for the output to DAX TX, because the default button in sound devices is grayed out.  I've already re-loaded all the DAX drivers. This is a windows problem that could not be resolved by doing a windows problem solver (shows an icon with device not fixed) or by going back to a previous restore to an earlier date on the computer.  Help or ideas appreciated

Comments

  • Craig_KØCF
    Craig_KØCF Member ✭✭
    edited February 2020
    Under recent SmartSDR versions, no DAX device can be a Windows default device.
  • Larry Loen  WO7R
    Larry Loen WO7R Member ✭✭
    edited February 2020
    Why do you want this as the default?  I don't see this as a good choice at all.  You will have various Windows' junk playing music and ads through your radio.

    Modern browsers, particularly, are ridiculously aggressive about playing ads even when you supposedly have the sound turned off.
  • w5ap
    w5ap Member ✭✭
    edited February 2020
    I'm not sure what you're suggesting as I don't want windows anything set as the default. I want to use DAX TX so that I can transmit with N1MM with MMTTY selecting the TX DAX as an output so that it can send AFSK for example. So far I have been able to disable RealTeck hi def audio which is the default audio output device. And Craig, if I don't select DAX Audio TX, doesn't the DAX control panel show DAX output streaming in yellow instead of green?  So is this caused by SmartSDR?
  • Larry Loen  WO7R
    Larry Loen WO7R Member ✭✭
    edited February 2020
    I suspect you have conflated two different things -- selecting the right DAX stream for use by your ham software and the Windows setting for the "default output device".  Some software deliberately uses the "default device" whereas ham software, particularly SmartSDR is essentially set up to _set_ a particular device.  In fact, whether on a Flex or not, ham software is looking for some kind of "not the default" audio device.  In a slightly different way, SmartSDR is also.   Now various software that asks for an explicit device driver will let you set the default  device (Windows is not really set up to prevent this) but it is pretty certainly a bad idea if such a device is sending audio to or from a radio, any kind of radio.  That's why Flex has apparently told Windows not to use DAX as a default and, I infer, Windows is now noticing and respecting this on your machine.  It should have always done so, but never mind on that.

    Windows sometimes has some weird ideas about what the default device should be; Flex saying "I am not a default kind of device" for its drivers/devices is a good idea.

    Meanwhile, you explicitly setting which DAX stream you want (even on a 6300 you choose between DAX 1 and DAX 2 for instance) is the behavior you want.   You do _not_ want any of DAX 1, DAX 2, or DAX TX set as the Windows' default lest other software on that PC use them, probably at the worst possible moment.

    To use a DAX stream you neither want nor need it to be the Windows "default" device.  You need to explicitly set the DAX stream you want in the software of interest, be it SmartSDR, WSJT-X, or some other ham software that deals with audio.   If the device in question is _not_ the default, you get your radio used the way you want it to be used.

    With all DAX never as the default, no other Windows code will ever try and use it.  Why?  Because that other kind of software simply "reads from" or "writes to" the "default" audio stream.  Why would anything do so?  Such software expects to be the "regular" speaker or microphone actually used by the user.  Some machines have more than one microphone and speaker but a lot of software just wants "the one the user said is the default mike or speaker".  Such software thinks it can use those kind of devices any old time it likes.  A web browser making such a choice is perfectly reasonable, for instance.  But a DAX stream is not such a device, not ever.

    Remember, you said:

    "Under latest Win10, I can't set the default sound device for the output to DAX TX"

    This is what you almost certainly do _not_ want to do.  You want to explicitly set DAX TX (and the other DAX numbered streams) in the ham software of interest.  Something else should be the default audio device(s).
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited February 2020
    You should never use a DAX device as a default Windows audio recording or playback device.  This can cause all sorts of issues, so the most recent versions of DAX do not allow for this.  You need to use a physical sound device, line an embedded sound card or a USB audio device connected to the PC to provide the default recording and playback audio devices for Windows.
  • w5ap
    w5ap Member ✭✭
    edited February 2020
    Thanks to all who responded to my concern about grayed out sound device default settings. Especially Lary's WO7R comprehensive explanation. I only understand marginally the connections between Windows 10 and SSDR. I always in the past set the  DAX TX as the default device in MMTTY and in the Windows sound card selection process and all worked fine. Then this last weekend during the CQWWRTTY WPX test, for what ever reason, I couldn't transmit.  Looking at the default output selection, I saw (for the first time) that I could not anymore select (because it was grayed out) DAX TX as a default.  So I spent 5 hours trying to fix that and even did a restore from a previous point. It didn't work.  Kind of ruined this contesting event. How was I supposed to know that I shouldn't select DAX TX as a default?  Did I miss an announcement? It seemed logical to me that something was wrong with Windows, or SSDR, or my sound card. I didn't know where to start. But as I stated, I'm a user, not a computer guru.  Thanks to all es 73, Jim

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.