Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

DAX corruption

Mark_WS7M Member ✭✭✭
edited October 2019 in DAX
Hi all,

This issue is not specific to 3.1.8 but it seems to remain.  I have a Flex-6600.

My poor computer has had a fair number of SmartSDR versions installed including Alpha Test versions.  I've removed all but 3.1.8 and restarted to ensure the system is fairly fresh.  System is a Windows 10 machine on the latest OS version with all updates installed.

I've been doing some work on FRLogger with respect to better support of FT8 and FT4.

I have noticed that after some period of time WSJT-X simply stops decoding.  My time is NTP'ed and pretty much spot on.   The signals in the wide graph look good.  Dax level looks good, there are signals on SmartSDR and the slice is set to the correct DAX channel but decoding just stops.

I have taken baby steps to resolve the issue:

1) I have turned the DAX channel off then back on - No improvement
2) I have changed slice Dax channel to none then back to 1 - No improvement
3) I have terminated WSJT-X and restarted it - No improvement

The only thing that seems to solve the problem is to terminate DAX using the DAX control panel and restart it.   Of course to do this I have to terminate WSJT-X and restart it.

I have a friend across town that I sold my 6500 to a while back and he pretty much leaves WSJT-X up and decoding on 4 slices 24/7.   I will ask about his OS and other specifics but the simple fact is that he does not end up with corrupted DAX.

The strange thing for me is that there is no obvious indication that DAX has gone south.  The wide graph looks fine, the Dax levels look fine but nothing decodes.

I seem to remember there were other threads about similar issues but I could not find them.  I'm wondering if someone has experienced the same issues and if there are any known fixes.

Mark - WS7M


  • John - AI4FR
    John - AI4FR Member ✭✭
    edited October 2019
    Mark, I've noticed several DAX issues and something similar to what you describe. I am not a causal user of WSJT, not a weekend warrior, I usually have 2 instances of wsjt running(FT4, FT8) between 3 monitors all day long. I normally park on a band and wait for a call to appear that is not in the log(band/mode) yet as I get other things done.

    When wsjt stops decoding please take note if the "Decode" button is lit a solid baby blue color. I have seen this often and restarting that instance of wsjt solves the issue. The symptoms when this happens are exactly as you described above. I am not sure if this is a Flex issue but have seen it reported occasionally every once in a blue moon on various sites. I think the problem happens more often then we realize and folks are not catching it unless they are paying very close attention. As you said, it looks like it is working but it is not.

    Yesterday, every so often wsjt would skip a decoding cycle on me here. So far today with a fresh reboot all is fine.

    There are other DAX issues with one in particular in that DAX is sending way too much signal to your digital programs as seen here. https://community.flexradio.com/flexradio/topics/dax-rx-issue-on-ver-2-5-and-up Notice the pics towards the end of the thread for what to watch for in DAX.

    I've been wanting to park on a digital signal such as the German RTTY weather signal on 30m or some all day long digital signal to see if other software programs besides wsjt exhibit this behavior but have not done so as of yet.

    Win. 7 pro = CAT 5 into router
    i7 980x 12 cores, 24gigs ram, 2 GPU's
    Flex 6700 = CAT 5 into router
    SSDR 3.1.7

  • Harold Rosee
    Harold Rosee Member ✭✭
    edited October 2019
    I know to have gone to DAX channel 1 to none and back to 1.  Have you tried a totally different channel.  I was having a similar problem and changed to DAX 3 and hadn't had any issues since.  I can't explain why and don't care at this point in time.
  • NR4O
    NR4O Member ✭✭
    edited October 2019
    Mark, I'm a relatively new owner(mid-August) of a Flex-6600.  I reported a problem with DAX audio corruption issues that are very obvious when operating WSJT-X and RTTY shortly after got the radio up and running on digital modes.  I can tell when the stream is corrupted by looking at the WSJT-X spectrum graph.  An FT-8 signal edges become less sharp and get what appears to be a high frequency sign wave super-imposed on the signal.  You may also see what looks like smearing of the signals on the waterfall graph. The only recovery for me is to close DAX and restart it. 

    Flex support says this is a known problem they're working to solve that only shows up on some windows 10 systems.  I found that occasionally the network response time on my system spikes momentarily to several hundred milliseconds.  That seems to trigger the DAX corruption. 

    There is a tool available on the Flex support site that you can use to monitor the network response time and help identify when the response time gets too long and attempts to identify drivers that may be contributing to the response time.  You may want to try to run the tool and see if it may be an issue on your system.

    It's an annoying problem because it happens randomly and fairly often, on the order of once or twice an hour.

    I'm still trying to figure out what on my system is causing network response issues.  I am likely going to reload my Windows 10 system from scratch to see if that corrects the issue.  But, it's a time consuming process. 

    Hope this helps,
    Eric - NR4O                
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited October 2019
    Hi all,

    Interesting info.   John I will check your links out.

    Harold, a different Dax channel is worth a try!

    Eric, great info.  I sort of knew it was a known problem.  I guess I was hoping 3.1.8 had fixed it but it appears not.  I will try the network stuff.
  • KM4CQG
    KM4CQG Member ✭✭
    This problem has plagued Smart SDR on all versions. The only quick fix is to shut the DAX Control panel then manually restart it as already mentioned.

    I have found running Web Browsers and Youtube videos makes the problem worse.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.