Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Smartlink Not working after 3.1.8 Upgrade

W2ECK Member ✭✭
edited October 2019 in FLEX-6000 Signature Series
After doing the upgrade to 3.1.8 ( or possibly 3.0.19), I noticed Smartlink wasn't connecting. Did the Test on the Smartlink Setup screen and the Test fails. The last time I attempted to use it, all worked fine. I have made no changes to any of my Network settings or Network hardware. Anyone else run into this issue or have any ideas on a cure??
72 Paul w2eck


  • Dave KØKQ
    Dave KØKQ Member
    edited October 2019
    For me, Smartlink has started working with the upgrade to 2.6.1. Hasn't worked for six months, works great today, remoted all weekend.

    I believe that Smartlink working now is coincidental to the SSDR upgrade; it's about the quality of the line. Mine is a very remote Century Link DSL line over former voice twisted pair. CL made changes to their DSLAM infrastructure, it stopped working. Changed again, Smartlink started working. 

    On the day of the SSDR upgrade and Smartlink working again, my IQRouter arrived. Implementation has a lower priority than before, but probably holds the ultimate long term solution.

    I don't know Paul, just a data point...

  • VK7WH Winston
    VK7WH Winston Member ✭✭✭
    edited October 2019
    Dave, is your Flex obtaining it’s IP address from your router by DHCP?. If so, I wonder it your Flex LAN IP address may have changed.

    if you haven’t already done so, it  might be worth rebooting your router and the Flex and then see if you then get a green light pass for the SmartLink test.

    GL and 73 Winston VK7WH

  • W2ECK
    W2ECK Member ✭✭
    edited October 2019
    Dave & Winston - thanks for the suggestions. Quality of my internet connection is very good, nothing has change in this aspect and all was working fine prior to Upgrades. I did reboot the router and it didn't help. 
    The 6600 is assigned a static ip by the router and yes it is obtaining an ip from the router. I think I will submit a ticket.

    73 Paul
  • Steve K9ZW
    Steve K9ZW Member ✭✭✭
    edited October 2019
    Hi Paul

    Do you have anyone close at hand who can look at things for you?

    To get a "static IP" address you have to assign that - what the router does is something different.

    If I were to guess is whatever port forwarding you had might still be there, but is active for an old IP address.  

    Unless you are certain that the IP address your 6600 had before is exactly the same as what it has now?

    Might be useful to go through the original setup procedures to condition your network and radio to give a clear path and ports for SmartLink.

    Would not say you have this going on, but I had an AT&T service that I had to remove the two port forwarding rules and redo them on occasion to keep things working.  Very much a ISP & hardware issue, rather than a Flex-6000/SmartSDR issue.  

    While we don't technically "ping a port" you can check if they are open - there are lots of write ups on how to do this.  Check the ones you need for SmartLink (it's in the manual) and if they are NOT open you will have put your finger on the root network problem.  

    GL and 73


    Blog:  http;//k9zw.wordpress.com  

  • W2ECK
    W2ECK Member ✭✭
    edited October 2019
    Steve- 6600 is assigned a static ip in router  and it is the same ip that radio had before upgrades. The radio is drawing the assigned ip correctly. Smartlink setup has not changed. Still not working. :0((

    tnx & 73

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.