Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Maestro not finding radio except on home WiFi connection and LAN connection

Mike-N1VE Member ✭✭
edited April 2020 in FLEX-6000 Signature Series
The Maestro works fine using my home WiFi or LAN connection.  However, it will not find the radio after connecting to other WiFi networks.  I am assuming if it is connected to the network it should find the radio. 


  • Abed - AB5ED
    Abed - AB5ED Inactive Employee
    edited June 2019

    When connecting from a different network your radio needs to be setup with SmartLink.  Have you already done this?  If not, here are some useful links get set up:

    Quick Start Guide: https://www.flexradio.com/downloads/smartlink-quick-start-guide-for-smartsdr-pdf/

    YouTube tutorial: https://www.youtube.com/watch?v=kMbi3dAiMi0

  • Mike-N1VE
    Mike-N1VE Member ✭✭
    edited June 2019
    You are correct.  I didn't realize I had to sign in with each change of WiFi access.  Thank you.
  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited June 2019
    I wouldn't expect you to have to log in each time you change networks.  You should just need to log into SmartLink once.  Then it should work on any network outside your LAN.
  • Mike-N1VE
    Mike-N1VE Member ✭✭
    edited June 2019
    Eric,  When I got home, I turned on the Maestro and it immediately connected to my home WiFi. Then I had to log into SmartLink for me to connect to my iPad.  It's important to remember the email address and password, or write them down when planning to operate remotely.
  • K7JV
    K7JV Member ✭✭
    edited April 2020
    I am having the same titled problem.  I have a new 6400 and it is working great with the Maestro.  It works great with Dogpark, as well.  In both cases, however, I have to be on my LAN to be able to connect to the radio.  I can NOT get it to work with SmartSDR on my iPhone.  The SmartSDR on the Windows platform does not work, at all.

    Several posts on here, and some of the info I've downloaded from FlexRadio describe a solution(s) that haven't worked for me.  I've even kind of lost track of what I've tried.  The majority describe situations that don't apply, such as my radio not being turned on, or on the router, etc.  When I go into the SmartSDR in Windows, I do not see my radio.  I do get a log-in screen and am able to log in.  On the next screen I do see my name and call sign at the top of the box and a text box that says, "There are currently no radios available.  Please ensure that your radios are turned on and either connected to your local network or accessible via SmartLink."

    There is a box that says "SmartLink Setup", but it is not active and can not be selected.  That is as far as I can get.

    I thought I might be able to either disconnect (if I am even "connected") or bail completely and re-register from scratch, but I don't find any way to do any of that.

    So I am at a total standstill with getting SmartSDR to work under Windows.

    When I launch SmartSDR on my iPhone, I get a screen that says, "You are currently not connected / Tap here to connect."   When I do that, I see the Demo FLEX-6700 but my radio does not appear, even though the iPhone is on my home LAN.

    I can go to the Settings, and choose "Check SmartLink status".  When I do that, I get my name, and K7 in a big red box.  My call sign shows correctly along with my email.  Next to where it says Confirmed, it shows "No". I am able to log out and log back in, but it still shows "No".

    I welcome any ideas on what I might try to finally be able to get outside access to my radio.  Thank you, so much!  Best 73!
  • Dudley  WA5QPZ
    Dudley WA5QPZ Member ✭✭✭
    edited April 2020
    You need to have your router on your radio local LAN passing the correct Internet ports to the radio..   In Windows SmartSDR ,  at the bottom of the SmartSDR radio selection screen is the the "SmartLink"   Setup .    You should read the section of the SmartSDR User's Guide,  starting page 23


    Sign into SmartLink ,  Test the ports and be sure to save the results back to the SmartLink Server so that it can connect the radio back to your remote SmartSDR computer.. 

    By the way ,  SmartLink is not designed to work when you are on the local LAN,  only use SmartLink when you are remoting into the radio..   

    Hope this helps,
  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020

    It sounds like you have logged into a demonstration product, need to create your own SmartLink account and complete the configuration of your system.  There may be some network issue preventing your discovery of the radio as well. Please create a helpdesk ticket to resolve your network and connection problems. That will be the fastest solution.

    Here is a draft simplified description of how SmartLink works and could help you visualize how everything works together.

  • K7JV
    K7JV Member ✭✭
    edited March 2020
    Thank you, Dudley.  I will downloaded the document and will see what I can find out that might help.  As for the "SmartLink" Setup, that button is not live.  It can not be selected.  The only thing on the item other than the name box at the top is the "Settings" button, and it only offers two options, neither of which apply to the problem I'm having.

    Dudley, I am pretty unsure about the specific mission of SmartLink vs SmartSDR.  I did believe that SmartLink was only for remote access.

    I am trying to access it via the WAN using the SmartSDR app I was told that I needed on my iPhone, and it does not find my radio.

    I will try to digest the document you gave me the link to.  Thank you so much.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.