Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Transmit question with WSJT-X

Golden23412
Golden23412 Member ✭✭
edited May 2020 in Third-Party Software
I am trying to get a 6400 up and running on Windows 2.4.9.  Ultimately, I'm trying to use my Macbook Air (DogparkSDR, xdax, xcat), but for now, I just want reliable operation on my Windows machine.

Last night, I was getting FT8 QSOs on WSJT-X.  I could see in SmartSDR when it was receiving and transmitting.  During WSJT-X transmit, I could see RF power in SmartSDR was approaching 100 watts, and SWR is close to 1.4.  

Now, when WSJT says it's in Transmit mode, I don't see any RF power or any flicker on the SWR meter.

In Dax, TX Stream is on.
In SmartSDR, DAX is set as primary transmit audio source.

When I click the Tune button in SmartSDR, it does show expected tuning RF power.

In WSJT-X, Test PTT appears to work as expected, by turning on MOX, but no RF power is shown.

I can't seem to figure out what's wrong.  Can anyone point me in a good direction?


Answers

  • Lou
    Lou Member
    edited June 2019
    DAX turned on? 
  • Paul Bradbeer
    Paul Bradbeer Member
    edited June 2019
    So ptt is fine but essentially there is no tx audio when using WSJT. In the WSJT set up (from memory i think it is the Audio tab) have you correctly selected the TX Audio...I. e. The tx dax channel ?
  • Golden23412
    Golden23412 Member ✭✭
    edited June 2019
    Yes, that's right.  PTT seems fine (MOX comes on in SmartSDR when WSJT-X is transmitting). 

    Also, I can see audio in the P/CW window in SmartSDR when transmitting.

    I saw some other references to similar behavior here in the board, and have rebooted both the radio and the PC to no avail.
  • Golden23412
    Golden23412 Member ✭✭
    edited June 2019
    Ok, weird.  Everything seems normal again.  I don't know if it was something I clicked or not.  The last thing I changed before it started working again was re-selecting Dax 1 in the SmartSDR waveform window for slice A (not in the TX settings).
  • Rick N0VT
    Rick N0VT Member ✭✭
    edited November 2019
    Rebooting the PC fixed the same problem I had this morning when resuming operation in the VHF contest.  

    (If you plan to transmit a lot (like in a contest) you might want to cut your power output back some since FT8 is a 100% duty cycle)

    73
    Rick WR0H
  • KI4P
    KI4P Member ✭✭
    edited May 2020
    Try this, may work or may not, I don't run ft8, I assume you have a mic profile setup for Ft8? On my 6400 , ver. 3, sometimes when I key to talk there is no transmit, radio keys but nothing out. So I click different mic profile and just talk into Mic and it worked, switched back to regular mic profile and all was good, done me that way once today. Just an idea!
  • Ernest - W4EG
    Ernest - W4EG Member ✭✭
    edited October 2019
    Several of the suggestion that has been given are okay;
    Download J.H. Taylor K1JT Guide.
    http://physics.princeton.edu/pulsar/K1JT/wsjtx-doc/wsjtx-main-2.0.1.html#RADIO
     This is how I run my FT-8 configuration; 
    1.Download WSJT=X2.0 User Guide
    2. On the Table of Content; 
    3. Go to Paragraph 4. Settings:
    4. Follow all the instructions listed. 
    For example: Rig. Flexradio 6xxx 
    Serial Port; I use - localhost: 60001 or what ever port you want to use. And or a
                     Network Server: 127.0.0.1:60001 etc...
    Everything else will lock out and you may not be able to change.
    Except you must TEST CAT (if everything else is okay, it will turn GREEN)
    Then TEST PTT. That will tell you that the PTT is working
    5.On the AUDIO tab::
       A. Sound card: 
       1.Input: DAX Audio RX 1 (or whatever RX you want to use)
       2. Output: DAX Audio TX 
    Nothing else ... The rest of those tabs are self explanatory.
    If it still does not work? Call Flex radio doctors (lol) and they will do it for you. 
    However, you now may want to check that DAX drivers are NOT corrupted. There are
    several way to correct then, Tim Ellison and several others have written procedures to 
    do then. For example on Jul 1st 2016 Tim wrote "How to do a complete uninstall of SmartSDR
    for Window PC." Someone else re-wrote "How to manually re-install DAX drivers." Dated 26 APR 19.
    Hope this will get you going and hopefully understand a little more, how DAX works.

  • roger na4rr
    roger na4rr Member
    edited June 2019
    For some reason, sometimes I have the same thing. 6700 goes into xmit but no WSJT audio.  I have to close WSJT and restart. then all works fine.  Once running it does fine.  I figure its something in WSJT-X but who knows.  I did ok in the contest 8,880 points.  Had a good opening to Spain this morn and one to the NW this evening. 
     
  • N8AUM
    N8AUM RETIRED Member ✭✭
    edited June 2019
    I run ver 3 with Win7 and occasionally  my DAX cuts out. I just toggle the DAX and 99% of the time it will start working again. If that fails than I restart WSJT . Also had same "issue" with ver 249. Also double check the slider on the right side of WSJT and make sure its not turned down too far. I keep mine set at abt -1db
    good luck!

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.