Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Version 3 SSDR not starting properly

AC9S
AC9S Member ✭✭
edited April 2019 in FLEX-6000 Signature Series
Hello,

I am running a 6700, Maestro (original version) and SSDR Version 3 on Windows 7.  Accessed  locally, through a GS108 switch, SSDR appears to start, the chooser appears, but when I choose the 6700, the application never appears on the screen, nor does the program icon display on the task bar.  However, I can hear sound from the radio and the application shows up on task manager.  I cannot bring it to the foreground or maximize it from the task manager - both of which I can do with DAX and CAT.


The Maestro works just fine and yesterday I think SSDR when I first loaded it worked as well.  I am able to tune the SSDR receiver from Logic9, but of course that is the limit of my RX functionality from that package.  


The application is definitely running, but with the exception of Task Manager it is invisible to Win7.  The only way I can get rid of it is to **** it from Task Manager.  I have tried every permutation that I can think of powering down the 6700, computer, and Maestro.


Help!


Keith - AC9S

Comments

  • Mack
    Mack Member ✭✭✭
    edited April 2019
    Keith, One possibility is the application is offscreen. Press thee Windows Key and Right Arrow to see if that’s the case. Does the program icon appear in the task bar? 73, Mack W4AX Alpha Team
  • K1UO - Larry
    K1UO - Larry Member ✭✭
    edited April 2019
    Sounds like the SSDR window is open off your main screen..  try one of these 3 methods to snap it back to your viewing screen..
    https://www.nextofwindows.com/3-ways-to-deal-with-off-screen-window-in-windows-7

  • AC9S
    AC9S Member ✭✭
    edited April 2019
    Hi Mack,  The program icon does not appear in the task bar.  By the three Windows keys I assume you mean CTRL, Windows, and alt - plus the right arrow.

    I tried that plus throwing in the fcn key on my wired keyboard.  Nothing show on the screen.


    Thanks -- Keith  - AC9S
  • AC9S
    AC9S Member ✭✭
    edited April 2019
    Hi Larry,

    I tried these - since the program icon doesn't show on the task bar they didn't work.


    Appreciate the input.

    Keith - AC9S
  • Geoff AB6BT
    Geoff AB6BT Member ✭✭
    edited April 2019
    Is there any chance you have set up virtual desktops? I'm just taking a stab because that could explain the lack of taskbar icon and the application being off screen. I use virtual desktops a lot so I thought I'd throw it out there.
  • AC9S
    AC9S Member ✭✭
    edited April 2019
    Hi Geoff,

    No - I do not have a virtual desktop going, not intentionally anyway.

    Thanks for the input.

    Keith -AC9S
  • Geoff AB6BT
    Geoff AB6BT Member ✭✭
    edited April 2019
    As a quick check, hold down the Windows key and then the Tab key.
  • AC9S
    AC9S Member ✭✭
    edited April 2019
    Thanks Geoff,

    That is a nice tip, but all windows showed up except SSDR which was still decoding 40m.  Bizarre!

    The sequence is:

    1. Clean start up of everything - radio , computer - Win 7, switch.
    2. Start 6700
    3. Start SSDR V3
    4. Chooser shows
    5. I pick my 6700 & connect
    6. The chooser immediately appears to minimize, but does not show up on task bar
    7.  6700 is receiving
    8. SSDR shows up as an application in task manager - along with DAX and CAT which have autostarted
    9. When I **** SSDR application from task manager it disappears from the application  list, but the radio still plays
    10. The SSDR task still shows up on task list and the radio only stops playing when I **** the task from task manager.
    11. If I start SSDR, Maestro, then another instance of SSDR the chooser says there is an instance already running on my computer.

    Looks like I have a Ghost!

    Keith - AC9S



  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited April 2019
    Keith,

    My suggestion would be to reset the SmartSDR settings file.
    1. Close SmartSDR for Windows.
    2. Open a file browser and go to %appdata%FlexRadio Systems.
    3. Make a copy of the SSDR.settings file.
    4. Delete the SSDR.settings file.
    5. Start up SmartSDR for Windows (which will create a new settings file).

    The settings file contains information about where each of the Windows was last used, which could be involved in this issue.
  • AC9S
    AC9S Member ✭✭
    edited April 2019
    Thanks Eric,

    That did the trick.  I appreciate the help.

    Keith - AC9S
  • John Watson W4JCW
    John Watson W4JCW Member ✭✭
    edited April 2019
    I have a similar issue, using a 6300...everything starts automatically, but I never get to see smartlink, so I can't set it up...any suggestions?
  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited April 2019
    If Auto Connect is functioning, but you want to get back to the radio selection screen (SmartLink Setup is also there), you can use the Settings -> Choose Radio option in the menu at the top left.
  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited April 2019
    Eric, thanks for spending so much time on the community lately, it's been noticed.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.