Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

RCA TX1 Won't persist

K1ESE Member ✭✭
edited February 2020 in SmartSDR for Windows
On startup, the remote 6300 has RCA TX1 disabled.  I enable it.  If I change bands I have to enable the TX1 line each time and if I go back to the first band, it is again disabled.

I have to enable the TX1 line every time I change bands.

I have tried to use the default transmit profile, save to a different profile, and save global profiles with no success.

With the contest starting tomorrow evening I don't want to have to enable TX1 with every band change.

I am thinking there is some setting that is wrong.  The 6300 is barefoot, no DDUtil or other third party app running.  No logger running.

John K1ESE


  • Mack
    Mack Member ✭✭✭
    edited March 2019

    TX profiles, including TX1, is saved in the TX profile. Try saving your TX profile with the proper settings enabled. This is spelled out in the profiles user guide. Once you've read the guide I can help more if needed.

    The good news is that profiles are saved as changes are made in version 3 of the software so this won't be an issue in the future.


    Alpha Team
  • Pat N6PAT
    Pat N6PAT Member ✭✭
    edited February 2019
    I also have a problem with TX1 and 2 becoming disabled. Every so often they become disabled in between QSO's with no band changes.

    When my amp and key interface no longer activate when transmitting I check the setting and see that both TX1 and 2 are disabled. Enabling them again fixes the problem.

    This happens every couple of weeks for me.

  • K1ESE
    K1ESE Member ✭✭
    edited February 2019
    I enabled TX1 on 20 meters.  I saved the profile.  I went to 40m and enabled TX-1 and saved the profile.  I went to 20 meters and TX-1 was DISABLED.  I went to 40m and TX-1 was DISABLED.

    I did this with several TX and Global profiles. Change bands, enable TX-1, save profile, retry and whenever I changed bands, TX-1 was DISABLED.

    That's when I came here to find help.

    73 K1ESE
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited February 2019
    I also have this issue.
  • Tim VE6SH
    Tim VE6SH Member ✭✭
    edited March 2019
    Moi ici!

    Tim VE6SH
  • Gene Duprey
    Gene Duprey Member ✭✭
    edited February 2019
    Did you push the Load button after Save?
  • K1ESE
    K1ESE Member ✭✭
    edited February 2019
    Yes, I did click on Load.  I also started and stopped SmartSDR with no improvement. 

    Earlier I had set the timing of the TX-1 delay from 20ms to 0ms and that change persisted in all profiles.

  • Craig_KØCF
    Craig_KØCF Member ✭✭✭
    edited February 2019
    You are not doing this quite correctly... Go to each band in turn, enable TX1, set a power level if required, and any other settings in the transmit profile. Then step to the next band and repeat these steps. Continue this process for all bands. Then, after ALL bands are set, save the profile. These settings are saved on a per-band basis in transmit profiles.

  • K1ESE
    K1ESE Member ✭✭
    edited February 2019
    I could do that, but I can't get TX-1 enabled to persist on ANY band.  Why would it only work if you set it to ENABLED on all bands before saving a profile?

    I thought if I could get it to stay on one band, it would then be worth changing and saving all bands.

    Just to be clear.  If I set TX-1 to ENABLED on 40m, go to 20m and come back to 40m, TX-1 in no longer ENABLED. 

    If set TX-1 to ENABLED on 40m I save the profile, load the profile and then go to 20m and back to 40m, TX-1 is no longer ENABLED.

    Any band change DISABLES TX-1.

  • Geoff AB6BT
    Geoff AB6BT Member ✭✭✭
    edited February 2019
    Silly question perhaps, but (in your example) you don't indicate that after going back to 40M you load the 40M profile. Are you loading the profile you saved when you go back to 40M?
  • K1ESE
    K1ESE Member ✭✭
    edited February 2019
    There is no specific "40m" profile.  I ENABLE TX-1 and then save the Global and Transmit profiles that are supposed to save settings for all bands.  I then load the profiles and go back and forth.

    This is not really about profiles.  I assumed profiles were involved, but maybe not. 

    Let me ask it this way.  Forget about profiles. 

    When I set TX-1 to ENABLED should that change if I change bands?

    If I set TX-1 to Enabled on one band, should it be set on all bands?

    If I set TX-1 to ENABLED on one band, go to another band and return to the first band should TX-1 still be ENABLED?

    73, K1ESE

  • Geoff AB6BT
    Geoff AB6BT Member ✭✭✭
    edited February 2019
    I'm not currently near my radio so I can't answer your questions. Hopefully someone can be of more assistance.

  • Kari Gustafsson SM0HRP
    Kari Gustafsson SM0HRP Member ✭✭
    edited February 2019
    Hi folks, I have had a similar issue. It turned to be due to too many overlaping profiles that got mixed up somehow. Deleting and clearing up profiles solved the issue. Perhaps this is not valid in your case. Tx1 enabled is connected per band. If you change band it may not persist. In SO2R operating this is essential and you need to define per band what Tx should be enabled or not. At least this is how I have gotten a SO2R remote set up working with two amps per individual band and individual Tx power level.
  • Gayle Lawson
    Gayle Lawson Member
    edited February 2019
    I'm using  6500/6600 radios.  If I change TX1 on one band, save it, that parameter is changed on all bands.  One thing that caused me grief was the TX Delay.  It would not stay memorized.  I found that to get the Tx Delay  to be memorized, I had to change it then disable and re-enable TX1 or any other TX-1,2,3 button( that caused the star to be displayed by the TX profile) then it would save to the profile.  I have solid state amp as well as several old 30S-1s, the 30S amps need a little more delay.

    Craig your correct about setting up each band then saving the TX profile, I found that when trying set the power level for the solid state amp. 

    Gayle K0FLY 
  • Michael Coslo
    Michael Coslo Member ✭✭
    edited February 2019
    Hi Steve - here is what I would try. This is the scorched earth approach, which isn't canon. But before that...

    First, try resetting the radio. from a start, hold the button until it blinks white. After it resets and boots, see if the radio has tx persistence.  I had a problem with not transmitting on 20 meters once, and it fixed that right off.

    If that doesn't work, a total reinstall of SSDR, starting with using Revo uninstaller. The free version will work FB. Unistall, then run the deep scan for leftover files and settings. **** it all, from SSDR, the DAX and CAT programs and FlexVSP.
    note: after uninstalling, the flex software will tell you you need to restart the computer - don't do that until the deep scan and removal is over.

    But - I suspect that the reset of the radio will fix your issue and you won't have to do anything else. Let me know.
    - 73 Mike N3LI -
  • K1ESE
    K1ESE Member ✭✭
    edited February 2019
    Unfortunately, RESET didn't work.  The radio is at the remote site and there was no time before the contest to reinstall everything.

    Instead, we wired the ACC TX relay to the amp and that worked all weekend.  I have opened a Help Desk ticket.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.