Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FlexLogger V0.1.0.3

Mark_WS7M
Mark_WS7M Member ✭✭✭
edited June 2020 in New Ideas
Hi All,

I am hoping to release FlexLogger V0.1.0.3 tomorrow morning.  

Here are the improvements and changes (so far):

- Increased size of text on radio control form meters
- Increased size of text on SPE amp, KPA amp and KAT tuner meters
- Add basic LOTW support
- Spot sources now support a password if needed
- Substantial improvements to CW panel - Looping, variables, speed control
- Added a lock layout to the layout menu. This prevents dragging of items when enabled
- Added a restore default layout item to the layout menu
- Corrected a bug that was setting slice values to strange settings on radio connection
- Enhanced KPA500 and KAT tuner support
- Added a clock and map panel.  The map is not yet active

The primary changes that will need testing and attention are:

LOTW support.  This is a first pass, basic implementation.  I expect to improve it.  In this version it is manually trigged by you both for posting and checking status.  To use LOTW you need to provide the path to TQSL if it is installed in a different location on your system. 

You also must provide your station name and any password that was applied to that station when you created it.

For checking lotw status you need your ARRL login and password.

I do expect to enhance and fine tune the LOTW support and will welcome all input.

The other big change thanks to Joe N3HEE is work on the CW panel.  If you are a CW operator then the CW panel will offer you a lot to play with:

The panel supports real time CW send.  As you type a characters they are buffered and as sent they are removed and shown in a sent panel.  This allows you to see what has been sent and what is remaining to be sent.  

There are speed controls right there including the TX delay.

Both in typed in characters and in macros there is support for:

N1MM speed increase and decrease:   <<<5NN>>>
Speed can also be set with {SPEED=35} {SPEED+2} {SPEED-2}
Delays are supported:   N3HEE DE WS7M UR RST {DELAY=5000} HW CPY?
Looping is supported:  {LOOP=5} CQ CQ DE WS7M {DELAY=5000}
Variables are supported:   {CURQSO_CALL} DE {STN_CALL} HW CPY?

You can store these macros into function keys F1 to F12 and use them from any form.  So while entering a log entry you can hit say F5 to send a response if you have programmed F5

Sending of CWX either from macros or typed in can be paused and restarted using either a button or the PageDn key.

There are also quite a few small bug fixes.   On request I added the clock/map panel.  Since it is a new panel you may need to toggle the show of it using the panel menu.

If it does not show for you then as a last resort you can delete WS7MAppsFlexLoggerDataFlexLogger.layout.   Doing this will force you to reposition your panels.

So check for updates tomorrow.  I will also post the installer download link here.

Mark
«1

Comments

  • WW1SS - Steve
    WW1SS - Steve Member ✭✭
    edited April 2020
    The KPA 1500 interface is working good with my amp so far. I only ran it for an hour or so when I was home this morning

  • WW1SS - Steve
    WW1SS - Steve Member ✭✭
    edited April 2020
    Tune button does not work though
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019

    Hi All,

    V0.1.0.3 is complete.  If you have FlexLogger installed you can simply check for updates under the help menu.

    The full installer is at:

    http://184.154.226.168/flinstallers/FlexLoggerSetup-0.1.0.3.exe

    If you want to use the installer and you already have FlexLogger installed... YOU MUST uninstall first, then run the new installer.
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Upcoming feature for the map window:


  • KF3F
    KF3F Member
    edited January 2019
    Really nice software Mark!
  • bobby
    bobby Member ✭✭
    edited January 2019
    Panels still have issues, slices dont check properly and cant for the life of me figure out how to get slice A to merge with B and setup as I had it in 0.9.2 so went back to that version which is great and easy to use. Fortunately installed 1.03 on win 7 while 0.9.2 is on win 8.1 and works great!

    You do a great job Mark but I think your falling into the issues I have with most software, you want to add so much that its getting to a point of complexity that there is more bugs that are not corrected before other features are added, but actually thats what flex is doing with there software as well, the only difference is your doing a better job with more updates and not charging for it.

    Keep up the good work for now I will stick with .0.9.2 which does all I need without issues, Thanks again :-)
  • W7NGA
    W7NGA Member ✭✭
    edited January 2019
    I'm concerned about the red blob. Please tell me it isn't headed for the coast of Oregon!
    W7NGA
    Seaside, Oregon
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    It has your coordinates... GPS locked and it is on its way!!!

    Actually due to a bug it reversed path a few hours ago and is headed for Moscow... Darned Sun position calculation are difficult...

  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Thanks sir!
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Hi Bobby,

    I'm more than happy to help if you are having issues.

    Between the 0.0.9.x versions there are a lot of changes.  The panels are very different to use and I provided a movie to help with the process.

    I do not agree with your statement on the bugs.  Most so far have been user error.  Once you learn how to use it, it works fine.  

    That is not to say there are not bugs and certainly new ones are introduced with new features.  But here is the real deal:  I use this software personally each and every day for my own logging.  If something doesn't work I find it pretty quick.

    For example this am before releasing V0.1.0.3 I found an issue with Slice window restoration.  I fixed it as soon as I found it.

    There it little doubt that not every new feature will appeal to all users.  But here is one fact:   The panel system in V0.1.0.3 can be made to work VERY CLOSE to how panels work in 0.0.9.2.   Not exactly the same but very close.

    But like when you get a brand new radio, you need to get to know it.  So let me help you to figure out what the issues are.  And if you have found real bugs by God I will fix them as soon as I can.

    Thanks for your support Bobby.  Please email me at:  [email protected]

    And lets work out what is going on.

    Mark
  • bobby
    bobby Member ✭✭
    edited January 2019
    Mark here is a screenshot of how I have 0.9.2 arranged, I have watched your video once on 1.03 but will have to try again. When I startup 1.0.3 after unselecting the excess panels and leaving just slice a and slice b, i cannot make slice a smaller it fully engulfs the lower screen area i can move or resize b but i can never move or resize slice a, when i closea i get this huge map as a background but slice b disappears as well. Im sure its me i have to find time to watch the video when i try to set it up.image
  • bobby
    bobby Member ✭✭
    edited January 2019
    Mark my mistake i just had to work with it a bit and rewatch the video, so my question now since this 1.03 layout is saved and locked in, is there anyway to take this whole setup of 1.03 and which is on win 7 and get it to transfer or copy to win 8.1 once i uninstall 0.9.2 and install 1.03 on win 8.1? I want to copy over this exact layout in the picture. Thanks so much, it was me, not u! image
  • bobby
    bobby Member ✭✭
    edited January 2019
    image v1.03
  • N6OIL
    N6OIL Member ✭✭
    edited January 2019
    Video, where?
  • Oxford English
    edited January 2019
    If you look at the Top Bar, there is a LAYOUT tab. You can use that to save or load a layout of the panels. Save your preferred layout and give it a name other than FlexLogger.layout. Then save the file to somewhere safe. 

    Go to you Win8 machine and LOAD the saved file and the job should be done.

    The file location is C:WS7MAppsFlexLoggerData 

    Hope that helps

    Tim
  • bobby
    bobby Member ✭✭
    edited January 2019
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Hi all,

    John found a few issues with LOTW upload.  I've corrected these in V0.1.0.4 which you can get by checking for updates.

    For LOTW upload there are two needed things:

    1) Your station name
    2) Your station password if you set one when you created it

    First your station name is NOT your call sign.  In TQSL, on the station locations tab the station name is the name UNDER your call sign.  Here is how mine looks:



    So what I want to enter into FlexLogger LOTW setup for station is "HomeStation".

    Also the password under station is NOT your ARRL login password.  It is the password if ANY that was set when you created the certificate or station.

    For checking LOTW status you will enter your ARRL login and password.

    If you need to use an installer rather than the updates please first UNINSTALL FlexLogger using the control panel.  Then download and install the new version.

    http://184.154.226.168/flinstallers/FlexLoggerSetup-0.1.0.4.exe



  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Hi Bobby,

    Glad you figured it out!   Tim helped you on the layouts.  You can save the layout files anywhere you want and reload them.

    I do admit the docking scheme takes a little getting used to but once you understand it you can pretty much set things up almost any way you want.

    Mark
  • K6HN
    K6HN Member ✭✭
    edited January 2019
    The KPA and KAT bar graphs are working now, Thanks! Unfortunately the KPA500 Operate/Standby switch function is not working now. 

    Gary



  • Jose - EA5SW
    Jose - EA5SW Member
    edited May 2020
    Hello Mark. and thanks for the program.

    The dx cluster frequency are also bad converting , at least here in  EU, for example 71280.0 are read as 71 Mhz, I test ve7cc and my own running dxspider cluster.

    I have also an Expert 1K that have another protocol that 1k3 and newers, please consider add those protocol.

    73

    Jose




  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Hi Jose,  

    Is your computer by any chance set to use the comma as a decimal point?  Some EU localizations do this.

    I will be converting FlexLogger to recognize the culture of the computer and deal with the conversions correctly.

    Mark
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Thanks Gary,

    KPA and KAT are the focus right now.  I have one bug fix for Club Log but will focus on getting KPA and KAT working well.

    Mark
  • K6HN
    K6HN Member ✭✭
    edited January 2019
    I forgot to mention the KPA500 Power button no longer works also. 

    Thanks for the update. Love the map, can't wait to see what you will do with it. Hopefully integrate it with some a rotor panel to show beam heading etc...

    Gary


  • Jose - EA5SW
    Jose - EA5SW Member
    edited January 2019
    Yes, the problem are the decimal sign, in Spanish from Spain.
    Changed to dot, and now works.

    Thanks

  • N8FNR
    N8FNR Member ✭✭
    edited June 2020
    Flex should add this software to their Works With Flex page! https://www.flexradio.com/works-with-flex/
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Hi Jose,

    Ok... I will elevate the culture conversion stuff!
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2019
    Gary, Do you happen to know what version of firmware your amp is running?
  • K6HN
    K6HN Member ✭✭
    edited January 2019
    My KPA500 Firmware version is 01.47
  • Jean_Luc F5JRC
    Jean_Luc F5JRC Member ✭✭
    edited January 2019
    Mark, first thank you so much for this fantastic program!
    I think I meet the same issue with the decimal sign in French language, no frequency, no distance or bearing in spots and in log entry window. I double check the Flex Logger Station Editor but still not working. Please let me know if you want a log from my system (running W10, Flexlogger V0.1.0.4). 73s Jean-Luc
  • Jean_Luc F5JRC
    Jean_Luc F5JRC Member ✭✭
    edited January 2019
    Mark, I changed to dot the decimal sign as Jose suggested and it works nicely now!
    Thank you Mark and Jose, this software is really appreciated!

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.