Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

How to set up JTDX

rgracerrgracer Member
How do you set up JTDX on Flex 6400? I have set up WSJT-X using slice master. I have no problems. I want to try JTDX, but I have not been able to configure the radio properly. I set it up on slice 2, receiver B and I’m using the DAX RX 2 to receive and DAX audio TX for output. What do I enter under the Radio tab? I am receiving data through DAX and it is decoding properly. There is no CAT control nor PTT when I test under the Radio tab. Slice master has set the radio as ham radio deluxe for WSJT-X. This is also confusing. I am uploading photos of the radio and Audio tabs. I’m sure this is simple... Thanks for any guidance. The first photo I uploaded was of the WSJX radio Tab. I did this in error. imageimageimage

Answers

  • K1DBOK1DBO Member ✭✭
    edited November 2018
    In Slice Master you could enable the HRD Listener for your slice B (under the Sync tab), then set the rig control in JTDX to use Ham Radio Deluxe with the port chosen for the listener in Slice Master.  I'm assuming here that JTDX, like WSJT-X allows, Ham Radio Deluxe as a rig choice.  This will cause Slice Master to handle the rig control with the rest of the JTDX.

    Other configurations involving SmartSDR CAT instead of Slice Master are also possible.  For integration between Slice Master and WSJT-X, I chose Ham Radio Deluxe as the rig control protocol because, at the time at least, it more more stable than the alternatives.  

    Using Slice Master for rig control also provides a couple more options related to how the TX slice is handled.  



    The "On MOX" options control how the TX flag is set when the connected program starts to transmit.  It also controls the state of the DAX audio setting for transmit.  So, for example, if you are using USB with a hardware connected mic on slice C but then tell the JTDX on slice B to transmit transmit, Slice Master will first move the TX flag to slice B and then make sure the DAX option has been set.  It's not for everyone, but it can be useful.  Internally, Slice Master makes use of these options when it set up the connection to WSJT-X.  In that case you dont have to worry about it.  But since Slice Master doenst have direct support for JTDX, these feature might come in handy when you manually configure the connection.

    --Don


  • rgracerrgracer Member
    edited April 2019
    Do I open Slice-master manually and then JTDX? If I set up the synchronization and port as above does Slice -Master bridge to SDR? Sorry if I seem dense, I am a newbie..
  • K1DBOK1DBO Member ✭✭
    edited November 2018
    The idea I'm suggesting is that you can use Slice Master for rig control in a configuration that is very similar to the way Slice Master configures WSJT-X. 

    So yes, start Slice Master first, then enable the HRD Listener for your slice of choice (you mentioned slice B).  The slice can now be controlled by any program that knows how to speak the HRD rig control protocol. 

    JTDX is one of those programs.  In its radio settings dialog choose 'Ham Radio Deluxe" as the rig along with the port number from the HRD Listener in Slice Master.  In JTDX you should also choose CAT as the PTT method.

    Assuming that JTDX is set to use the same DAX channel as your slice, you should be good to go.

    Good luck!
  • K1DBOK1DBO Member ✭✭
    edited November 2018
    ...sorry, I missed an important detail.  When you select 'Ham Radio Deluxe' as the rig type you'll need to specify both the IP address of the computer where you are running Slice Master along with the port.  In most cases '127.0.0.1:<port>' will do the trick, just swap <port> for the port number for the slice's HRD listener.
  • rgracerrgracer Member
    edited November 2018
    Better, but.. CAT is now working.I see the freq inJTDX, it triggers transmission at the right times. The only thing is no tone and no power I have the Pwr setting maxed out and have checked all the settings. What’s next and muchas gracias for your help and patience. JTDX seems to decode more messages and I like the set up..
  • K1DBOK1DBO Member ✭✭
    edited November 2018
    It sounds like your TX audio isnt set up properly.  In JTDX Settings, Soundcard Output should be set to 'DAX Audio TX'. 

    Next, in the DAX Control Panel make sure the "TX Stream" is enabled and set to somewhere around 60. 

    Now while watching the level indicator in the DAX control panel, press the "Tune" button in JTDX.  The radio should go into transmit mode and the TX Stream level indicator in DAX Control Panel should start dancing around.  If you are still not seeing a signal being transmitted make sure the "DAX" button in SSDR's "P/CW" panel is enabled (blue) and try it all again.

    The screen grab I gave you above for the HRD Listener setup in Slice Master has the DAX related 'On MOX' setting set incorrecly.  Change that to either 'DAX On' or 'Toggle DAX On'.  Slice Master will then insure that the DAX button on SSDR "P/CW" panel is always correct each time JTDX starts a transmission. 

    The difference between these two settings is that with "DAX On", the DAX function is simply enabled with each transmission.  With "Toggle DAX On", Slice Master will first remember if the current state is on or off and then return DAX to its original state after the transmission ends.  TX has a similar option. 

    You should chose which works best for you based on what's happening in your other slices.  When Slice Master sets up for WSJT-X, it uses the toggle variant for both to insure the radio is put back to it's prior state (TX slice and DAX mode) after the transmission ends.  

    Once you get all of that straight, you'll want to tweak your audio levels.

    --Don

  • rgracerrgracer Member
    edited November 2018
    I was very hopeful that changing the DAXmode would work. I checked all the things in your last note, but I am still getting transmission triggered, but with no tone and no output. This is the case both with enabling a real transmission or with the tune button. It also does not change if I use the DAX on setting. I am attaching two photos. The first is In receive mode, the second is when a trigger the tune button. I am including a view of the JTDX program and the DAX next to each other. Sorry to be so frustrating, but I really am stymied. imageimage
  • N6OILN6OIL Member ✭✭
    edited November 2018
    Make sure your TX bandwidth is set to 2900 hz or higher and on the panel DAX is clicked.image 
  • K1DBOK1DBO Member ✭✭
    edited November 2018
    If I'm reading your second image correctly it looks like you grabbed it while the tune button in JTDX was pressed.  If that's the case the level indicator for your TX Stream in your DAX Control Panel should be showing something but it's not. 

    Confirm your audio output device is set to "DAX Audio TX".  If it is, you might have some DAX driver issues... unless you can confirm that "DAX Audio TX" is working for some other program. 

    If you can confirm that, then we are still missing a setting in JTDX that is preventing it from sending audio.  

  • K1DBOK1DBO Member ✭✭
    edited November 2018
    Rory's suggestion is a good one.  But shouldnt come into play until you can see audio activity for the TX Stream in the DAX Control Panel.
  • rgracerrgracer Member
    edited August 2019
    Thanks again for all your help. Everything is set up exactly the way that it should be. In addition, WSJT-X works just fine the tone comes through and transmits normally. It just has to be something in the JTDX program. I know there are a lot of boxes to check. I’ve gone through everything several times. Not sure where to go from here. image
  • K1DBOK1DBO Member ✭✭
    edited November 2018
    You could try removing the JTDX config folder. 

        C:Users<your name here>AppDataLocalJTDX

    This will return all your settings to the "factory" defaults.  From there, adjust just the rig and audio setting as mentioned earlier.  

    I tried JTDX for the first time yesterday, made only the changes we discussed and it just started working.  I think at this point your Slice Master, DAX and SSDR setting are all correct.
  • rgracerrgracer Member
    edited December 2018
    I deleted the whole JTDX program with all files. I reinstalled it and set it up from scratch. No change. I have good reception, freq tracking and triggering transmit, but no tone. I’m frustrated, but also intrigued. What about setting it up the prior way through the CAT program?
  • K1DBOK1DBO Member ✭✭
    edited December 2018
    Give it a shot, it cant hurt.  But at this point your CAT connection is working just fine.  The trouble you are having is related to the audio.  For reasons I've been unable to determine, your audio from JTDX is not making its way to your DAX TX audio device.  Until you see the Tune button in JTDX cause the red level indicator in DAX Control Panel to dance, I dont think you'll have much luck transmitting a signal.

    While looking around and trying to find a setting that might reproduce your problem I realized I started having the same trouble.  It turned out the driver for my DAX TX device was somehow wedged.  First thing I tried was to shutdown/restart DAX Control Panel.  That didnt help.  Next, I opened the Windows Sound control panel and found the "DAX Audio TX" device on the Playback tab.  A right click on the device to disable it followed by a right click to enable it, followed by a restart of DAX Control Panel got me going again.

    When it stopped working for me though, WSJT-X also stopped working in the same way.  I'm pretty sure you said that WSJT-X will still working for you though, so it might be a completely different problem.

  • rgracerrgracer Member
    edited December 2018
    Tried this, but no change. It’s not DAX. It has to be a software problem in JTDX. I then to re downloaded the latest version from the website and tried again. Still same.
  • K1DBOK1DBO Member ✭✭
    edited December 2018
    The only thing I have left is to suggest a reboot of the computer.  While you are at it, a reboot of the radio wont hurt either.  With all of the uninstalling/reinstalling you've done I'd be surprised to hear that you havent tried that already, but I feel the need to mention it just the same.

    Likely unrelated... as I was re-examining that last screen shot you posted I noticed that your network connectivity to the radio is in the red with just one bar.  What's up with that? I'm guessing unrelated since WSJT-X would be bothered by it too if that was actually the problem.  At the very least it's something to watch out for.


  • rgracerrgracer Member
    edited December 2018
    The red is probably due to the wifi connection to the computer. The Flex has an R-45 ethernet cable directly to the radio. I am getting an ethernet hub so I can plug the computer in as well. It works well. I have rebooted several times. I have asked this question to the JTDX support group and will see if they have any other ideas. I have also set up DM 780 and it works fine as well with the same DAX set up. Go figure..
  • rgracerrgracer Member
    edited December 2018
    The red is probably due to the wifi connection to the computer. The Flex has an R-45 ethernet cable directly to the radio. I am getting an ethernet hub so I can plug the computer in as well. I have rebooted several times. I have asked this question to the JTDX support group and will see if they have any other ideas. I have also set up DM 780 and it works fine as well with the same DAX set up. Go figure..
  • rgracerrgracer Member
    edited December 2018
    Problem solved. Turns out that on the flex there are two DAX transmit channels. I still am not sure what the differences. one says IQ and the other Just DAX transmit. I switched to the one without the IQ AND It started working. I believe that the distinction between these two should be made much more clear in all the directions that are given we’re setting up a Fleksy through the DAX system. I am not sure what the I Q means. Thanks for the help and time. I like the JTDX program more than the WSJT.
  • K1DBOK1DBO Member ✭✭
    edited December 2018
    Ah, great news!  Thanks for update.
  • W2ECKW2ECK Member ✭✭
    edited August 2019
    RGracer- hi. Am wondering if you got Slicemaster to start JTDX and let it do the integration with SSDR? Have used Slicemaster/WSJTX for quite a while but thought I'd give JTDX a try. NOticed that you said you like it better .

    73 Paul
    w2eck

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.