Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Switching between digital audio source and voice audio

Tim K9WXTim K9WX Member ✭✭
edited March 21 in SmartSDR for Windows

Something changed in the way microphone VOX and DAX work together on SSB between SSDR 2.3.9 and 2.4.9 with my 6600 and I have been unable to get them to work together in 2.4.9.  I don’t see anything in the release notes that would explain this change.

Section 20.3 of the SSDR Software User's Guide says, in part, "If the DAX button . . . has been selected and PTT is initiated through CAT, audio will be used from the DAX source rather than the currently selected microphone input. If, however, a microphone PTT is depressed, the selected microphone will be used for input. This allows the operator to switch between a digital audio source and voice audio quickly."

I found this to work as described in SSDR 2.3.9.  I found it would work whether I used a footswitch with the mic for PTT or used VOX.

I don't work a lot of phone: my last phone QSO was back in August when 2.3.9 was the most recent release.  This evening, with SSDR 2.4.9 installed, I find that VOX and the mic will no longer key the radio if the DAX button has been selected.  I must manually turn DAX off in SSDR in order to use VOX with the mic.  The footswitch with the mic still works with DAX turned on.

I downgraded to 2.3.9 to make sure I was not imagining things and found the behavior as I remembered it: that I could have both mic VOX and DAX turned on at the same time, allowing me to seamlessly go back and forth between voice audio and digital audio without using a footswitch.  I then reverted to 2.4.9 and found once again that I had to choose between using VOX with the mic or using DAX.  The footswitch will allow me to use the mic just fine with 2.4.9, but the ability to use microphone VOX alongside DAX is not there.

Here are some screen shots showing my setup.  The first one is 2.3.9, both VOX and DAX are selected and both work.



This second image is from 2.4.9.  Both VOX and DAX are selected but only DAX will work.  If I want to transmit mic audio I cannot use VOX.  I either have to turn DAX off or use the footswitch.



The settings in these two images appear identical to me.  But perhaps I am missing something.  Any suggestions would be appreciated. 

I should note that I am using an N1MM+ 1.0.7342 macro to provide the digital audio for the radio with both 2.3.9 and 2.4.9, and everything is configured for SO2R.  The result is the same regardless of which slice I use for TX: works in 2.3.9 but not in 2.4.9.


Tim K9WX




Comments

  • Dudley  WA5QPZDudley WA5QPZ Member ✭✭
    edited March 21
    VOX over ride of DAX is not working in version 2.4.9, if that is a feature you have to have, best to drop back to 2.3.6 of SamrtSDR. I understand this was unintentional result of get remote DAX /SmartCAT operational. Dudley WA5QPZ
  • Tim K9WXTim K9WX Member ✭✭
    edited November 2018
    Thanks, Dudley.  I was hoping it was me and that there was a setting I could flip to make it work.

    You mention a roll back to 2.3.6.  Did you mean 2.3.9?  I can't find where 2.3.6 was in general release.
  • Joe N3HEEJoe N3HEE Member ✭✭
    edited February 2019
    This is contest season folks !!!  Radios need to be working.  This is where Flex needs to offer a break fix patch to fix this problem.  Why make us wait months for a fix in the next upgrade ?  There will allot unhappy users this coming weekend in Sweepstakes SSB.  Including me.  Sure, I can roll back but I shouldn't have to ?  
  • Joe N3HEEJoe N3HEE Member ✭✭
    edited February 2019
    I get MIC audio when using a foot switch connected to PTT jack on back of radio when DAX is enabled. This is far easier than rolling back to 2.3.9.  This is what I will do for SS SSB this weekend.  I will be running high power so using a foot switch is preferred to keep the amp happy.  Problem solved !  

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.