Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Radio registration unsuccessful, could not access Smartlink Server

So, I installed our Club Flex-6400 over the weekend, and several of us have been successful in accessing it remotely over the last few days.  Suddenly, last night, the radio dropped out of the Smartlink window.  If I connect to the PC I have on the same LAN with the radio, SmartSDR works fine.  However, if I go into the smartlink setup window, and it appears that the radio is not registered.  If I try to register it, I get the "Radio Registration Unsuccessful" message.  

Given I'm not seeing a ton of other complaints in the forums, I'm assuming the "Mothership" is not down, and something else is awry.  I have no idea why this would quit working spontaneously like this.  I had used it remotely, just hours before it started failing.  The network is obviously up, since I can remotely connect to the PC that's behind the router.

<soapbox>
I'll take this as an opportunity to b*tch about this architecture.  The fact that I can't just enter a freakin' IP address to connect to my radio is infuriating.  Flex-radio has value-added this Smartlink thing, and made the radio completely dependent on some "database in the sky" for access.  As hams, we should be technically competent enough to define a few ports on a router, and enter an IP address into a **** client if we want to circumvent all this **** that makes the radio unreliable.  One of the precepts of Ham Radio is disaster preparedness.  The fact that my club can't access the radio if some random part of the internet is down, even if we have local connectivity, is infuriating.  

It's further frustrating, since as a University, I have a WAN network in our shack, and I could just plug the radio right in, and give it a WAN address on the Internet.  But nooooo, I couldn't do that.  Instead, I had to take a router from home, disable the wireless, and use it as a NAT to cope with this Smartlink ****.  Grrr.

</soapbox>

Anyway, suggestions on making the radio spontaneously heal and start talking to the smartlink mothership again would be appreciated.

Crankily,
Mike / KD2EAT
Advisor, Amateur Radio Club at Cornell, W2CXM

Comments

  • Stephen VA3KXPStephen VA3KXP Member ✭✭
    edited December 2019
    I have had his happen a couple of times and a reboot of the radio resolved the issue.
  • edited October 2018
    Ugh.  Charming.  One reason we were so looking forward to remote access is that our shack is up 5 very tall flights of stairs, with no elevator. lol.  I guess I'll haul my busted knees up the stairs and try that.


  • edited October 2018
    I agree with Mr Hojnowski... I operate remote only...Station in MN and home in FL...once in a while the smartlink service does go out...but the majority of times cutting the power to the radio will do the trick...not just powering the radio down...removing the 12vdc supply. I use a RC USB powerstrip to do this.
    All the best.
    Mike
    KC0YHM
  • Jim GilliamJim Gilliam Member
    edited April 2019
    You can always use a VPN. It takes an IQ in the double digits to set one up.

    Jim, K6QE
  • Stephen VA3KXPStephen VA3KXP Member ✭✭
    edited October 2018
    I have found just powering the radio down using the “Remote Power” (via the RCA jack on the back) then powering it back on the same way is sufficient. I too operate remote (only about 1.5 hours away) and the “Remote Power” has saved my bacon more than once.
  • edited October 2018
    Thanks both for the thoughts on Remote Power.  Looks like I'll have to set something up on a Raspberry Pi or something so that I can powercycle either the radio via the RCA jack, or the power supply via a remotely controlled power outlet.  
  • WA5GPWA5GP Member ✭✭
    edited December 2019
    I too am having the same issue; the suggested fix's have not worked on this end. Keeps saying cant connect to server.  Oh well so much for advanced technology.  :)
  • Stephen VA3KXPStephen VA3KXP Member ✭✭
    edited October 2018
    Have you ever been able to connect to the SmartLink server from the radio?
  • WA5GPWA5GP Member ✭✭
    edited October 2018
    Yes from the Ipad  Does not show radio now and doesn't or won't connect to Smart Link Server
  • Stephen VA3KXPStephen VA3KXP Member ✭✭
    edited October 2018
    I would check the SmartLink Setup. Ensure the “Test” is successful.
  • Mark G ThomasMark G Thomas Member ✭✭
    edited October 2018
    I share Mike's ongoing frustration about theSmartSDR and Maestro client inability to specify a base radio by direct IP address. For those of us with already established multi-subnet LANs, private WANs, and conventional (non-broadcast-passing) site to site VPNs, we have to work around this silly design limitation. Being able to connect between various kinds of IP clients and servers across IP gateways is one of the most fundamental and basic aspects of IP networking.

    Explanations to date have included concerns that this would make it easier for hams to make radios insecurely accessible via public IPs, or that having an option for direct IP entry adds confusing technical complexity that will disorient less technical users, but I disagree with the rationale.

    Many common networking setups, intentionally, by design, DO NOT pass broadcasts for performance and other reasons related to basic networking functionality, and in some cases security. If I have two sites connected by a site to site VPN or dedicated private connectivity, on different subnets, why should I have to set up some new custom broadcast-passing VPN for the sake of the radios, or use public IPs and Smartlink when I already have direct private IP connectivity? Examples include Cisco AnyConnect SSL VPN, and site to site VPNs using GRE or IPSEC tunnels and routers, or even just a wire running between buildings, but with a router involved.

    The radios now have the option to restrict IP connectivity to RFC1918 ranges, enabled by default. The iOS iPhone/iPad SmartSDR app thankfully DOES permit direct IP entry as one of the optional ways to connect to a radio. What is the big deal here? Why not just add the option to SmartSDR for Windows and the Maestro???

    Mark Thomas KC3DRE
  • edited March 11
    Sorry to hear of your "busted knees". That would no doubt make me "cranky" as well.

    Good luck !

    73
    Jim, WQ2H
  • Bob G   W1GLVBob G W1GLV Member ✭✭
    edited June 16
    If Smartlink is setup properly it works flawlessly. If your router does not support auto port forwarrding then you have to do it manually. With this said you should be in for the greatest adventure in ham radio. Networking is a very exacting science, one character missing or not in the correct position muddies the operation. Good luck

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.