Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Upgraded to 2.4.9: QSK in some bands, not in others.

NA0BNA0B Member ✭✭
Upgraded to 2.4.9. QSK works in some bands, but not in other bands. It is not clear to me when the QSK flag should be on (6600M, 2 antennas). Anyone with similar problems? Thanks.

Answers

  • NA0BNA0B Member ✭✭
    edited September 2018
    A factory reset seems to have fixed my problem. Now the QSK flag works as described in the manual.
  • NA0BNA0B Member ✭✭
    edited September 2018
    Well, sort of. If I have ANT1 for receiving and transmit, I need to switch to ANT2 for transmit, and back to receive to get the QSK flag (and get rid of the relay clicks).
  • NA0BNA0B Member ✭✭
    edited September 2018
    Downgraded to 2.3.9 and QSK is back to normal. I will repeat the upgrade to 2.4.9 once more just in case.

  • Barry SimpsonBarry Simpson Member
    edited November 2018
    I upgraded to 2.49 yesterday and very quickly noticed a huge improvement in keying with the previous random irregularity in the sidetone having disappeared. A really great second improvement is that the previous presence of background noise (as if just the antenna has been disconnected) on transmit between characters when using a foot switch to manually control transmit/receive has gone with the receiver fully muted and just the sidetone heard. However, I have now found exactly the same issues that you describe but QSK works whether the symbol is lit or not but sometimes the background noise is there with the foot switch and sometimes it is fully muted. I believe that the huge keying improvement is almost there. We just need the QSK symbol to be consistent, no relay clicking and no background noise in manual CW transmit but in QSK mode.
  • Barry SimpsonBarry Simpson Member
    edited November 2018
    I think I have a workaround. As well as the above issues, my ATU was also randomly turning itself back on. I found that I had ATU MEM engaged and as I tuned the band, the ATU came back on and that affected the QSK. So I turned off ATU MEM and the QSK works normally now and the ATU doesn't switch itself back on. However, the background noise in manual CW transmit is still there as previously.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited September 2018
    When the mem is on it uses data in the mem data bank as you tune across a band, at times it will want to tune to store yet another freq. Turning it off is the right thing to do to stop it from using the presets.
  • NA0BNA0B Member ✭✭
    edited September 2018
    Thank you Barry for sharing your experience. I never even thought about relay clicking until I upgraded to 2.4.9. I did not notice any background noise, but may be it is because I was not paying attention. If after upgrading again during weekend, I still have problems, I may submit a help ticket.
    By the way, I am using Windows 10.
  • NA0BNA0B Member ✭✭
    edited September 2018
    Bill, you were right on! I upgraded to 2.4.9 and noticed the erratic QSK behavior. Then, I erased all the ATU memories. The erratic behaviour is gone. One more thing to do when upgrading. Thanks.
  • Joe N3HEEJoe N3HEE Member ✭✭
    edited February 2019
    There is definitely something wrong with the relationship between QSK, ATU and ANT selection behavior in 2.4.9 code.  For example, I am using ANT 2 for both 20 and 80 meters.  I can get QSK working on 80 meters with ATU enabled as described in above thread. I need the ATU on 80 meters.  I dont need ATU on 20 meters. With a single panadapter open I switch to 20 meters (no ATU enabled and QSK works) and then go back to 80 meters QSK is disabled again.  I then have to go through switching between TX ANT 1 & 2 to get QSK working again.   There is no persistence.  I am opening a ticket.   Joe N3HEE
  • NA0BNA0B Member ✭✭
    edited February 2019
    I noticed a similar behavior. Thanks for opening
     a ticket.
  • Joe N3HEEJoe N3HEE Member ✭✭
    edited October 2018
    I have also added this thread to my ticket.  I will keep you all posted with what Flex has to say about the issue.
  • Joe N3HEEJoe N3HEE Member ✭✭
    edited March 2019
    Ticket has been opened and Flex engineering is looking into issue.  I made a short video to demonstrate the odd behavior.  This issue has been added to the bug tracker.

    Tim informed me that Flex was trying to fix a potential receiver performance issue when using the ATU and QSK.  Depending on ATU settings (capacitance/inductance) the receive signal may be attenuated due to insertion loss while using QSK with ATU engaged due to how the signals are routed with QSK enabled. 
  • KT8DXKT8DX Member
    edited March 2019
    Has there been any response from Flex on this issue?  I am experiencing it too - the keying is atrocious when the QSK is off - loud relay and erratic dropping out.  Almost unusable.  Inexcusable in such an expensive 1 month old radio.  
  • Joe N3HEEJoe N3HEE Member ✭✭
    edited March 2019
    I am hoping this will be addressed in version 2.5. Flex is aware of the problem and it was added to their bug tracker. For now, there is a workaround you can use to get QSK working again after changing bands. See my response in this thread above.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.