Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR 2.3.9 Network Disconnect

2»

Comments

  • Mike VE3CKO
    Mike VE3CKO Member ✭✭✭
    edited February 2019
    Hi Lloyd, one thing I forgot to mention in the email is to ask if each Ubiquity radio is grounded at the radio. The purpose of the ground is to discharge any build up of static electricity, yes it does happen. 1's and 0's get confused, cats and dogs start dating, it gets messy.
  • John WA7UAR
    John WA7UAR Member ✭✭✭
    edited February 2020
    Lloyd, what frequency range does the Ubiqity router operate in? I’m wondering if, being in a marina environment, it might get overwhelmed with occasional radar signals? The same way slower/older WiFi routers can be impacted by microwave ovens or such nearby. Just a thought.
  • L.Kubis
    L.Kubis Member ✭✭
    edited July 2018
    It's on ch 160 --5800 Mhz, John.
    I'm trying to get Ubiquity's Airview to work to look at the spectrum. Problem is it's legacy software and I haven't found a computer to run it on.

    Cheers!
  • Vin Jacobo
    Vin Jacobo Member
    edited September 2018
    I am occasionally having this problem too.  I run my 6500 hardwired to the router.   I run ssdr Ios, and  ssdr windows via  ipad or surface pro, respectively -  all wireless.   The disconnects happen randomly, only while transmitting and only when I am working directly in the shack,  close to the radio and antenna tuner.  Thus, I am now wondering if the problem arises from stray RF.   I wonder if others are noticing the problem happening in transmit,  receive, or both?  I am going to work to reduce RF in  the shack and see if that has any effect on these disconnects.
    vy 73
    wz2j

  • John Cooper
    John Cooper Member ✭✭
    edited February 2019
    Hello, Lloyd;

    I have a similar problem with my 6500 running remotely over a WAN. 

    I'm using a VPN (OpenVPN) on a private server and not the SmartLink connection.  I've run this way since before version 2.0 and have had no problems until lately with version last two versions of SmartSDR.

    Since the recent upgrades the radio will need to be restarted when the network connection develops erratic latency.  High latency or low latency seems to be not a problem.  I've operated from central Europe to my Virginia station with over 400 ms of latency with no problem.  But if the latency jumps up and down abruptly, the 6500 will disconnect and show an error message indicating the radio has lost connection.  Then it's game over.  I have a remote USB relay on the server that will cycle the FlexRadio power to off and then on via bash commands.  On start up, all is good again until the next time. 

    If I try to just rerun the SmartSDR software, two problems occur.  First the Windows Task Manager shows SmartSDR still running in the background so I can't restart it.  I have to use the task manager to end the SmartSDR task.  Then I can restart the SSDR program. 

    Once started, I can see the radio in the list so it's broadcasting it's presence on my VPN server.  But when connecting to it, it throws an error message indicating it can not connect to the radio. 

    So the drill is to close the SSDR program from the dialog window, then go to the Windows task manager and end the SSDR task, then cycle the 6500 off and back on over my separate control link, then restart the SSDR program and all is working again. 

    Networks are what they are with latencies all over the place from time to time.  In the past with version 1 software that has caused the SSDR software to stop but it could be restarted again easily.  Making the network better is always a help, but I feel this problem is with the new SSDR software or firmware. 

    I see from this thread that others have similar problems with the CAT and DAX. Perhaps a fix in that area will help my SSDR failure to restart problem.

    Thank you for your comments. 

    Regards,

    John, WB3AYG  

          

          
  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    Maybe out in left field... I, too, had a “disconnect” problem with my 6600 as soon as I got it. Random intervals, no seeming common factor. Turns out that the RCA plug I used for remote on/off was flakey. The rig would be commanded off (and lose connection to the PC) if the dogs barked too loud or the temperature changed. Replacing the connector (or disabling remote on/off) fixed the problem. Took me months of looking in the wrong direction before the light came on! On the plus side, I am VERY sure about my LAN and data cabling.
  • K5ROX
    K5ROX Member ✭✭
    edited February 2019
    Weird...… George did your screen say connection lost or did radio turn off?

  • K5ROX
    K5ROX Member ✭✭
    edited March 2020
    ED your lucky, I been having same problem with my 6600 since new but mine will sometimes stay connected for days, like now I think 4 days just fine, yours will be easier to see if fixed.


    Ive tried several computers, switchs and many cables...and now ive moved to another town and got yet another new computer etc...….same problem for a while then bam.....nothing changed and it's solid for days.   The new computer is fresh windows, updated and no extra programs running, when it disconnects its almost always not being used...no xmit.


    Nothing I do seems to affect problem, Flex keeps examining my network but im waiting on a reply so well see. All mine is wired, no wireless.


    Good Luck with your problem




  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    Got a “connection lost” message. Had the front panel “waves” turned off, so didn’t immediately recognize the radio turning off, which it did after a few seconds.
  • John Cooper
    John Cooper Member ✭✭
    edited February 2019
    I took your advice, George, and removed the USB/solid state relay device from the server to the rear connection on the Flex 6500.  Once restarted, the radio ran fine in remote for four days. 

    After the latest crash, the same behavior occurred.  The SmartSDR program was not able to communicate with the Flex.  However, the listing in the opening dialog box did show the radio present. 

    image  

    Therefore, the Flex is able to broadcast its presence on my VPN network, but not able to pass data packets to my end of the connection and the SSDR program.  

    I know if I go the the server site and use the front panel power on toggle switch, all will be good again.  

    John, WB3AYG
  • Ed, K0KC
    Ed, K0KC Member ✭✭
    edited February 2019
    I should have reported this earlier, but I have apparently solved my disconnect problem by eliminating a reserved address for the 6700 in the router and just letting DHCP assign one. I also changed my lease time from 120 minutes to 48 hours. I am not sure which change fixed the problem, but at least it is fixed!!!
  • Dudley  WA5QPZ
    Dudley WA5QPZ Member ✭✭
    edited February 2019
    Ed, 

    Glad you found your issue with the network drops on your network.   Router reservations normally are not a bad thing,  I normally will leave the radio in DHCP mode, but use the router or DHCP server reservation to assign the unique IP address to the radio MAC address.  Extending the lease time is not a bad ideal also. 

    Enjoy,
    Dudley
    WA5QPZ


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.