Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Port Forwarding issue in v. 2.2.8

Mark K0JMMark K0JM Member ✭✭
edited July 2018 in SmartSDR for Windows
I'm having a problem with SmartLink. Automatic port forwarding comes back red. The test on port forwarding comes back showing UPnP port PASS, but Forwarded ports FAIL. I've tried all sorts of different port numbers in manual forwarding with the same result.

If I'm not mistaken, the message that UPnP port PASS indicates that the issue is not with my router, but with something on the radio side. Or am I misinterpreting that???

Answers

  • Steve MooreSteve Moore Member ✭✭
    edited May 2018
    Same problem at my QTH.  I port forward Fusion, echolink, etc., no problem.   With Smartlink no luck.  I determined it has to do with the AC wifi side of the router.  When I jack into the router it works.   When I go wifi it fails.   Solution here at this QTH is to pull CAT6 to the radio room --> switch --> rig and PC.   
  • Mark K0JMMark K0JM Member ✭✭
    edited May 2018
    My rig and PC are already hardwired to the router, so don't believe wi-fi is the issue here. I had SmartLink working fine a few months ago. Got home from a trip and didn't use it for awhile. Now that summer has come, thought I'd test it out and no go. Nothing has changed other than the software version.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2018
    If your router supports UPnP, it is configured for UPnP (the default may be off) and you click the test button, if it turns green you are good to go.  Only one of the three options will work,  Not all three will pass.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    Unless your router, if it is provided by your ISP received a software update you are not aware of, that could be the change that is causing the connect issue.
  • Mark K0JMMark K0JM Member ✭✭
    edited May 2018
    The router does, indeed, come from the ISP. UPnP is enabled (I checked). When I test in Automatic I get RED. I don't understand what you mean by three options. The only options I see are Automatic and Manual. In Manual, the only options are the two port numbers. So what's the third option?

    Again, the box I get when I hover the mouse cursor over the Test button says UPnP ports PASS, but the two Forwarded ports FAIL. I'm trying to determine what that means. Are the Forwarded ports in the radio or elsewhere?
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    When you run the test, put your mouse cursor over the circle indicator and a popup will show the three different ways the radio can communicate with the SmartLink server and which one of the three passes or fails.

    If you are getting red, then the radio cannot connect to the SmartLink server.

    Since UPnP is enabled on the router, reboot the radio.  If your router has a UPnP status window, you should see the radio as a UPnP client if the router received the UPnP setup messages.
  • Mark K0JMMark K0JM Member ✭✭
    edited May 2018
    Yeah, I get that red means it won't go. But I'm not getting a straight answer to my question. Here is the complete text I get in the pop-up box when I hover the mouse over the Test:

    Radio cannot be accessed using SmartLink
    UPnP Ports:
         TCP=PASS
         UDP=PASS
    Forwarded Ports:
         TCP=FAIL
         UCP=FAIL
    Hole Punch Supported: No

    My question is simply, "WHAT DOES THIS MEAN?" What and where are these failed forwarded ports? If I know that, maybe I can trouble-shoot in the right place.

    The log on the router shows the port forwarding happening.

    But the circle for SmartLink on my screen is still red.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    When you click the Test button, the radio tries to initiate a proxy connection to the SmartLink server (in the cloud).  It will first send a UPnP message to the routers and if it responds, they exchange information that allows the router to set up port forwarding automatically.  Now the radio knows it has a UPnP connection to the router.  Once that is established, it does not try the other two methods (manual port forwarding) and Hole punching.

    Now you run the test.  The radio sends SmartLink commends that will emulate a client connection and if that passes, then the dot is green.  If it fails, as it has in your case, the dot turns red.

    The information provided indicates the radio believes it has a valid UPnP connection established with the router, but data did not pass through it correctly.  I an suspect of the UPnP configuration or operation on your firewall/router.

    If you can get to your router management interface, and if it has a UPnP status, it should show the radio, the outside ports it selected for the TCP and UDP data streams and the internal ports.  If you can get this information, that will help to debug the process.

    Also if UPnP is enabled, you should not set up manual port forwarding, as that can confuse the router if the endpoint IP (the radio) is the same.  
  • Mark K0JMMark K0JM Member ✭✭
    edited May 2018
    By setting the radio to a static IP address, and designating that address in the router as a DMZ, I am able to get the green light on SmartLink.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    Great. Your making progress. The challenge is not all routers setup port forwarding and UPnP similarly. I suspect your router only allows thei type of access through a DMZ
  • N8SDRN8SDR Member
    edited May 2018
    While DMZ will pass the info (because it is OPEN) it is not a desired means to allow communication between the device to the outside world(internet) this is leaving you wide open. Have you tried resetting your router and then turning on UPnP. its possible some other application may have tried setting its self up using the ports needed and the router is more or less confused. I'd only suggest you keep it in DMZ mode if all else has failed, and even at that point I switch out routers myself before leaving t open like that.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.