Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Update Issue or me

Rick lRick l Member
Problem loading new SmartSDR firmware to radio. I started the new version SmartSDR firmware update and the yellow process indicator bar went to 100% and stopped. The flex 6400 on/off indicator flashes three times then pauses about a second and repeats.   The radio will not shutdown.  Any help on what I did or how to correct the issue??  Thanks for your help

Completed · Last Updated


  • DougDoug Member ✭✭
    edited December 2019
    I also had trouble but mine only went to 75% on the yellow bar and just sat there for a few minutes then a message in another bar or window came on and said it failed and to try again which I did. It wouldn't  even start then so I canceled with the cancel icon on the face of the radio and finally after a couple tries it took off and completed. There will be 4 different bars which you have not gotten to see yet. I blamed my problem perhaps at 8pm last night Flex was bomb bared with upload request and there server was overloaded. All ended well for me hopefully you can get er done. i did do a cold boot on my radio which includes shutting off, then pulling the power cord from the radio and letting it sit for a min then turning back on. I might add my power button turned a bright purple and flashed,  the radio did a lot of different things i can't remember just all what it did but it was quite a lot of stuff.
  • Lionel Lionel Member ✭✭
    edited March 19
    Same this happened yesterday, same symptoms.  Cold boot of radio and all seemed to be fine.  It's been happy ever since.
  • Rick lRick l Member
    edited May 2018
    When upgrading the firmware are we to install the DAX and CAT drivers or skip the driver update??

  • Steve W9HHSteve W9HH Member
    edited May 2018
    Mine went through the upgrade most of the way just fine (Purple indicator, etc.) and then there was a popup message that reported a communication problem back to the radio. I believe it was related to DDUtil being opened if I remember correctly. Forgot to close it before I started the upgrade.Probably not a good thing! My radio has a static IP address assigned to it as well. The yellow bar graph was almost to the end, but everything had froze after the error and the radio was unresponsive. The indicator on the power button was now red. I was not able to connect to the radio through SmartSDR at this point. I had no choice but to unplug the power cable to reset it. After starting the radio everything was fine and update seemed to have been successful.

    - The next time I do an update, I'll make sure all 3rd party software is closed and hopefully things will go a little smoother!
  • Rick lRick l Member
    edited May 2018
    Thanks for your input . Tonight I will try unplugging the radio followed by a  cold boot. Did you upgrade the DAX and CAT as well? 
  • Steve W9HHSteve W9HH Member
    edited May 2018
    DAX and Cat are included in the upgrade package... so that will be taken care of
  • Matt NQ6NMatt NQ6N Member ✭✭
    edited April 2019
    I updated my 6600 via VPN yesterday and it hung at 99% for a while.  I think this might have been due to the new MAC Addressing scheme.  Since I was not sitting near the rig I do not know whether it rebooted on its own, but after I rebooted it remotely and rebooted the router (with DHCP server serving a static address to the 6600's MAC address) everything worked just fine. 
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    Occasionally, the radio will not reboot properly after an upgrade.  There are 6 different processors in the radio that have to reset and reboot after the new firmware is installed and doing a hard power cycle is needed.  I am confident that if the radio booted up and you are able to use SmartSDR v2.2.8, that the installation was successful.

    We address this in the SmartSDR for Windows Release Notes.  Here is the text for your convenience:

    What to do if the firmware updates do not finish after 5 minutes?  
    On rare occasions, the update status may not recognize the completion of the firmware update.  If the radio has not successfully completed the firmware updates after 5 minutes, power off the radio by pressing the power button. The firmware update should complete normally.  Note: While this should be extremely unusual if a single press on the power button does not shut down the radio, remove the DC power source from the radio to power down all processors.  Restore DC power and reboot the radio. 

    Note: It would be rare that a single press on the power button did not shut down the radio.  If this occurs, remove the DC power cable from the radio to force a power down to reset all processors.  Wait about 5-10 seconds and restore DC power and reboot the radio.  The firmware update should complete successfully.
  • Rick lRick l Member
    edited May 2018
    Yep!  a cold boot fixed it all.  Thank you all for your help 

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.