Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Anyone having problems with IOS app after update?

KE5ZSKE5ZS Member
After IOS update 11.3.1 my IOS app will not connect outside of my network.  Is anyone having similar issues?

Completed · Last Updated

Answers

  • Burch - K4QXXBurch - K4QXX Member
    edited July 2018
    I can connect via VPN but I no longer see the radio with Smartlink after the update.
  • KE5ZSKE5ZS Member
    edited May 16
    I see the radio with Smartlink but it keeps going back to the page (Tap here to connect). It’s a vicious circle now.
  • Burch - K4QXXBurch - K4QXX Member
    edited May 2018
    This is the issue I usually have but since the iOS update, I just get the "Discovering" message and the circle spins but no radio is listed.
  • KE5ZSKE5ZS Member
    edited May 2018
    Well it looks as though the app needs and update now.
  • Steve G1XOWSteve G1XOW Member
    edited May 2018
    Its all Microsofts fault - stock answer
  • Ted  VE3TRQTed VE3TRQ Member ✭✭
    edited May 2018
    Yeah, Apple is just as evil as Microsoft :-) And if you use Debian or some other Linux distro, shared library incompatibilities will eventually get you. There is no escape!
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited May 2018
    I am NOT having an issue after iOS update. Everything works 100% via SSDR/iOS
  • Tony TaddeoTony Taddeo Member
    edited March 22
    I’m not having any problems with latest IOS and SSDR.
  • CharlieCharlie Member
    edited May 2018
    I have no problems on Ipad or Iphone
  • KE5ZSKE5ZS Member
    edited January 20
    My issue is on an iPhone 6
  • Terry K7NYTerry K7NY Member ✭✭
    edited May 2018
    I just tried my I6 and when I hit connect it was trying to go to smartlink. While it was spinning around I hit connect at the top and came up with the right screen to select smartsdr or smartlink.

  • WW1SS - SteveWW1SS - Steve Member
    edited April 10
    I posted on this last week. I can connect via Ipad OK but not on my Iphone X. It sees the radio via smartlink but won't disconnect or connect to it. Just goes back to the main screen.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    I have no issues using the iOS App (v2.4.1) connecting over the LAN (set to scan an IP subnet) or using SmartLink on my iPad Air running iOS 11.3.
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited May 2018
    No, definitely no issue with iOS 1.3.1 or iPhone X. What’s your mobile provider Steve?
  • KE5ZSKE5ZS Member
    edited May 2018
    AT&T, I have an iPhone 6. When I try to connect via the internet it jus keeps circling back to (tap here to connect). Also when I leave the app it disconnects regardless of where I have (prevent device sleep) on my internal network. It works fine locally on my internal network at home other than disconnecting when doing something else on the phone and it did work fine via the internet before the latest IOS update. Everything worked flawlessly before the IOS update.
  • Matt NQ6NMatt NQ6N Member ✭✭
    edited December 2019
    I have had a few cases where the IOS app will not connect to the radio via VPN or Smartlink.  Those have been situations where I have marginal internet connectivity to my phone. But it would be nice to know for sure what is going on -- why can it discover the radios correctly but then tapping on them to connect results in nothing happening (and no error message)? 
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited May 2018
    Maybe your data rate has been used up or you have a poor connectivity? In order to check if it’s the App or iOS, can you try either to connect to your radio from another network using SmartSDR for Windows or can you ask another HAM fellow to try to connect to your radio? Also, if you say the App disconnects even on your local network, this is not normal and likely caused by any issue on your local network or WiFi. Just tried the same with my iPhone 6 and 6 plus test device, all works well by the way.
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited May 2018
    These are indeed two different things and so far, there is even not much more I can display as error message. The first step is to establish a connection to the SmartLink server with it's authentication etc. The SmartLink server then tells me how to connect to the Radio so the next step is to connect to the Radio by using the information provided by SmartLink. The Radio Connection doesn’t go via SmartLink. But for this, the Radio must be reachable on that given particular IP address via TCP and UDP on the given ports and that’s what is not the case when no connection can be made. Also, UDP packets are sent back and forth connectionless so there is no lost connection Situation for instance.
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited December 2019
    I have also just added a new Chapter "SmartLink doesn’t connect properly" to the "Common issues" section of the Manual.

    73,
    Marcus, DL8MRE
  • KE5ZSKE5ZS Member
    edited May 2018
    I can connect to my radio from a different network using SmartSDR for windows.  It works fine.  The TCP and UDP ports on the app under radio info are incorrect.
  • KE5ZSKE5ZS Member
    edited May 2018
    It disconnects when the phone goes to sleep or the screen turns black.  It doesn't matter where I have (prevent device sleep set) in settings, it still disconnects,  Again I'm SmartSDR for windows everything works fine from a network at my work.  Which  is physically 30 miles from where the radio is on a different network than the radio.
                                                                                                       
  • KE5ZSKE5ZS Member
    edited May 2018
    I have good connectivity on my phone and I also have unlimited data.
                                                                                                                  Danny
  • KE5ZSKE5ZS Member
    edited May 2018
    OK so the disconnecting issue on a local lan is resolved.
  • KE5ZSKE5ZS Member
    edited May 2018
    OK so I am going to try to setup up smartlink again on my radio when I get home.  Because during discovery it shows flex-6600m (hp) instead of UPnP.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    Thank you, Marcus!
  • KE5ZSKE5ZS Member
    edited May 2018
    Problem solved, thanks for the input Marcus. It seems as though my Flex-6600m lost its TCP and UDP settings. All is well now. Marcus I love the app, thank you!
  • KE5ZSKE5ZS Member
    edited May 2018
    Problem solved, my Flex-6600m lost its smartlonk tcp and udp settings.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.