Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Waiting for Hardware Initialization (Y, K, YTS)

Jerome Lofton
Jerome Lofton Member ✭✭
edited June 2020 in Maestro

Help-desk request has just been submitted; While waiting for a reply perhaps the Flex Community also has some suggestions ... my Maestro is showing an on-screen pop-up message "Waiting for Hardware Initialization (Y, K, YTS)" after selecting version of software version during startup.

Operation appears normal up to that point. Unit even goes thru the updating software progress bar (twice), but eventually goes to the Hardware Init screen and remains with this showing. 

However, the unit does not appear to be locked up as it does perform other tasks in the background with the message showing (i.e. accessing the log-in screen link, and selecting the other Top Left/Right Radio/Version menu links and/or enter information in fields not blocked by the pop-up message. 

I let the unit sit overnight twice to see if it changed, but it did not, I have also tried rebooting it several times and also reverting from v2.0.17 to v1.9.13 software from the Version menu, but eventually it returns to the hardware init screen (these two versions of SW per present and did not require download).

No attempt was made to perform a "Factory Reset", or equivalent action.

The associated Radio is a Flex 6700, running v.2.0.19, which works fine. Also my other Maestro, running v.2.0.19, works fine with the Radio. Both Maestros were NOT being used at the same time.

Any ideas about what should I try next?

73, Jerome Lofton, WD4CWG,


  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited June 2020

    The message says that there is likely a connection problem from the main control board to the audio board.  You did the right thing to start a helpdesk ticket as that is the right next step to getting this resolved.  Sorry you are having the problem.  I'm sure we can help you get this resolved.
  • Jerome Lofton
    Jerome Lofton Member ✭✭
    edited February 2018
    Thanks for your rapid reply. I also look forward to the reply to the helpdesk ticket.
    Jerome, WD4CWG
  • Bob  KN4HH
    Bob KN4HH Member ✭✭
    edited June 2020
    Jerome, are you running the Maestro on battery power.  Every time I run on battery power and the battery gets low, I get the same error message along with others.

    Bob, KN4HH
  • Jerome Lofton
    Jerome Lofton Member ✭✭
    edited February 2018
    Thanks for the reply.

    No, typically all on the AC adapter, except on one instance where I accidentally pressed the power button as I was unpacking it before I had connected the AC adapter and it turned on and had another error indicating that the tablet was unable to start the Maestro software. It appeared that the error was being handled directly by Windows on the Maestro tablet (screen). I have not seen that error since using the AC Adapter. Hope that helps!

    73, Jerome WD4CWG
  • Ray - K6LJ
    Ray - K6LJ Member ✭✭
    edited February 2020
    Hi Jerome, Had this issue when I was in China. Of course easy for me cause I live here in Austin area. I took it in and they opened it up and found a connector loose. Took all of 15 minutes.
  • Jerome Lofton
    Jerome Lofton Member ✭✭
    edited February 2018
    Thanks for the reply.

    I got a series of things to try from the helpdesk yesterday that I am in the process of responding to today, Unfortunately, the issue remains the same. I'm also thinking that it is probably a loose connections as well, as everything else appears to work and the unit is not "locking up". It is just not completing the update.

    73, Jerome, WD4CWG
  • Mike Presnell
    Mike Presnell Member
    edited February 2020
    What was the eventual fix for this problem?  mine is looping with that message....
  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited February 2020
    Is your radio acting just like the radio in this thread? or is it looping. What were you doing when it started looping,,,would need more background
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited February 2020
    @mike - it is a hardware issue and you need to open a HelpDesk ticket.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.