Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Does anyone else have trouble toggling through filters on a M radio?

Rich McCabeRich McCabe Member ✭✭
I have a terrible time switching through filters on the new 6600m. No matter how hard I try, I often bring up the menu that shows filter width instead of toggling the filters. So apparently it is sensing rotation before the actual click.


Rich

Completed · Last Updated

Answers

  • John - AF3KJohn - AF3K Member
    edited February 2018
    Not sure I understand which menu you are trying to bring up.  Is it on SmartSDR or on the M?
  • Rich McCabeRich McCabe Member ✭✭
    edited July 2018
    M Radio front panel.  The filter knobs turn to adjust filter width with an inner/outer ring but also push to toggle through the preset filters.

    When you turn the knobs you get a menu showing that particular filter skirt sitting. Like 3 k for a filter skirt. When you press the knob it should cycle though the filters without pulling up a menu to adjust. It only does it part of the time correctly. Pressing really fast seems to work best, most of the time.

    Should not take practice and skill to toggle through filters :)
  • KC2QMA_JohnKC2QMA_John Member ✭✭
    edited February 2018
    Sounds like a debounce issue with reacting to button press.

  • John - AF3KJohn - AF3K Member
    edited July 2018
    I have what might be a related issue - its happened maybe 2 or 3  times during the first week of operating the 6600M where the AGC-T value changes up/down randomly without touching the radio. I wasn't able to replicate it at the time, but turning the AGC-T knob manually fixed it.

    While trying to replicate your situation by pressing the filter knob I noticed the AF gain value (which is on the adjacent knob with AGC-T) started to change randomly. 

    Perhaps the vibration caused by the button press is causing what we are both experiencing to happen? 

    I was able to catch some of it on the video attached.






  • KC2QMA_JohnKC2QMA_John Member ✭✭
    edited February 2018
    Sure looks like a debounce / sensitivity type issue. Also looks like the encoder update rate is crazy fast, but maybe that's a good thing.
    I hope some of these bugs are worked out real soon.
  • Rich McCabeRich McCabe Member ✭✭
    edited July 2018
    John,  I think Flex needs some/more filtering on the rotary encoders as to what should be considered rotation.  My first 6600M which flex replaced had audio issues and it would randomly popup the menu for AF gain, Mic Gain and filter without even touching the radio. I could sit back in my chair and just watch it do it.

    It appears to me that the encoder is sitting on the edge and toggling on/off making the radio think you are rotating the knob.  6600M #2 does not seem to do this however pressing the filter buttons is challenging because once again it appears to me that it is sensing rotation.

  • KC2QMA_JohnKC2QMA_John Member ✭✭
    edited February 2018
    Yes in simple terms "The Darn Things Are Too Sensitive"!
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2018
    I am just surprised there are not lots of people complaining and alpha testers did not have the issue.

    Here is my AF issue.

    https://vimeo.com/256510325
  • KC2QMA_JohnKC2QMA_John Member ✭✭
    edited February 2018

    "It appears to me that the encoder is sitting on the edge and toggling on/off making the radio think you are rotating the knob."

    Now imagine how the poor radio is trying to deal with all of the encoders miss triggering at the same time.
  • KC2QMA_JohnKC2QMA_John Member ✭✭
    edited February 2018
    "I am just surprised there are not lots of people complaining and alpha testers did not have the issue."
    Maybe this problem is isolated to just a few radios?
  • John - AF3KJohn - AF3K Member
    edited February 2018
    Sounds like I'd better put in a trouble ticket in case it is radio specific.
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2018
    That would be a good idea, and I might do the same.

    I personally don't think its hardware. I think they can fix it with software filtering of some sort.

  • John  - W8AGSJohn - W8AGS Member ✭✭
    edited March 11
    I have a Maestro and never had this problem with any of the controls. I am running the latest software. Hope it’s not a hardware problem. I have a 6600M on order.

    John, W8AGS
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited February 2018
    John, the Maestro and the radios do not share the same electronics, But now that Flex is aware of this they will look into it. If it were a hardware issue it would have been spotted even on the mock up radios.
  • Steve-N5ACSteve-N5AC Community Manager admin
    edited February 2018
    John, AF3K, this is a hardware problem that is easily remedied. You should enter a trouble ticket and we’ll get this fixed.
  • Rick  WN2CRick WN2C Member
    edited February 2018
    Rich, I have the 6400M and found that using my the tip of my finger pushing directly in it will toggle with out any problem. Although it does seem that when I first touch the knob it will change the skirt setting.
  • John - AF3KJohn - AF3K Member
    edited February 2018
    Steve - Thanks for the answer! I'll get the ticket in.
  • WayneWayne Member
    edited June 2018
    Someone else had a similar issue and it was easily remedied by removing the knob and cover and adjusting the closeness of the knobs after loosening the set **** retightening recovering and reinstalling the knob. Apparently the knobs were too closely mounted with inadequate clearance for the push operation to take place properly.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.