Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartLink and DMZ

2»

Answers

  • Ed W2MKM
    Ed W2MKM Member ✭✭
    edited February 2018
    Thanks Dave for the above .. just achieved connectivity via "Manual Port Forwarding" ... combo of dumb luck and some trial and error .. net is I first opened the port range on the secondary shack router E4200 ports 4993 to 4994 .. selected the "Both" option (TCP/UPD) and the IP address of the Flex 6400 from the shack router 192.161.1.128 ... but no joy.

    Next went to the primary xfinity router/cablemodem and did the same though I had to select the IP address of the secondary router 10.0.0.77 and opened up the same port range from 4993 to 4994 and then viola .. the test light gets to green ..

    So I grab my iPad and go to the apple store and DL the SmartSDR for iOS and open it up only to find that I now need to fork over $59.99 for the iOS app ... seriously .. what a let down ... I guess it's the harbinger of things to come .. though I'm NOT HAPPY FLEX with this ...

    Next Q is it worth it?  SmartSDR for iOS ..  oye ..
  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited February 2018
    It is worth it, and no the App is not free.
  • WX7Y
    WX7Y Member ✭✭✭
    edited June 2020
    I think Marcus set's the Price on the APP who is the author of the IOS app and Flex just supports it on there WEB site.

    Marcus is great with keeping things updated and working with bugs much better then other  IOS app authors. 

    I think if you use it, you will find it is a really well put together APP and worth the $59.99, his other add on tools are great quality as well and you may look at them if you run portable. 

    I really like the Griffin Bluetooth PowerMate Knob add on works great with the App. 

    73's
    Bret
    WX7Y


  • Ed W2MKM
    Ed W2MKM Member ✭✭
    edited February 2018
    Thanks Bill/Bret ... I DL'ed and purchased SmartSDR for iOS and attempted to get it going via SmartLink last night once I confirmed that SmartLink was working with the Manual Port Forwarding according to the diagnostic window on the Win10 desktop machine.

    I was able to connect once while on a wifi connection local to my secondary router to which the radio and Win10 desktop were connected .. but then that failed ... and I got stuck in the loop of trying various options on the SmartSDR for iOS ..

    Checked this a.m. and I'm still getting a GREEN indication on the Win10 Desktop that SmartLink is still working .. but seems that SmartSDR for iOS is having a hard time locating the 6400 or the WIn10 desktop or both ..

    Which raises another good question .. am I connecting to the IP for the 6400 via SmartSDR for iOS or the Win10 Deskstop .. obviously 2 different IP addresses, just looked and I've got the port forwarding set up for the 6400 vs. the Win10 desktop .. not sure if that is correct or not though SmartSDR on Win10 machine SmartLink Window instructs to connect to radio ..makes sense .

    Net is SmartSDR for iOS not connecting yet via SmartLink when using Manual Port Forwarding even though SmartLink on Win10 desktop reporting GREEN and SmartLink working.

    image
  • Ed W2MKM
    Ed W2MKM Member ✭✭
    edited June 2020
    Ok gents .. back to the SmartLink puzzle.  While I was able to turn the Test Light Green as indicate above via the Port Forwarding indicated in the screen shot above ... No joy on the ability to access SmartLink from the Internet coming in from my ISP Comcast/Xfinith.

    My network is pretty straightforward:

    - Xfinity Cablemodem/Router/Wifi - assigns 10.0.0.X series local IP addresses ... (I attempted port forwarding on this router as well but I'm not exactly which IP port to assign forwarding to ... suspect this is the root of my issue)

    - Netgear PoweLine AV500 - powerline ethernet adapter to get ethernet from one end of the house to the other where the shack is .. works great and I get >100 Mps through speed test, this connects the Xfinity cablemodem/router above to the device below

    - Cisco/Linksys E4200 v2 - Router/Wifi - assigns 192.168.1.X series local IP addresses.  I have the 6400 connected directly to this router (192.168.1.128), I have the Win10 PC that controls the 6400 (192.168.1.132) connected directly to this router and I have port forward forwarding for (4993-4994) for both TCP & UPD and for port 192.168.1.128 (the 6400).

    When I test the SmartLink from my local Win10 PC (192.168.1.132) I get a successful connection via the Test button.

    When I run SmartSDR for iOS locally on the Wifi connected to the E4200 router I can connect .. though not via SmartLink.

    Though when I attempt to run SmartSDR from another Laptop PC connected to the Xfinity Cablemodem router or the SmartSDR for iOS .. no joy .. just doesn't find the SmartLink or radio.

    My hypothesis is that I don't have the right Port Forwarding set up on the Xfinity Cablemodem/Router device as I'm not exactly which 10.0.0.X  IP address to assign Port Forwarding .. I don't see the 192.168.1.128 device (6400) or anything in that range (of course) but unsure if a 10.0.0.X address gets assigned for the devices on the E4200 router that is in the shack  ..

    What's my next move gents?

    Ed W2MKM
  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator
    edited March 2018
    What is the wan port IP of the E4200? In the Xfinity router you can port forward 4994 TCP and 4993 UPD to the address of the 4200. What would be easier is to put the Xfinity router in Bridge mode and just use the E4200 as a router. Doing double NATing gets complicated. Dave wo2x
  • K1SZO
    K1SZO Member ✭✭
    edited March 2018
    I agree with WO2X.

    You would be better served by setting up the cable modem router in bridge mode, but if you don't want to or can't.  The cable modem router should port forward to the to the WAN address of the Cisco/Linksys router.  Then the Cisco/Linksys router should then forward the ports as you normally would.
  • Ed W2MKM
    Ed W2MKM Member ✭✭
    edited March 2018
    Thank Dave & K1SZO, appreciate the input .. a couple of Qs and details before I start some more testing tonight/tomorrow.

    1. My what I call "Master" router, is the Xfinity Cablemodem/Router, which serves 70% of the household ethernet and Wifi needs ...  not sure if I made that clear ..

    2. My "****" router is the Cisco E4200 which serves primarily the ham shack and related goodies nearby.  This is getting "internet" from the Xfinity box, via the Netgear Powerline device and plugged into the "internet" port on the E4200 leaving 4 ethernet ports for hard wire connections to the 6400 and 2 shack computers 1 for the 5000A and 1 for the 6400

    I ask this as the suggestion above suggests putting the "Master" router (Xfinity) into Bridge mode vs. the E4200 which is counter intuitive to me .. but I've never done it .. I don't know if the Master (Xfinity) would even work properly as it is also the Cablemodem and serves up VOIP.

    I'll assume that the better option would be to put the **** (E4200) into bridge mode given it that I don't want to mess with the Cablemodem/VOIP features.

    If that's the case, what IP address do I enter into the **** E4200?  Recall the Xfinity dishes out 10.0.0.X IP addresses and the E4200 **** 192.168.1.X addresses ... 

    Once bridged will that change the addresses assigned by the E4200 from 192.168.1.x to 10.0.0.X used by the Xfinity router?

    I ask since I've taken one half hearted attempt at putting the **** E 4200 into Bridge Mode but was unsuccessful likely due to not knowing what IP address to put in .. 

    Thanks for your help and patience here gents.

    Ed

  • Ed W2MKM
    Ed W2MKM Member ✭✭
    edited March 2018

    Dave,  just checked the port forwarding on the "Master" Xfinity Router and it seems to be config'ed as you suggest .. screen shot below ...

    I also confirmed that the **** E4200 router in the shack is getting "Internet" from port 10.0.0.77, so that seems to jibe.

    Could it be that I'm setting up a range in the port forwarding or won't that matter?

    Ed



    image
  • Ed W2MKM
    Ed W2MKM Member ✭✭
    edited June 2020
    SUCCESS ... I think .. ok I've successfully got the **** router E4200 into Bridge Mode .. Dave .. thanks for your pointers on config'ing the E4200 ... 

    What I now realize is what I didn't know about Bridge mode .. and probably still don't know much .. but that is that the Master Xfinity Cablemodem/Router now assigns ALL of the IP addresses in the system along it's IP assignment scheme, and in the case of the Master Router in my system, the Xfinity, it uses the 10.0.0.X scheme vs. the 192.168.1.X scheme used by the Cisco E4200 .. so now all of my devices are served through the Master router to the **** router (now a bridge) .. and there are no longer any 192.168.1.X LAN IP addresses anywhere on the system .. I suspected this might have been how it worked.

    I also think I now have UPnP working as well as port forwarding .. at least that's what the SmartLink status says for both tests in both modes.  

    More testing to do ... the last remaining part of the puzzle is with the Cisco E4200 **** Router (now in Bridge mode) and that is that I can no longer get into the Administration functions of that device as the address was 192.168.1.1 ... which no longer exists or is addressable ... any thoughts on how to get into this admin function once in Bridge mode ...  I don't see an IP address on the Xfinity Router for this either .. 

    I ask only since I do have a couple of Wifi SSIDs configured on the **** E4200 and they are indeed working in Bridge mode .. but wondering if I want to change SSID names or other Wifi attributes like security how do I get in?

    Hats off to the SmartSDR community .. appreciate it gents .. more to come as I discover more .. 

    Thanks 

    Ed W2MKM
  • Bob - W7KWS -
    Bob - W7KWS - Member ✭✭
    edited March 2018
    Ed,

    I believe that having two routers is the basis of your difficulty plus, the group, not knowing enough about your network from the beginning has produced many suggestions that don't fit your situation. Trying to implement them has confused things for you even more. I suggest first things first. Get the things inside your LAN going first then rest. Then think about SmartLink as a second step. I think it will be much simpler to do this as a two step project.

    It seems to me that the first thing you should do is to follow your instinct and leave the cable modem/router alone. You will have to do one or two things in that device later for SmartLink but not now.

    Now for the second router, unplug it, put it in some closet and forget about it unless it can be set up as an access point for WiFi where its routing function is off and its Ethernet ports are working as a switch only. This IS NOT always Bridge mode. In my Asus there is no bridge mode but instead "Access Point" mode.

    If it can't be set up as described, in its place, use a 10/100 switch. I'd avoid a Gigabit unit for now. Flex had an issue with some of these & I don't know if a soloution was distributed or not. 10/100 is plenty for what you have described to be in use in your ham shack and they are cheap. I use this one from Amazon:

    https://www.amazon.com/gp/product/B00...

    If you need WiFi in the ham shack location, an access point works well. I use this one from Amazon:

    https://www.amazon.com/gp/aw/ya?ac=bi...

    Just plug the access point into an Ethernet port on the switch. Plug another port on the switch into your current "Power Line" connection to the router, Flex radio to a third one. The switch needs no configuration of any kind. The access point is straight forward per its manual & the defaults should work out of the box although setting it up with your own password is a good idea fairly soon.

    If you need to log your iPad or computer onto WiFi, go ahead. They should work from either WiFi devece, the cable modem/router or your new access point. Just be sure to set the new WiFi up in the iPad & computer.

    There are no IP addresses or ports for you to set in this first step of the project. All IP address you need will be automatically issued by the DHCP server in the modem's router function.

    Later, after things are working within your LAN, you need only see to it that the radio always uses the same IP address and that the two ports are forwarded for SmartLink. This only needs to be done for SmartLink. Get the thing working in your LAN for a few days first then the SmartLink will be easier as a second step in your project.

    Best regards!
  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator
    edited March 2018
    Check the client list in the Xfinity router to see what IP was assigned to the WAN port of the E4200. You should be able to log into the E4200 using that IP instead of the 192.168.1.1

    Have fun!

    Dave wo2x

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.