Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Connection Issue SmartSDR iOS on iPad

John - K3MA
John - K3MA Member ✭✭
edited June 2020 in SmartSDR for iOS
I originally posted in this thread but it was not answered so I have created a new thread.

https://community.flexradio.com/flexradio/topics/smart-sdr-for-ios-connect-problem?topic-reply-list[...

I am having exactly the same problem as Don - KB1YWL.
I have two Flex radios in two different locations with two different internet providers.
Both radios show up in Smartlink and I have no issues connecting and using them with both the PC version and Maestro of SmartSDR over Smartlink.  

However, on the iPad version I can connect and use one but the other one never opens the user interface and hence cannot be used.  Looking at the info and the Smartlink connect window the only difference I see is one is has (UPnP) at the end of the first line and the other has (HP).

Any hints on how to make the one with (HP) work correctly with the iPad app?

Answers

  • Jay Spaulding
    Jay Spaulding Member
    edited February 2018
    Sounds like you need to forward the Ports because the router isn’t letting it pass. Jay
  • John - K3MA
    John - K3MA Member ✭✭
    edited April 2018
    TU Jay but I do not think that is the issue as it connects and works just fine with SmartSDR on my laptop or computer from a remote location as well as my Maestro.

  • Greg N8GD
    Greg N8GD Member ✭✭
    edited June 2018
    Are both the iPads the same model and running the same version of iOS (preferably the latest)?  If so, then I would remove the Smartlink setup on the one with the (HP) and reactivate Smartlink on it and see if it picks up the (UPnP).

  • John - K3MA
    John - K3MA Member ✭✭
    edited April 2018
    Greg, problem exists on both a older iPad and a new iPad pro.  When I get back to the shack of the (HP) Flex I will reset it on Smartlink and see if your suggestion works.

    I cannot understand why there is this issue only with Smartlink on a iPad with this Flex and not for any other device.  It would be nice if the developer of SmartSDR iOS would chime in and provide some help and direction.
  • Greg N8GD
    Greg N8GD Member ✭✭
    edited June 2018
    You can contact the developer, Marcus, DL8MRE, via his website: http://ham-radio-apps.com/.  Scroll down toward the bottom of the page and enter your request under the "GET IN TOUCH" section.  Marcus is very responsive and helpful.
  • Mike  W1BFA in Maine
    Mike W1BFA in Maine Member ✭✭
    edited June 2020
    I just got back from my camp about 8 miles away.  I hadn't been in since last fall and at that time Smartlink was working like a champ on both the Ipad Pro and the Maestro.  I took the Ipad with me this morning and I couldn't connect.  I called my wife and had her power cycle the 6500 and I tried again but "no joy". 

    I got back here and checked the Smartlink set up and it was set for manual port forwarding and I could swear when I originally set it up it was set for auto..  I switched it to auto and ran the test button and got a fail.  I then tried rebooting the router and the 6500 and Smartlink restarted in the manual position again.  I did a retest in both auto and manual and both fail.  The only thing that has changed since November is I did the upgrade to .30 (still there) and the Smartsdr is current on the Ipad.  Both routers are linksys EA6350's and internet etc. is working fine on each.

    Going back to camp in a while and I will also take the Maestro and maybe the laptop and try those.

    Headscratching!   thanks  Mike W1BFA


  • Mike  W1BFA in Maine
    Mike W1BFA in Maine Member ✭✭
    edited June 2020
    Update... while at home I rebooted the home router and was able to access the 6500 both using the local lan and smartlink options with the iPad. I’m at the camp now and was able to connect via Smartlink on the second try... first one timed out but second attempt was “like buttah”. I’m as happy as I can be without knowing what the problem was.. hate that. In my working life I always needed to know what was broken and how you fixed it to be complete clearing a problem. Mike W1BFA

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.