Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

T-Mobile Wireless Hotspot and Maestro

John - K3MA
John - K3MA Member ✭✭
edited December 2018 in Maestro
For the first time I tried to connect my Maestro to my T-Mobile Aristo phone using the phone as a wireless hotspot.  The phone as a wireless hotspot works with other devices without issue.

The LG-Aristo hotspot shows up on the Maestro WiFi network available list.  When I try to connect to it from the Maestro I get the wireless password selection box.  I type in the correct wireless password and it goes blank for a few seconds and then comes back to the same password selection box.  I have tried changing the password but still I cannot log into the T-Molbile LG-Aristo mobile wireless hot spot.

Does anyone have a similar problem or any suggestions on how to get a connection to the hotspot?


  • John Pfeifer
    John Pfeifer Member
    edited February 2018
    I had a similar issue when connecting to my openspot but I have consumer cellular, I ended up turning on the blue tooth in the cell phone and wala it connected
  • John - K3MA
    John - K3MA Member ✭✭
    edited June 2018
    I discovered that changing the security protocol from "WPA PSK" to "WPA2 PSK" worked,  Connection good with no issue.  TU. 
  • David Marotti
    David Marotti Member ✭✭
    edited May 2018
    John, I have the same problem with my iPhone.  Although it worked before.  For some reason the hotspot no longer works.  Now I have the exact same problem you described in the message above.  Where did you change the security protocol?  I can't find that on the Maestro.  David.
  • John - K3MA
    John - K3MA Member ✭✭
    edited May 2018
    David, it was a setting on the TMobile Hotspot in Android.  I do not have a iPhone so I cannot offer any help on what to do in this case.
  • W9WLX_Chuck
    W9WLX_Chuck Member ✭✭
    edited December 2018
    Be sure there is no apostrophe in the network name.  Some iPhones do this by default.  The network name is the same as your phone's name.  If you have an apostrophe in the network name, you can change your phone's name and remove it by going under Settings>>General>>About.  Tap the name and remove the apostrophe.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.