Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Corrupt download / unable to update - Win10, SSDR 2.1.30

Rob Salsgiver
Rob Salsgiver Member
edited December 2019 in SmartSDR for Windows
Win10 x64 system, SSDR 2.0.19 previously installed and working with 6700.  Downloaded v2.1.30.

1st attempt - Tried to install from download file and received during file unpack a "source file is corrupted" warning when trying to unpack "C:ProgramDataFlexRadio SystemsSmartSDRUpdatesFlex-6x00_v2.1.30.103.ssdr".  Aborted installation and retried with antivirus disabled and received same warning.

Deleted install file and re-downloaded

2nd attempt - Same warning during install.  Figured (incorrectly) that it was an SSDR program update that was being done after install and (I)gnored it and rest of install progressed fine.  Started SSDR and it came up fine.  Went to (U)pdate the radio and the update file was missing (above error message now made more sense). 

At this point I'm not dead in the water because my previous 2.0.19 version of SSDR still connects to the radio and works fine.

Any suggestions on how I can get the (radio) update file and finish the update to 2.1.30?

Rob - NR3O


  • John K4SQC
    John K4SQC Member
    edited January 2018

    This is just a WAG but try shutting off Windows Defender.  As a "feature" it will remove from a download any file that it thinks is a virus and never tell you what it has done nor give you a chance to stop it from doing it.  It only shows up when you try to install or in some cases run the program.  The JTAlerts listserve is full of people having similar issues.  Like I said, just a guess but that is the first place I would look. The last couple of Win10 updates have really been raising cane with downloads.

    John K4SQC
  • Mack
    Mack Member ✭✭✭
    edited March 2019
    Try turning off your antivirus software and downloading the file again. I’ll bet it works.
  • Neal_K3NC
    Neal_K3NC Member ✭✭
    edited February 2018
    I talked with a 6300 owner yesterday that was having this happen using Webroot A/V. I use the same software and had no issues with downloading 2.1.30 so I suspect its something else (or in conjunction with Webroot).
  • Rick Hadley - W0FG
    edited January 2018
    Neal, since you're the computer expert; any idea why the January cumulative update won't load on this Toshiba laptop?  I've tried it several times and always wind up having to go back to an earlier restore point.  The error message seems to indicate an inacessible boot drive, but obviously that's not the case since it restores OK.
  • Neal_K3NC
    Neal_K3NC Member ✭✭
    edited January 2018
    I have seen this happen when either removing/replacing a hard drive or you have a drive with an old Windows folder. By the way, if you decide, for instance, to go to a SSD instead of a hard drive and clone your old hard drive to the SSD and then boot from the SSD, Windows has a nasty habit of remembering that there is a Windows folder on the old drive (if you keep it in your system. Then it views it as a dependency, kind of like a secondary windows  location. If you clone a windows system to another drive and want to use the old drive, format it right after verifying the new drive works correctly.
  • NX6D Dave
    NX6D Dave Member ✭✭
    edited December 2019
    Let's find out if you are getting the right bits.  The SHA256 hash of the installer is:


    You can calculate this value by starting Powershell, then use "ls" and "cd" commands to navigate to the directory that contains the downloaded file.  Then run the "get-filehash <filename>"  command.  The default is to calculate the 256 SHA1 hash.

    If your value doesn't match the above, your file is corrupted.  If it does match, then it is an installation problem and at least it is somewhat narrowed down.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited February 2018
    I have seen this problem before where if you try to download the program to a different PC on your network, it works fine.  If you have another PC you can try that.
  • Rob Salsgiver
    Rob Salsgiver Member
    edited February 2018
    SOLVED - Ironically all I had to do was look back to the last time I had almost exactly the same problem (sigh).  As Tim mentioned above, it worked fine when downloading to a different PC.  The other difference I've found is that the PC that has worked both times is directly connected to indoor WiFi/cable.  The PC(s) having the problems are out in the hamshack, where the WiFi signal has periodic TCP ping timeouts - not enough to drop the connection, but obviously enough to corrupt the download.  I never have a problem with email or web pages loading, or even doing file copies across that link, but this is now twice where my Flex downloads have been corrupted.  Downloading them in the house and manually copying them over that same link and installing in the shack works fine.  Downloading in the house to USB and then installing in the shack also works fine.

    The other irony is that I installed 2.1.30 on the house PC with no problems, and the house PC updated the radio (in the shack across the lower quality link) just fine with no errors.

  • Rick Hadley - W0FG
    edited February 2018
    That's probably it, since I did have a new SSD installed, to replace the failing HD, a few months ago.  Is there a way to fix the problem now that the HD is gone?


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.