Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

PowerSDR "no device found"

Steve G1XOW
Steve G1XOW Member ✭✭
Hi All,

Just picked up a used Flex 3000 for not too much money, but can't get it to see the radio as a device. Long time since I played with these old firewire based radios, but I have hit a brickwall with this one.

Installed v2.7.2 okay. Installer ran fine, rebooted. Scan utility reports that the FW card is seen and is compatible, but also states "no devices found". I am doing something wrong or missing a step?  The FW card looks good, and I tried another card just to be sure, but can't get it to see the radio at all.  Tried powering down/up the radio a few times but nothing.

I understand the device drivers are now integrated on these later PSDR versions, so what else could be wrong?

Windows 10c 64 with all updates, applied. Installed ran as admin right and no issues.

Here is the report from the scan utility...

  CPU(s):
    Processor:  Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
    Physical:  1
    Cores:     4
    Logical:   8
    L1 Cache:  32 KB   (8)
    L2 Cache:  256 KB  (4)
    L3 Cache: 8192 KB  (1)
  Installed RAM: 24256 MB

Looking for OHCI 1394 Host Controllers...
1:
  Vendor : (104C) Texas Instruments
  Chipset: (8235) XIO2200A
  Revision: 01
  Status :  Active
  Details:
    Subsysten VendorId: 5678
    Subsystem DeviceId: 1234
    Max # isoch Rx contexts: 4
    Max # isoch Tx contexts: 4
  Max 1394 Speed Capability: S400
  Support:  Compatible, no known issues.
Done.

Comments

  • VE7ATJ_Don
    VE7ATJ_Don British ColumbiaMember ✭✭✭
    edited July 2019
    Are you sure the cable is ok?
  • Larry _ NY8T
    Larry _ NY8T Member ✭✭✭
    edited July 2018
    This may not even be applicable with the firewire setup but is it at all possible a firewall  is blocking something?
  • Steve G1XOW
    Steve G1XOW Member ✭✭
    edited May 2020
    Guys i forgot to say i just did a fresh install of w10c without any updates or antivirus/firewall installed but that did not help either. Tried 3 FW cards now and 2 cables. When i click the master box on the driver util i just see "no choices" Is there a known problem with psdr drivers etc on w10? Guess i will have to try w7 next...
  • JDE
    JDE Member
    edited January 2018
    Just in case... And just to cover all bases, the simplest question must be asked.

    Was the 3K power "ON", and in a steady state before starting PSDR? If so, then just ignore this message and say it was a **** question. BUT! It can't hurt to ask anyway.
  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited February 2018
    Steve, I am a bit stumped on this, I have never seen this with my Flex 3000. I was using Win 7.
    Unless Win 10 is the problem. From what I see here it should just work.
  • Todd
    Todd Member
    edited January 2018
    Try this: Go to the Flexradio website / Knowledgebase and lookup "Legacy Firewire driver" or just google "Flexradio Legacy Firewire driver" and follow what is suggested. This can be a problem in win7,8, 10. I hope that helps
    73, Todd K1OD
  • Sasi VK5SN
    Sasi VK5SN Member
    edited January 2018

    Just to discount the issues with PSDR you may want to try and run KE9NS PSDR https://www.ke9ns.com/flexpage.html as a standalone installation. I run this on Win10 with antivirus and all the security and never had an issue.

    It pays to check the firewire cable as well

    73, Sasi

  • Wayne
    Wayne Member ✭✭
    edited June 2018
    goto the ke9ns site and do all the steps for running windows 10 by his windows 10 narrative.u
  • Dan -- KC4GO
    Dan -- KC4GO Member
    edited March 2018
    Did you see the 3000 working prior to purchase?
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited January 2018
    The firewire based radios do not have to be powered on before starting PowerSDR.  once powered on, if the PC can detect the radio, it will show up in the chooser.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited May 2020
    A few things.  First, I am going to assume that the firewire interface in the 3000 is good.

    One, we have been seeing a high incident rate of Win10 PCs not working well with Firewire cards.  Even though they are shown in Device Manager and the FLEX Firewire driver recognizes the card, there is difficulty connecting to the radio.  We do not know exactly why this is happening, but we suspect that changes to the Win10 1394 bus driver have produced some incompatibilities.

    I ran across some information recently where it provides instructions for installing the older legacy 1394 bus driver from Win8.  These drivers are applicable to Win10 too.

    https://support.microsoft.com/en-us/help/2970191/firewire-port-based-device-does-not-work-correctly-...

    If you decide to do this possible fix, I highly recommend creating a restore point before installing the legacy drivers.

    Also, it used to be that we recommended only TI based Firewire cards due to their compatibility and performance.  However, we have seen that VIA based cards seem to work better with Win10.  Go figure.

    One other thing that could be a possible issue is that newer computers have overclocking capabilities enabled by default.  If the PCIe bus timing is too fast, the card may be recognized, but cannot effectively transfer data, which is required when PowerSDR initializes; it reads the radio's EPROM for radio data.

    Lastly, it could be a firewire cable issue.  They can result in the same issues that prevent data from being reliably transferred from the card to the radio. 

    Now, if all these issues are addressed and you still can't connect, then I'd start to suspect that the radio's Firewire interface is faulty and the radio will need to go to a service center (Germany in your case) to have the radio checked out and repaired if possible.
  • Steve G1XOW
    Steve G1XOW Member ✭✭
    edited January 2018

    Hi Tim,

    Thanks for the input on this. I think I have knocked down all the possible causes now.

    I have tried 3 FW cards, all are TI chipset, and reported as okay by driver package, 2 were PCI and one was PCie with separate PSU connection. I also tried 2 good quality FW cables. Tried it on two 2 PC hardware platforms, with both W7 and W10c still nothing. I also tried the legacy driver.

    When I power-up the radio I get the blue light on, I hear one relay click once, then nothing. I can see a small LED inside the hole near the FW socket, but that is it.

    There are very few diags available for this problem, so I am left with intuition and guesswork. My best guess therefore is that the f3k is simply not TXing out that initial string on the FW port but think I have exhausted all the reasonable options.

    The radio is now going back to the seller for testing/verification. It was said to be working 2 weeks prior, however I did not see it working myself.

    Recently sold both of my F6500s, so this 3k was just to keep my hand on the tiller!

  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited January 2018
    There should be 2 clicks close together on turn on.
  • Steve smith
    Steve smith Member
    edited February 2018
    I had the same thing happen to me....found out it was a bad firewire card. The one I had was brand new but the radio could not communicate with the computer....so I got a new firewire card and that solved that problem.


  • Steve G1XOW
    Steve G1XOW Member ✭✭
    edited February 2018
    Thanks for confirming the 2 clicks Bill - that confirmed an internal POST failure inside the radio. Sent back to seller and got refunded. Shame really as F3k and F5k are pretty rare. So, I am now hunting for another one within EU.

  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited February 2018
    That's too bad Steve, I had mine on air for 12 years. I still have it as a back up. I always thought for the price, the 3000 was a great **** for my buck.
  • Craig Williams
    Craig Williams Member ✭✭
    edited February 2018
    I bet the seller knew the radio had a problem.
  • Steve smith
    Steve smith Member
    edited February 2018
    Here is what I figured out was the problem when the PowerSDR 2.8 would not allow recognition of the 3000.  I run WIndows 10 Pro......It was the Fire Wire card. The one I got from MicroCenter was compatible but was faulty. The card was not communicating with the radio and so the  Flexradio software told me that the card was not communicating. I did not see Windows 10 tell me that the Flex3000 was even there which it will do if everything works right. There are a few fire wire cards that are not compatible with Flexradio. I would check with Dudley at Flexradio on this problem. He was a great help in figuring out that the Firewire card was bad.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.