Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Smartsdr for iPad frequently has audio fall outs

James Madden
James Madden Member
edited December 2019 in FLEX-6000 Signature Series
Smartsdr for iPad has audio fade out issue


  • Ria
    Ria Member ✭✭✭
    edited November 2019
    A lot of factors could be at play:

    Older iPads don't handle it all that well. Consider one of the new iPads or iPad pro

    Wifi varies. Try to get 802.11ac with a good signal. Marginal wifi won't cut it. 802.11n will work but if it's weak it won't be reliable.

    If you're using SmartLink, consider what router you are using. Some of them increase bufferbloat which can use problems with streaming. Also if you're on a cellular connection it may not work well if you're on a congested cell site or have weak signal.


  • Phil Stephenson
    Phil Stephenson Member ✭✭
    edited June 2018
    I'm using an iPad Air 2, and the IOS SmartSDR app performs as expected except when using the iPad 's audio. The iPad audio is intermittent. If I choose any other audio option the audio performs perfectly.

    I have plenty of WIFI bandwidth fed by ATT fiber 1000 gb.so I just don't think that bandwidth latency is at issue. No other apps are running and the only resource constraint I could imagine would be the processor but I would think that the heavy lifting would be for the UI logic and not the audio, Is there a configuration parameter I should be looking at? 

  • Ted  VE3TRQ
    Ted VE3TRQ Member ✭✭✭
    edited December 2019
    Are you in an area where there is any WiFi congestion? And are you using 2.4G or 5G WiFi? 2.4G is especially bad if there is contention of any kind. 5G handles it much better, although signal levels may be lower at distance. Might be an idea to do an RF survey in your WiFi frequencies.
  • Phil Stephenson
    Phil Stephenson Member ✭✭
    edited June 2018
    I'm three feet from the access point and I tune the 2.4Ghz and 5.0Ghz channels for an optimal reception based on other close access points but at this range, it's not an issue. I am connecting to the 5Ghz radio. I suspect bandwidth would be an issue if I were remote and on a lower bandwidth WIFI connection. I just find it confusing that the app behaves well in all other respects, the panadaptor and waterfall are both smooth and behaving as expected and it tunes well. but the iPad audio is the only issue. I see recommendations to switch to iPad Pro but the app's developer hadn't listed any minimum resource requirements so I still am not sure what minimum memory and processor resources might be required for complete operation of the app. I do understand why bandwidth would be a huge consideration but I really think a lack of bandwidth would more likely manifest itself as overall poor performance and not just audio. I am now concerned about operating remotely in situations where bandwidth is not optimal. 

    Thanks for your response - BTW, that's a really cute boy in your avatar photo :)
  • Charlie_KB8CR
    Charlie_KB8CR Member ✭✭
    edited June 2018
    I'm getting similar results in the same room as my router. (iPhone X) Interestingly, when out in public on LTE, it works great.....but that's not great for the data plan. 
  • Kevin - K4KWB
    Kevin - K4KWB Member
    edited June 2018
    Mine had a setting in the router, under the wireless side that caused mine to act that way.
  • Manuel Maseda
    Manuel Maseda Member ✭✭
    edited May 2019
    I had a similar issue. Turned out it was the Wi-Fi link between my iPad and my wireless router. The problem would come and go. I changed out and relocated the router but I would still occasionally get audio dropouts. I finally just hooked my iPad directly to my router using an Ethernet to Lightning adapter. Performance is significantly better and never had a single dropout.
  • Charlie_KB8CR
    Charlie_KB8CR Member ✭✭
    edited June 2018
    Do you remember what that setting was? 
  • Kevin - K4KWB
    Kevin - K4KWB Member
    edited June 2018
    I will look when I get home.
  • Kevin - K4KWB
    Kevin - K4KWB Member
    edited June 2018
    From what i can tell is that i turned the wireless from Mixed mode to G (2.4) and A (5)
  • Charlie_KB8CR
    Charlie_KB8CR Member ✭✭
    edited June 2018
    Thanks, I tried, but no change. It's better....but still cuts in and out on AF. I tried slowing the waterfall down (I thought selecting "low bandwidth mode" would do that, but it doesn't) and it helped some too.

    Thanks again,

  • Craig Williams
    Craig Williams Member ✭✭
    edited December 2018
    I just upgraded from an iPad 4th generation, the minimum model the developer says will work, to a 2018 iPad. I still have "stuttering" on my audio about 10% of the time. I am a retired IT Consultant and believe my wireless system is setup correctly. Same problem when running the WiFi iPad with an ATT wireless access point. My iPhone 6s+ running direct to the cell site and a Windows 10 through the ATT access point seem the most solid. Since I am and old hardware guy I don't have a clue about programming but you would think something can be done to improve this problem many of us seem to be having. But, still love using the Flex remote.
  • Dave - N6XVZ
    Dave - N6XVZ Member ✭✭
    edited September 2019
    It's the iPad-wifi-application trio.  For example when I run it on my iPad on the work WiFI I have no drops.  At home it's a beating and useless.  I've tried most of the tricks.  The one that seemed to help the most is to reset network on the device.

         Settings ->General -> Reset -> Reset Network Settings.

    Required me to re-enter my credentials for any wifi networks I use regularly but gave me life again.  Occasional stutters but 95% better.

    With the newer iPads I seriously doubt it's CPU hardware.  Something about the wifi of some networks with home ones and low volume (ie: Hotel) being very suspicious in ability to feed the app.  When I run on my phone via Verizon LTE (and good coverage) I have no problems as well.

    I really do wish this could be overcome; it's very cool to run the radio when remote and with an iPad/iPhone but wifi is problematic and noticeable.  It seriously degrades the value of the software if we can't reliably use it as an option for the radio interface.

  • Dave N6XVZ You are a life saver. I tried many fixes and your recommendation seems to have bailed me out. Whew, Wow , Thank you TU TU!:  "Settings ->General -> Reset -> Reset Network Settings. Required me to re-enter my credentials for any wifi networks I use regularly but gave me life again." 2021-07-15 KB4FHA Bruce
  • John WA7UAR
    John WA7UAR Member ✭✭✭

    It’s also possible to use wired Ethernet using an iPhone or iPad. It’s takes an adapter but it is possible. Maybe that will help some who are willing to use that as a necessary option when WiFi is difficult on the road.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.