Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Fix for Cisco Meraki wi-fi and iOS connectivity

Paul StaupePaul Staupe Member
edited March 2019 in New Ideas
I ran into an interesting problem when I upgraded my home network to a Meraki firewall, switches and APs.  For anyone who has a Cisco Meraki home network with a Meraki MX security appliance, the wireless clients will default to a cloud based Meraki owned 10.x.x.x/8 DHCP subnet to insure that there is no connection between wireless clients.  This is an added safeguard in a commercial environment.  Although the wireless 10.x.x.x/8 subnet communicates with the home LAN based 192.168.x.x/24 subnet there is some firewalling. In my case, I could change the frequency of the Flex 6500 and see the display but couldn't see the waterfall or hear sound.  The fix was to select "All clients on LAN DHCP " vs. wireless clients using Meraki DHCP.  This puts all clients on the same subnet and now my iPad works as a remote control for the Flex 6500 just fine.

Comments

  • K1DLMK1DLM Member ✭✭
    edited January 2018
    Paul - I have dealt with many of these issues for years myself, as I use a Fortinet Firewall at my home with (5) Fortinet AP's.  To make it easy for hams to use the radio with minimal networking expertise, FRS uses a zero-configuration networking mechanism.  In order the the SmartSDR client to discover the radio, it must be on the same subnet, and the network must allow visibility between clients.  The new SmartLink functionality might be used to overcome this limitation, depending on your setup. 

    I would love for FRS to allow us to assign IP Address information manually on the radio and the client, but I don't think this will be happening anytime soon.

    73,

    Dave
    K1DLM

  • Mark G ThomasMark G Thomas Member ✭✭
    edited March 2019
    The option to specify the radio's IP on the SmartSDR Windows/Maestro client would be an extremely desirable feature for a bunch of us. I've said it before. I'm all for providing as default the zero-configuration networking support, but do not understand how adding this OPTIONAL ability can be such a tremendous implementation hurdle.

    In another post, I believe I saw one can specify the target radio's ID on the SmartSDR Command line (provided it is still on the same subnet). How would specifying the radio's IP address be much different? I am dismayed and put-off by FRS prior negative responses regarding this request; it has tainted my view of an otherwise-spectacular product line.

    Fortunately the IOS Flex Radio client absolutely DOES support specifying the target radio IP (required to work via IOS Native/Cisco VPN), so works easily from an alternate subnet, such as via many WiFi, non-broadcast VPN, LAN, and WAN networking scenarios.

    Mark Thomas
    KC3DRE
  • edited January 2018

    I do not understand why Flex does not follow conventional UX principles on this. People have been asking for this for years.

    Basically default to the zero-config setup, this satisfies most users. Then add an option in a spot that is not obvious for novice users that allows for advanced configurations. Even put a warning the advanced settings can cause the universe to divide by zero and other related problems that could make support difficult.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.